Defective Parts Listing - Page 4 - Ford Bronco Forum
 13Likes
Reply
 
LinkBack Thread Tools Display Modes
post #61 of 107 (permalink) Old 02-24-2012, 06:32 AM Thread Starter
Moderator
 
miesk5's Avatar
 
Join Date: Oct 2003
Location: NJ
Posts: 17,208
Bronco Info: 96 Bronco XL 5.0 E4OD, Man Xfer/Hubs
iTrader: (2)
Garage
So it turned out that autozone sold me a faulty TPS. I've returned it and bought a motorcraft one. No more problems so far.

Thanks,

JRoo 02-21-2012, 11:29 PM
http://www.fullsizebronco.com/forum/21-noobie-bronco-tech-questions-flame-free-zone/204836-engine-races-idle-very-poor-drivability.html

See my partially recovered Bronco web site ...Will need to clean up dead links & add many more new links some day. Thanks to Mr. Schwim!
THANKS to ALL WHO SERVE!
miesk5 is offline  
Sponsored Links
Advertisement
 
post #62 of 107 (permalink) Old 04-01-2012, 09:24 AM Thread Starter
Moderator
 
miesk5's Avatar
 
Join Date: Oct 2003
Location: NJ
Posts: 17,208
Bronco Info: 96 Bronco XL 5.0 E4OD, Man Xfer/Hubs
iTrader: (2)
Garage
by aquaholic33
@ http://www.fullsizebronco.com/forum/21-noobie-bronco-tech-questions-flame-free-zone/206828-muffler-looking-input-sound-clips-suggestions.html
"...I ran into a small problem @ the autopart store being I have 3" pipe. I stopped by 4 different stores (all around town) and only oreiily's had 1 muffler in stock with a 3 in and 3 out and it was the thrusher. I said woody the wood pecker wouldn't do me wrong so for the 28 bucks I bought it.It a 2 chamber. So i hooked it up ran a pipe out to the side of the truck just before the rear tire. 30 minutes later I was done not expecting the tone and sound I got from this cheap little muffler. CAN you SAY WOW. It has a great tone at idle sounds mean sounding when you get on it but the cool thing is at 55 60 mph no exhaust drone. I'll post a clip. Miesh5 do you have any data on this muffle thrush 2 chamber.I got the stainless from the zone. (only muffler anybody in my area had that was 3" in and out. But cheap you buy cheap you get.less then 2 weeks later and it is cracked at the seams. On both the inlet and out. Cut that crap off got my refund and driving open pipes till my magnaflow comes in..."

See my partially recovered Bronco web site ...Will need to clean up dead links & add many more new links some day. Thanks to Mr. Schwim!
THANKS to ALL WHO SERVE!
miesk5 is offline  
post #63 of 107 (permalink) Old 04-01-2012, 03:14 PM
Fullsize Member
 
JScatt's Avatar
 
Join Date: Jan 2010
Location: SoCal
Posts: 5,108
Bronco Info: 1995 XLT 351W, 2.5 R/C Lift,4.10's, Rancho Extended R/As, 33's, Punisher Valve Body
iTrader: (2)
Dorman or Pioneer Inc accelerator cable, made close to original but not nearly close enough.
Any Duralast product is junk, a lifetime warranty really doesn't mean a product is better, they just know most people don't keep receipts.
PJCHANNING likes this.

No bum that can't speak poifect English oughta stay in this country...oughta be de-exported the hell outta here!"

-Archie Bunker

bron∑co/ˈbršNGkō/
Noun:
A wild or half-tamed horse, esp. of the western US.
JScatt is offline  
post #64 of 107 (permalink) Old 06-05-2012, 12:37 PM
Registered User
 
Scotty2hottie's Avatar
 
Join Date: Mar 2012
Location: pensacola, fl
Posts: 100
Bronco Info: 96 eb 351w
iTrader: (0)
cardone Part No. 30-2700

replaced due to bad PIP in oem. truck wouldnt idle with spout in only out. returned due to being defective and got another on one. #2 worked like a charm.

1996 EB 351w
6" lift, 35 km2s, spartan locker, warn manual hubs, extended breathers, taurus efan, 6 litre tune up, and dana 50 slip shaft.
Scotty2hottie is offline  
post #65 of 107 (permalink) Old 06-05-2012, 07:44 PM
Registered User
 
86beast's Avatar
 
Join Date: Feb 2008
Location: oroville ca
Posts: 1,649
Bronco Info: 1986 Bronco XLT 5.0 EFI 4x4
iTrader: (0)
Quote:
Originally Posted by pfun41 View Post
C:\DOS\
C:\DOS\RUN.EXE
INITIALIZING....................
GETFILE MIESK5\THREADS\PARTS\
SETTITLE "YO"



TPS autozone.. but then the name of the business says it all.

Quote:
Originally Posted by JKossarides View Post
easy answer, it's never that simple with a Bronco as we've all learned.
"Better to be thought a fool then to open your mouth and remove all doubt" -My Grampa quoted to me once
86beast is offline  
post #66 of 107 (permalink) Old 11-23-2012, 02:14 PM Thread Starter
Moderator
 
miesk5's Avatar
 
Join Date: Oct 2003
Location: NJ
Posts: 17,208
Bronco Info: 96 Bronco XL 5.0 E4OD, Man Xfer/Hubs
iTrader: (2)
Garage
yo,
oil pressure sender (switch) in a 96 5.0;
Thanks Got it fixed
it was the new switch it must have been a faulty one i got it from autozone so that explains lol i found a new one laying in my garage which was an identical match to the factory one that came out of my truck poped that sucker in and works like new lol.
by gearheadmike @ http://broncozone.com/topic/23480-damn-oil-pressure//
23 NOV 12
========

See my partially recovered Bronco web site ...Will need to clean up dead links & add many more new links some day. Thanks to Mr. Schwim!
THANKS to ALL WHO SERVE!
miesk5 is offline  
post #67 of 107 (permalink) Old 11-23-2012, 02:24 PM Thread Starter
Moderator
 
miesk5's Avatar
 
Join Date: Oct 2003
Location: NJ
Posts: 17,208
Bronco Info: 96 Bronco XL 5.0 E4OD, Man Xfer/Hubs
iTrader: (2)
Garage
yo,
by hizootiemizark 95 XLT 5.0; Get a Motorcraft PCV when you replace it. I got a cheap one from the Zone that was crap.
http://www.fullsizebronco.com/forum/21-noobie-bronco-tech-questions-flame-free-zone/215469-light-gray-smoke-when-downshifting-pulling-hill.html

See my partially recovered Bronco web site ...Will need to clean up dead links & add many more new links some day. Thanks to Mr. Schwim!
THANKS to ALL WHO SERVE!
miesk5 is offline  
post #68 of 107 (permalink) Old 02-01-2013, 10:43 AM Thread Starter
Moderator
 
miesk5's Avatar
 
Join Date: Oct 2003
Location: NJ
Posts: 17,208
Bronco Info: 96 Bronco XL 5.0 E4OD, Man Xfer/Hubs
iTrader: (2)
Garage
Airtex Review; "...so as some know my monte carlo has gone threw 6 fuel pumps this year.....
by yoomooman at F**K AIRTEX
today the 6th took a xxxso i dropped the tank and warrentied it out for another free airtex......2 hours later the tank is back in the car i turn the key to prime it an nothing, try to start it an nothing......tested fuel pressure an nothing, tested voltage which checked out 12.5v at the tank.....

so in a fit of rage i drop the tank again went back to advance an got into a yelling match with the store owner who originally pushed the cheaper pump on me last year....i demanded my money back and told them if they have any decency they would drop the Airtex brand like napa and carquest have an stop ripping people off.......he refunded my money an i bit the bullet on the $90 bosch with a new strainer an filter.....went home an had to cut solder an heat shrink the new bosch harness to the sending unit, installed everything an rite off the bat i have much better pressure then the cheap f*ckin Airtex brand and NO ANNOYING SCREAMING/WINEING PUMP NOISES

i also opted out of using the rubber insulater that they recommend putting over the pump to quiet it which i suspect was helping overheat the old pumps by insulating them an not allowing the fuel to cool them properly....i mean hell the OEM pumps you pull out of the tank dont have them so i didnt put it on this time

the new bosch pump is so damn quiet you cant even hear it prime before you start the car but my pressure guage comfirms it is priming and has great pressure it also holds the pressure indefinetly unlike the Airtex with the fualty check valves, impellers that round out in a couple months and scream so loud you cant even drown it out with the radio

i called airtex and they claim theyre quality is among the best so much so they have contracts with certain auto makers that use the pump as OEM from the factory....BULLSHYT!!!

well after a long day of BS i just had to put this rant out there and warn people DO NOT EVER BUY THE CHEAPO AIRTEX BRAND or youll be sorry you did, spend the extra $20-$30 dollars for a bosch, acdelco, delphi or some other well known brand



all in all im extremely happy with the bosch, ill just have to kick back an see how it does, total out the door for the pump, strainer, and filter was $105.07 out the door, i may have got hosed after looking at online prices on ebay an stuff but i needed the pump now so my pregnant wife could get to work tomorrow, also if that $107 is what it takes for me to never drop that tank again then so be it, after 7-8 times droping the tank an this time it had a half tank of fuel in it since the pump wouldnt work an there is a little ball in the filler to prevent siphoning im done with it....

this time i did it rite the only thing i didnt replace was the relay which i will be getting tomorrow

sorry for such a long rant but im totally done with those cheap a$$ Airtex pumps...

See my partially recovered Bronco web site ...Will need to clean up dead links & add many more new links some day. Thanks to Mr. Schwim!
THANKS to ALL WHO SERVE!
miesk5 is offline  
post #69 of 107 (permalink) Old 02-01-2013, 11:36 AM
my bko ate my money
 
yoomooman's Avatar
 
Join Date: Apr 2008
Location: hudson, FL
Posts: 2,336
Bronco Info: 92 Eddie Bauer Bronco 5.0, E4OD,MAF Conv, sixltre tune-up, OBA, on 31x10.50x15s
iTrader: (2)
gotta get the word out there


92 Eddie Bauer bronco 5.0--Travis

Quote:
Originally Posted by jopes
11:47 pm: hand pack it on the shaft. it's something you should be good at
Quote:
Originally Posted by yoomooman
some bucks is better than no bucks!
yoomooman is offline  
post #70 of 107 (permalink) Old 02-01-2013, 11:51 AM
Thread Killa
 
jowens1126's Avatar
 
Join Date: Jan 2011
Location: Orlando, FL
Posts: 8,697
Bronco Info: 1994 Bronco Eddie Bauer edition, 302 MAF, E4OD
iTrader: (2)
Four Seasons A/C Hose is JUNK. The pressure relief valve does not hold up at all. Keeps popping off. Get a motorcraft YF2223 instead. Twice the price, but at least it works. And the Relief valve is able to be changed without changing the hose.

1994 EB Bronco, 302 MAF, E4OD, BW1356, Slightly Customized Interior
"Demanding something free on top of a discount is just being a Democrat. - Steve83"

My Build Thread - http://www.fullsizebronco.com/forum/...d.php?t=191067
jowens1126 is online now  
post #71 of 107 (permalink) Old 04-27-2014, 09:28 AM Thread Starter
Moderator
 
miesk5's Avatar
 
Join Date: Oct 2003
Location: NJ
Posts: 17,208
Bronco Info: 96 Bronco XL 5.0 E4OD, Man Xfer/Hubs
iTrader: (2)
Garage
yo,
Vehicle Speed Sensor (VSS); also called RABS Sensor & Differential Speed Sensor (DSS) Defective; "... The VSS was probably working fine the entire time (except the DOA Vatozone ones)..."
by arse-sidewards at Another bouncing speedo....

See my partially recovered Bronco web site ...Will need to clean up dead links & add many more new links some day. Thanks to Mr. Schwim!
THANKS to ALL WHO SERVE!
miesk5 is offline  
post #72 of 107 (permalink) Old 10-03-2014, 05:48 PM
Registered User
 
AxlesofEvil's Avatar
 
Join Date: Nov 2006
Location: Mesa, AZ
Posts: 238
Bronco Info: 96 351W E4OD SAS Leaf Dana 44/Spool Front, Dana 60FF Rear, 4.88 gears
iTrader: (0)
Quote:
Originally Posted by miesk5 View Post
yo,

Went to Autozone and got a new water pump - It failed 2 months later -
Replaced it with one from NAPA

Went to Autozone and got a new fan clutch - sounded like a B52 bomber taking off when it kicked in - Replaced it with one from NAPA

Went to Autozone and got a new belt tensioner - the fooker sqeaked loudly-
Replaced it with one from NAPA
"
I have the same problem with the Vatozone fan clutch on my bronco, and my friend's F250.

My belt tensioner has the bearing noise of a supercharger. I'll keep it on there until it seizes and blows through my hood, then I'll buy a supercharger.

The water pump has also failed.

I'm worried that I may have Autozone ball joints, but my brother may have been wise enough to make me buy Moog. Is there any way to tell?

http://www.supermotors.net/vehicles/registry/10453

1996 XLT 5.8L E4OD, D44 SAS with Spool and Alloy USA Shafts, D60FF 30spl rear, 4.88 gears
AxlesofEvil is offline  
post #73 of 107 (permalink) Old 10-03-2014, 07:19 PM
Registered User
 
pfun41's Avatar
 
Join Date: Jan 2010
Location: North Florida
Posts: 9,241
Bronco Info: 1994 Bronco 5.0 liter e4od factory MAF, 130 amp 3g, auxillary transmission filter and cooler.
iTrader: (0)
Quote:
Originally Posted by AxlesofEvil View Post
I have the same problem with the Vatozone fan clutch on my bronco, and my friend's F250.

My belt tensioner has the bearing noise of a supercharger. I'll keep it on there until it seizes and blows through my hood, then I'll buy a supercharger.

The water pump has also failed.


I'm worried that I may have Autozone ball joints, but my brother may have been wise enough to make me buy Moog. Is there any way to tell?
My idler is noisy as well, I had planned on getting as much life out of it as possible then replacing it when it gets worse. Going on 7 years now hasn't gotten any worse.

Just because something is from autozone doesn't mean its bad. My Timken wheel bearings and energy suspension bushings came from Autozone.
Duralast is autozone's house brand, that and any other cheap brands are what you need to be careful of. Check the joints for any kind of markings. my bearings had Timken stamped into them. Other than that just keep an eye and ear out for them and check them every once in a while.

My Youtube: http://www.youtube.com/user/pfun41#p/a
The going get tough, the tough get debt
Don't pay attention, pay the rent
Next of kins pay for your sins
A little faith should keep us safe
pfun41 is offline  
post #74 of 107 (permalink) Old 01-08-2015, 01:51 PM Thread Starter
Moderator
 
miesk5's Avatar
 
Join Date: Oct 2003
Location: NJ
Posts: 17,208
Bronco Info: 96 Bronco XL 5.0 E4OD, Man Xfer/Hubs
iTrader: (2)
Garage
yo,
I" recently had a problem with my PIP module in my distributor. I bought a Cardone from Auto Zone. I am now on the third replacement. I was wondering what brand replacement you guys recommend. I do not need high performance. I do need high reliability. I get off road and have everything in place to do the 6 liter tune up. This is my DD. 37's, 4.88, auto with Aussie Lockers. I think I remember calling Ford when I was first having problems and them telling me that they do not sell the distributor for that vehicle any more. I am going to check again tomorrow...
Sorry, I didn't get detailed enough on the original post. It is the dizzy (PIP) that I am having problems with and replacing. The first issues was the same one I had with the OE one. It ran fine ( I could feel it missing at times) and then stalled. Spray some starting fluid in it and it would run. That quit working. The second one did the same thing. Now, I feel it missing again. I had replaced the ICM, the coil, the plugs, the wires, the cap, the rotor, checked the routing of the 2/4 and 5/8 wires, looked for sparking from a short from the wires to the block or exhaust. This is the 2nd issue I have had with Auto Zone parts and I think I have had enough. So, I am trying to find out what my next best option is. I was thinking of a junk yard replacement or spending some coin on a MSD, Accel or ??? Just wanted to know what you guys thought.

I am perplexed at why I am having this same problem over and over. But it is the third replacement dizzy...
Well the Ford dealer has it for $400+, I know the MSD wasn't that expensive. I have no idea on other brands. Not sure which one(s) are worth the money. Or, if I might be better off going with a junk yard find..."
http://www.fullsizebronco.com/forum/21-noobie-bronco-tech-questions-flame-free-zone/200442-auto-zone-%24%40-%2A%40-%24-%2A.html
by akojsp

Fireguy 50 recommended MOTORCRAFT Part # DU30C for 1985-91 trucks
MOTORCRAFT Part # DU50 for 1992-96 trucks

See my partially recovered Bronco web site ...Will need to clean up dead links & add many more new links some day. Thanks to Mr. Schwim!
THANKS to ALL WHO SERVE!
miesk5 is offline  
post #75 of 107 (permalink) Old 01-08-2015, 02:43 PM
Registered User
 
turpit's Avatar
 
Join Date: Dec 2009
Location: limbo
Posts: 1,793
Bronco Info: 93 XLT
iTrader: (0)
Quote:
Originally Posted by miesk5 View Post
yo,
I" recently had a problem with my PIP module in my distributor. .........
Fireguy 50 recommended MOTORCRAFT Part # DU30C for 1985-91 trucks
MOTORCRAFT Part # DU50 for 1992-96 trucks
Just a thought, maybe a longshot.....somewhere buried in FSB's bowels is a thread/post about the distributor shaft becoming magnetized and causing problems with the PIP/ignition....

IIRC, the thread/post mentioned a dealer shop identifying and solving the problem. I donít know where the thread is, but you will be able to find it a lot faster than I could.

WRT the PIP, you might find a motorcraft PIP on amazon. Thatís where I found mine, but that was a couple of years ago so I donít have the order/link for it anymore....sorry.

G/L

Quote:
Originally Posted by Verndewd
You're about as observant as a blind deaf mute in a sensory deprivation tank.
Quote:
Originally Posted by Alexander Stoklosa
After all, a world without enormous, fuel-sucking trucks with suspensions capable of bombing across the Baja at 80 mph isnít a world worth living in.
Quote:
Originally Posted by BikerPepe'
Punching a weatherman in the nose has been on my bucket list for decades!
turpit is offline  
post #76 of 107 (permalink) Old 01-08-2015, 05:01 PM
FSM Lifetime
 
NASSTY's Avatar
 
Join Date: Sep 2008
Location: ME
Posts: 1,549
Bronco Info: 1992 Bronco XLT 5.8L 4" Dick Cepek stage2 lift 35" Boggers 4.10s True Trac
iTrader: (6)
Last summer the plastic gears stripped out in my DS power window motor. Of course the local part stores don't keep replacement gears in stock so I got a remanned Dorman power window motor. It shit the bed one month later. I brought it back and exchanged it for another. It's been 3 months and this one is still working.
<fingers crossed>
NASSTY is offline  
post #77 of 107 (permalink) Old 01-08-2015, 05:51 PM
FSM Lifetime
 
AlaskanBronco's Avatar
 
Join Date: Sep 2008
Posts: 2,049
iTrader: (0)
So ANCO wiperblades suck now? Almost bought a set since that's whats currently on my Camaro, but I ended up with the fancy Michelins or something


AKA Probowler
AlaskanBronco is offline  
post #78 of 107 (permalink) Old 01-09-2015, 10:22 PM
Registered User
 
Join Date: Mar 2003
Location: New Joisey
Posts: 958
Bronco Info: 89 F350 42's / 78 Bronco 460 35's / 79 Bronco XLT stock
iTrader: (4)
I swore by ANCO, but yeah, they're crap now. I use the RainX Lattitude blades now. Expensive, but work great.

Quote:
Originally Posted by BikerPepe` View Post
"voting for hilary because she's a woman, is like eating shit because it looks like chocolate."
Mudman78 is offline  
post #79 of 107 (permalink) Old 01-09-2015, 10:31 PM
Registered User
 
pfun41's Avatar
 
Join Date: Jan 2010
Location: North Florida
Posts: 9,241
Bronco Info: 1994 Bronco 5.0 liter e4od factory MAF, 130 amp 3g, auxillary transmission filter and cooler.
iTrader: (0)
Quote:
Originally Posted by Probowler View Post
So ANCO wiperblades suck now? Almost bought a set since that's whats currently on my Camaro, but I ended up with the fancy Michelins or something
Ive tried the Ancos and Michelins and they both sucked. All the wipers Ive tried have sucked, so I stuck with buying cheap ones and swapping them out every year.

My Youtube: http://www.youtube.com/user/pfun41#p/a
The going get tough, the tough get debt
Don't pay attention, pay the rent
Next of kins pay for your sins
A little faith should keep us safe
pfun41 is offline  
post #80 of 107 (permalink) Old 01-10-2015, 07:24 AM Thread Starter
Moderator
 
miesk5's Avatar
 
Join Date: Oct 2003
Location: NJ
Posts: 17,208
Bronco Info: 96 Bronco XL 5.0 E4OD, Man Xfer/Hubs
iTrader: (2)
Garage
Quote:
Originally Posted by Mudman78 View Post
I swore by ANCO, but yeah, they're crap now. I use the RainX Lattitude blades now. Expensive, but work great.
yo M,
I can't believe the RainX are still going strong! Had them on since early NOV 2008!

I do swipe each monthly with alcohol wipes to clean them of sap and grime.

See my partially recovered Bronco web site ...Will need to clean up dead links & add many more new links some day. Thanks to Mr. Schwim!
THANKS to ALL WHO SERVE!
miesk5 is offline  
Reply

  Ford Bronco Forum > Other Forums > Anything Else

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Bronco Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself. DO NOT USE Gmail.com accounts. If you only have a Gmail.com email please contact the administrator here

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome