Parking Break Light and Rear Anti-Lock Light On? - FSB Forums
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 26 (permalink) Old 03-19-2010, 07:16 PM Thread Starter
My Bronco Isn't My Only
 
WuTang's Avatar
 
Join Date: Mar 2010
Location: Lake Havasu City, AZ
Posts: 1,010
Bronco Info: 1988 Ford Bronco 302 AOD|1993 Ford F-150 302 E4OD
Parking Break Light and Rear Anti-Lock Light On?

I just went out this morning and started her up and I noticed the parking break wasn't on (even though I thought I had put it on), but the light was on and so is a REAR ANTI-LOCK light.
It pulls when it's in drive so I don't think the parking break is stuck.
I looked at this thread, but my breaks don't grind at all...
http://www.fullsizebronco.com/forum/21-noobie-bronco-tech-questions-flame-free-zone/4765-brakes-rear-anti-lock-light-89-bronco-xlt-351-a.html
Any ideas?
WuTang is offline  
Sponsored Links
Advertisement
 
post #2 of 26 (permalink) Old 03-19-2010, 11:35 PM
Registered User
 
Runnin'OnEmpty's Avatar
 
Join Date: Nov 2004
Posts: 455
Lightbulb

Try the simple things first; there should be a parking brake switch
up under the dash and affixed to the parking brake mechanism.
Give it a good spray with WD-40 or something similiar, and maybe
it'll loosen up the sticking switch.

Not sure about the rear ABS light, but maybe the two problems
are connected...

1978 Bronco Ranger XLT, Trailer Special with FreeWheeling Package, 351M, NP435, Ford alloys w/BFG 31's, MAC/IMCO hybrid exhaust.
Runnin'OnEmpty is offline  
post #3 of 26 (permalink) Old 03-19-2010, 11:54 PM
Registered User
 
lovinfishin9's Avatar
 
Join Date: Nov 2007
Location: Waycross, GA
Posts: 114
Bronco Info: 1991 Bronco XLT 5.0 SAS in progress
Check the brake fluid, low brake fluid will cause both lights to be on.
lovinfishin9 is offline  
post #4 of 26 (permalink) Old 03-20-2010, 05:29 PM
Registered User
 
Join Date: Jul 2009
Location: western n.c.
Posts: 710
Bronco Info: '94 XLT stock 5 speed manual t-case (my 3rd bronco)


double that... the under dash switch mentioned above could be doing it as well. first check your brake fluid... If your truck has cruise control have you done the recall yet? The plug on your master cylinder leaks out fluid and can cause a fire... When I found out about the recall mine was smoking all the time from under the hood... close call there...

almost all ford's with cruise control were affected. that's why so many trucks burnt down in people's driveways for a while there.

"when man behaves like a beast he loses the pain of being man" by someone somewhere sometime...

'94 XLT stock 5 speed 302
goober is offline  
post #5 of 26 (permalink) Old 03-21-2010, 09:09 PM
Registered User
 
Join Date: Nov 2005
Posts: 27
Bronco Info: 05 Mustang, Metallic Mineral Grey
a 1988 doesn't have the cruise control switch.
AKAfactory25 is offline  
post #6 of 26 (permalink) Old 03-22-2010, 12:56 AM
Driving Stuff Henry Built
 
El Kabong's Avatar
 
Join Date: Oct 2006
Location: Pasadena, CA
Posts: 5,941
Bronco Info: -90 xlt, 351w, e4od, 3.55:1, sag, warn hubs, trans cooler, 35" bfg m/t, -73, 400, np435, 35s
Please excuse the cut & paste. 87-92 Broncos have Rear Wheel Antilock Brakes (RABS). There's a self test routine for pulling RABS codes quoted below, & section "C" below that covers testing when both BRAKE & REAR ABS lights are on. Go thru section "C" first, & it'll tell you if you need to do the self test. It's incomplete at this point, but there's some more info here: Common Replies to FAQs, post 8. If you need more info on another flashout code, let me know & I'll look it up.

Here's a good resource thread with more info from Miesk5 & jermil01: Brake and Rear ABS lights on

Quote:
Pulling RABS Flashout Code. This routine should be good from 87-92.

Quote:
The 90 service manual gives a routine to pull RABS codes. When the light comes on, don't turn the truck off before reading the codes. Put it in park, chock both front & rear of the wheels, note whether the red brake light is lit also, then momentarily ground the test connector.

On my 90, the test connector comes out of a large loom under the dash, coming through the firewall, near the parking brake. On mine there are 2 similar connectors in that area, the correct one has only 1 black wire with an orange tracer running to it, & was hidden on top of the loom. The correct one is hanging down on the bottom right of the 90 pic below. 92 has the test plug on the passenger side. See jermil01's 92 pics below.

After you've grounded & ungrounded the wire, the yellow abs light starts to flash. Count the flashes. It said to not count the 1st series, because it may start in the middle. The last flash of the series is a long flash. Then it repeats over & over, until you turn the key off.

Count all of the short flashes & the long one together (So 4 short & 1 long is code #5). If I remember right, it should be a number between 2 & 15 or so. In Steve83's Brakes & Hubs album, he has the code definitions & other info for RABS-II near the bottom.

There are also more testing instructions in the manual that I can look up after you know what the code is, & whether the red brake light is on or off.
90 Test Connector
Quote:
92 Test Connector
Quote:
Originally Posted by jermil01 View Post
92 Module
Quote:
Originally Posted by jermil01 View Post
And the RABS module behind the glove box

Quote:
C Testing Procedure from the 1990 Ford Truck Shop Manual. Use this section when both Yellow & Red lights are on.
Quote:
Test C
Yellow ANTILOCK light On and
Red BRAKE Light On

Quote:
C1 -Low brake fluid

Brake fluid level ok = Go to test C2
Brake fluid level low = Check for fluid leaks & repair. Fill system
Quote:
C2 -Master cylinder float -Check float for buoyancy
1- Remove cap from master cylinder.
2-Using a clean steel implement, push down on float in reservoir.

Float moves down = Go to test C3
Float does not move down (Sits at the bottom of the reservoir) = Replace master cylinder reservoir.
Quote:
C3 -Diode/resistor element -Check for proper functioning of the diode/resistor element.
1- Turn ignition key to the on position.
2- Check parking brake & release if applied.

Both ANTILOCK & BRAKE warning lamps go off = Replace RABS diode/resistor element.
Both ANTILOCK & BRAKE warning lamps stay on = Go to test C4.
Quote:
C4 -Diode resistor element continued -Continue to check for proper functioning of the diode/resistor element.
1- Remove the parking brake switch & the diesel low vacuum switch, if so equipped.
Both ANTILOCK & BRAKE warning lamps go off = Replace RABS diode/resistor element.
Both ANTILOCK & BRAKE warning lamps stay on = Go to test C5
Quote:
C5 -Antilock valve switch
-Obtain the flashout code as described in Diagnosis & Testing in this section.
(See the section above for pulling RABS codes)

Flashout code is obtained = Refer to Flashout Codes Charts
ANTILOCK & BRAKE warning lamps stay on steady = Go to test C6
Quote:
C6 -Master cylinder switch
-Check for the proper functioning of the master cylinder level indicator switch.

1- Remove the connector from the master cylinder.
2- Connect a jumper wire between the 2 purple/white wires in the connector.
3- Turn the ignition key to the on position.

ANTILOCK & BRAKE warning lamps stay on = Go to test C7
ANTILOCK & BRAKE warning lamps go off = Replace the master cylinder reservoir.
Quote:
C7 -Brake Light Wiring
-Check for shorts in brake light wiring.
1- Disconnect module harness connector from module
2- Turn ignition key to the on position.

Antilock light goes off & Brake light stays on = Check for short to ground in the 977 circuit. Refer to wiring diagram in this section.
Both ANTILOCK & BRAKE warning lamps go off = Replace module.

Baba Looey's Favorite FSB Links........................Common Replies to FAQs

“Don't find fault, find a remedy.” -Henry Ford
El Kabong is offline  
post #7 of 26 (permalink) Old 03-26-2010, 09:38 PM
Registered User
 
Join Date: Mar 2007
Posts: 4
Bronco Info: 87 Eddie Bauer
I know this may sound crazy but my rear abs light came on after i changed out my batt. what happened was a plug came unplugged on the neg side batt. cable, the clip was broken and it just kinda slipped out. I just didn't notice it at first plugged it back in and light out!
wannanotherbronco is offline  
post #8 of 26 (permalink) Old 03-26-2010, 11:46 PM
Registered User
 
Join Date: Nov 2009
Location: Spotsylvania Va
Posts: 127
Bronco Info: 95 f150 7" of lift and 35s
Had this happen to me when i had my parking brake on for a while when i busted a brake line. But what I did was pulled one of the fuses started it, then put it back in and started it again and badabing! Both lights were gone. No idea why it worked but it did.
bestdallasfan6 is offline  
post #9 of 26 (permalink) Old 08-21-2012, 12:12 PM
Registered User
 
Join Date: Oct 2011
Location: Dothan Al
Posts: 17
Bronco Info: 1991 EB 5.0 e4od 4WD
Got a? What does it mean if just the anti lock light is on and does not go off even momentarily.
The master cylinder is new the brake warning light works with low fluid and parking brake. I'm at a loss here the truck is a 1991 brunco with f350 master booster and wheel cylinder.
WILLIAMF is offline  
post #10 of 26 (permalink) Old 08-21-2012, 02:24 PM
Registered User
 
Join Date: Jan 2012
Location: PA
Posts: 613
Bronco Info: '89 7.3/7.3 banks turbo, parked in storage.
my rear ABS light as been on for years, through parts at it, nothing helped it... Now i read that it could be the low fluid sensor? Heck i disconnected that years ago as the wires were corroded and falling apart... Now i feel slightly dumb.

SOLD** 1989 Bronco XLT - 7.3 idi NA / ZF5 speed parked in storage
TOTALED by a PennDot SnowPlow** '95 f350 CC LB 4.9l / zf5 <-- grocery getter
96 F150 5.8L OBDII E4OD $400 beater
mickey556 is offline  
post #11 of 26 (permalink) Old 08-21-2012, 04:55 PM
Registered User
 
Join Date: Oct 2011
Location: Dothan Al
Posts: 17
Bronco Info: 1991 EB 5.0 e4od 4WD
I've done things like that it works with park brake and low fluild I'm wondering if it isn't the module
WILLIAMF is offline  
post #12 of 26 (permalink) Old 08-22-2012, 03:41 PM
Registered User
 
Join Date: May 2012
Location: Wilmington, NC
Posts: 256
Bronco Info: 1989 Bronco, 5.0, 5-Speed Manual Trans
Quote:
Originally Posted by WuTang View Post
I just went out this morning and started her up and I noticed the parking break wasn't on (even though I thought I had put it on), but the light was on and so is a REAR ANTI-LOCK light.
It pulls when it's in drive so I don't think the parking break is stuck.
I looked at this thread, but my breaks don't grind at all...
http://www.fullsizebronco.com/forum/showthread.php?t=4765
Any ideas?
Pull the code(s) as per a previous post....

I had he same issue, RABS light and Parking Brake Light on all the time, no brake grind, and it turned out to be the RABS valve assembly...

I replaced it and the lights are off....
inmytree is offline  
post #13 of 26 (permalink) Old 08-22-2012, 04:26 PM
Registered User
 
Join Date: Oct 2011
Location: Dothan Al
Posts: 17
Bronco Info: 1991 EB 5.0 e4od 4WD
I've. Tryed to pull codes the light just Burns steadily no blink or any thing
WILLIAMF is offline  
post #14 of 26 (permalink) Old 08-22-2012, 06:21 PM
Registered User
 
4NIC8R's Avatar
 
Join Date: Jul 2012
Location: Nevada
Posts: 193
Bronco Info: 91 Silver Anniversary
Williamf
Have you followed the directions in this thread above to perform the self-test and pull codes?
4NIC8R is offline  
post #15 of 26 (permalink) Old 08-22-2012, 07:15 PM
Registered User
 
Join Date: Oct 2011
Location: Dothan Al
Posts: 17
Bronco Info: 1991 EB 5.0 e4od 4WD
Yes I only have rear anti light on not the brake light
WILLIAMF is offline  
post #16 of 26 (permalink) Old 08-22-2012, 07:56 PM
Registered User
 
Join Date: Oct 2011
Location: Dothan Al
Posts: 17
Bronco Info: 1991 EB 5.0 e4od 4WD
Got it fuse 17 10 amp had no power but ABS was all that didn't work. Does this make any sense?
WILLIAMF is offline  
post #17 of 26 (permalink) Old 10-11-2012, 09:28 PM Thread Starter
My Bronco Isn't My Only
 
WuTang's Avatar
 
Join Date: Mar 2010
Location: Lake Havasu City, AZ
Posts: 1,010
Bronco Info: 1988 Ford Bronco 302 AOD|1993 Ford F-150 302 E4OD
Since I never did reply to this and state what was wrong, it was something simple and stupid. Bronco needed more brake fluid. Topped off the reservoir, issue was gone.


Quote:
Originally Posted by B-man View Post
I dont' care about gas mileage. I am broke as hell, and I will STILL drive my gas guzzlin, smog pollutin FSB.
Quote:
Originally Posted by paintballdude902 View Post
the only way to say goodbye to a bronco is a viking style ceremonial burning. climb inside, lock the doors, turn on stair way to heaven and light a match.
WuTang is offline  
post #18 of 26 (permalink) Old 10-11-2012, 11:12 PM
Registered User
 
Join Date: Jul 2012
Location: Houston
Posts: 52
Bronco Info: 89 FSB 5.0L 4AOD Eddie Bauer
Quote:
Originally Posted by lovinfishin9 View Post
Check the brake fluid, low brake fluid will cause both lights to be on.
x2
smptx is offline  
post #19 of 26 (permalink) Old 02-26-2013, 05:46 PM
Registered User
 
Join Date: Oct 2012
Posts: 1
My 88 has the same problem but my rear brakes are holding some
joeteasley is offline  
post #20 of 26 (permalink) Old 02-26-2013, 10:07 PM
Driving Stuff Henry Built
 
El Kabong's Avatar
 
Join Date: Oct 2006
Location: Pasadena, CA
Posts: 5,941
Bronco Info: -90 xlt, 351w, e4od, 3.55:1, sag, warn hubs, trans cooler, 35" bfg m/t, -73, 400, np435, 35s
That's what mine was doing, dragging the rear brakes.

Are both the Yellow REAR ABS and the Red BRAKE lights on?

Baba Looey's Favorite FSB Links........................Common Replies to FAQs

“Don't find fault, find a remedy.” -Henry Ford
El Kabong is offline  
Reply

  FSB Forums > Bronco Discussions > Noobie Bronco Tech Questions. Flame free zone!

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the FSB Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself. DO NOT USE Gmail.com accounts. If you only have a Gmail.com email please contact the administrator here

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome