sensor failures - Ford Bronco Forum
 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 11-19-2012, 10:30 PM Thread Starter
Registered User
 
Join Date: Nov 2012
Location: klamath falls
Posts: 3
Bronco Info: 92 xlt 351w
sensor failures

I have a 92 bronco xlt 5.8l. I have checked codes and tested sensors as I go when I replace a sensor within a couple days another problem arises and a different sensor tests bad. Ive replaced iac valve o2 sensor tps ect all due to codes and a follow up test of the sensor. I got the truck in february and at the time I was gettin 12 mpg average around town within a month it dropped to 9 at that point I changed plugs wires cap rotor o2 sensor still no change recent cold snap brought up new issues. Starts up great but idles up to 1500 if I wait around 2 to 3 minutes it will come down to my usual 750 but since this all started it now idles in gear automatic around 1000 and doesnt want to shift till 3500 and cruises around 2500 at 35 mph I can pat the gas sometimes and it will then upshift but starts back up at the next stop light. After driving for about 20 min I park the truck and the idle jumps to 2500 under no load. Sometimes after that I can shut it off let it sit for about 5 min and then it will idle perfect and shift perfect. Engine codes currently koeo 327, 328 which has to do with egr position sensor cannot get koer test to activate. My question is will changing that sensor effect my idle situation the ohms reading I get of the sensor itself is 15000 ohms the reference signal on the plug is 5 volts.

Thanks for reading I know its a lot of info but I really nead help it is my only means of transport right now
dan_chandler is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 11-20-2012, 12:55 PM
Registered User
 
Join Date: Jul 2012
Location: florida
Posts: 110
Bronco Info: 96 eb 351 auto
I doubt the EGR code is the problem. first ck for vac leaks [hoses gaskets ...] then ck the TPS for correct operation/adjustment and for IAC mounted correctly. IF those are ok ck the MAP sensor[can be tested for hertz but easier to just replace with a borrowed or new one].
96EB5.8 is offline  
post #3 of 8 (permalink) Old 11-20-2012, 01:10 PM
Fullsize Member
 
JKossarides's Avatar
 
Join Date: Apr 2005
Location: Rolling Hills Estates, CA
Posts: 9,563
Bronco Info: 1986 Bronco XLT 4x4 -AOD -Warn Hubs, NEW stock 302EFI (2008) All MSD ignition, 9mm FMSR wires
You need to figure out why you can't perform KOER self dynamic test, make sure the Ford Code Reader batteries are fresh or it won't trigger the computer properly, incomplete or failed test results.

What transmission are you running, AOD or E4OD, C6....?

You can pull and clean the IAC using throttle body cleaner but only in the bottom valve part to remove any built up carbon inside and it will improve idle.

Most TPS sold today are "plug & play" with no "adjustment slots" using a multimeter for adjusting voltage setting, the setting is automatic when reconnected, make sure the "tangs" little plastic bumps inside the spring loaded ring in the center engage the end of the TB shaft otheriwse it's like being in neutral.

Check thru the emissions sytem for possible vacuum leaks in the lines or hoses.....it doesn't take much...


Good Luck ~
JKossarides is offline  
post #4 of 8 (permalink) Old 11-20-2012, 03:33 PM Thread Starter
Registered User
 
Join Date: Nov 2012
Location: klamath falls
Posts: 3
Bronco Info: 92 xlt 351w
response to helping questions

Sorry e4od new idle air control valve new tps plug and play unit no adjustment and vacuum holds around 12 with vacuum pump. Thank you for replying and your help
dan_chandler is offline  
post #5 of 8 (permalink) Old 11-21-2012, 01:19 AM Thread Starter
Registered User
 
Join Date: Nov 2012
Location: klamath falls
Posts: 3
Bronco Info: 92 xlt 351w
Thumbs up thanks for your help

I went through and checked all my sensors again tps that I replaced last month was getting 5 volts but sending nothing back out from closed to wide open throttle. I warranty replaced it and now it idles great and shifts right on time.
dan_chandler is offline  
post #6 of 8 (permalink) Old 11-21-2012, 08:43 AM
Registered User
 
Join Date: Jul 2012
Location: florida
Posts: 110
Bronco Info: 96 eb 351 auto
Sometimes just because it is new does not mean it is good. GLad to hear you found it.
96EB5.8 is offline  
post #7 of 8 (permalink) Old 11-24-2012, 01:58 PM
Fullsize Member
 
JKossarides's Avatar
 
Join Date: Apr 2005
Location: Rolling Hills Estates, CA
Posts: 9,563
Bronco Info: 1986 Bronco XLT 4x4 -AOD -Warn Hubs, NEW stock 302EFI (2008) All MSD ignition, 9mm FMSR wires
What was the end result as to why you can't pull fault codes for KOER self dynamic test.....?

Thanks ~
JKossarides is offline  
post #8 of 8 (permalink) Old 11-26-2012, 02:22 PM
Registered User
 
Join Date: Jul 2012
Location: florida
Posts: 110
Bronco Info: 96 eb 351 auto
OBD 1 codes are ok for some things but sometimes are useless for drivability problems. They either are not present or for something unrelated to the actual problem, as in this case. On SD systems it almost always comes down to tp, maf, spark or fuel. Most of these on OBD1 are not code friendly. I am a ford senior master tech[tech for 20yrs] and I specialize in gas drivability
96EB5.8 is offline  
Reply

  Ford Bronco Forum > Bronco Discussions > Noobie Bronco Tech Questions. Flame free zone!

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Bronco Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself. DO NOT USE Gmail.com accounts. If you only have a Gmail.com email please contact the administrator here

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome