loud whine from gas talk after engine swap - FSB Forums
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 01-25-2013, 04:29 PM Thread Starter
Registered User
basssque's Avatar
Join Date: May 2011
Location: Connecticut
Posts: 203
Bronco Info: 92 Bronco Custom, 5.5" Lift (all Spring), BDS Ext. Radius Arms, Superrunner Steering
loud whine from gas talk after engine swap

After swapping a donor engine from a 96 f150 into my 92 bronco, everything is now running great! The last issue I have is that there is a very loud whine coming from the gas tank that didn't exist before the swap. Any idea's as to the cause or resolution? It was a simple swap, 302 for another 302. Thanks
basssque is offline  
Sponsored Links
post #2 of 3 (permalink) Old 01-25-2013, 05:06 PM
Huh Huh vanzercool
TheUnforgiven's Avatar
Join Date: Aug 2004
Location: Woodridge, Illinois
Posts: 19,072
Bronco Info: 2005 Chevrolet Venture, 1997 Acura TL
The fuel pump. They can make noise for years before failing. It may have been doing it before and you never noticed it because now you're actively listening for things.

Change the fuel filter and forget about it.

2005 Chevy Venture. 1997 Acura TL. $500 beater.
Originally Posted by "Bronco" John Galt View Post
New nuts are in the plan.
"Kids, they see the good in everything and through their eyes, they open ours." - Hank Davis

"To be easily amused is to live most of your life smiling."
TheUnforgiven is offline  
post #3 of 3 (permalink) Old 01-26-2013, 12:51 AM
Registered User
Join Date: Jan 2012
Location: seminole alabama
Posts: 101
Bronco Info: 96 eb e4od 351 4.10 eaton elocker rear ls frnt, k&n drop in Punisher valve body
^^^^^^^ x2 Even a new pump can be loud to the point of being annoying. You may just not have noticed it before. The level of fuel in the tank will also affect how noticeable it is

96eb e4od 351 4.10 elocker rear ls front buckstop winch bumper front k+n drop in gheto'd. 95 eb 351 e4od bone stock for now. So thats two and counting
96bronco58 is offline  
Sponsored Links

  FSB Forums > Bronco Discussions > Noobie Bronco Tech Questions. Flame free zone!

Quick Reply

Register Now

In order to be able to post messages on the FSB Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself. DO NOT USE Gmail.com accounts. If you only have a Gmail.com email please contact the administrator here

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome