84 bronco horn doesnt work - FSB Forums
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 02-17-2013, 04:59 PM Thread Starter
Registered User
Join Date: May 2006
Location: Fl
Posts: 41
Bronco Info: 1985 XLT, headers, 33's
84 bronco horn doesnt work

Hi everyone, I have searched, traced wires and cant follow them completely, they seem to change colors which doesnt make sense.

I bought the truck, the horn pad on the stock wheel was missing, I but a new grant wheel on it with the installation kit hooked all the wires up correctly and my horn doesnt work, , didnt work before the grant wheel either(had a spare wheel that was in bad shape but come off of a bronce that the horn was working).

I traced the wires to the horn relay (under dash near cigarette lighter)

I have 12v to 1 or 2 terminals on the relay (cant remember), I dont get any power at the horn. Can anyone give me some ideas or have had this problem before (I checked the fuses too...)

I'm not a cracker, I'm a vanilla wafer!
Clint Baxley is offline  
Sponsored Links
post #2 of 5 (permalink) Old 02-17-2013, 05:46 PM
Registered User
war1ock's Avatar
Join Date: Aug 2012
Location: Dearborn County IN
Posts: 157
Bronco Info: 1980 300 I6 4spd/1981 302 C6
find the horn and hook 2 jumper wires up to the 2 leads and see if the horn itself works. Then work your way back from there. I use my Power Probe for this but 2 jumper wires from a battery with do the same trick.
war1ock is offline  
post #3 of 5 (permalink) Old 02-17-2013, 07:14 PM
Registered User
Join Date: Aug 2008
Posts: 6
thats what i would do then check to see if the horn button is closeing the circut when pushed
socaloffroader is offline  
post #4 of 5 (permalink) Old 03-01-2013, 10:21 AM
Registered User
Join Date: May 2007
Location: Los Angeles, Ca
Posts: 82
Time for a train horn

You shouldnt let your girlfriend sign you up with mitchy as your user name...

i'll never let it go.
Mitchy7 is offline  
post #5 of 5 (permalink) Old 03-03-2013, 12:58 PM
F.O.T.M. - MAY 2014!!!
fartman's Avatar
Join Date: Jan 2005
Location: Los Angeles, California
Posts: 6,266
Bronco Info: 88 FSB. 4.9l -T18-BW1356-33" MTs-Warn hubs Daystar leveling kit
My horn stopped working a while back. I thought it was just the horn, replaced and still nothing. Then I would get a beep every now and then.

After tinkering, I found the problem is on the steering column. Behind the wheel on the column there is a metal ring. For some reason the ring on my truck was not making full contact with the contact pad on the wheel.

Sliding rear windows, GT roll bar, Cargo net and looking for other rare options. 4.10 gears LSD 33" MTs First ever Stock Fullsize of the Month...
J A S N http://www.supermotors.net/registry/19528
fartman is offline  
Sponsored Links

  FSB Forums > Bronco Discussions > Noobie Bronco Tech Questions. Flame free zone!

Quick Reply

Register Now

In order to be able to post messages on the FSB Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself. DO NOT USE Gmail.com accounts. If you only have a Gmail.com email please contact the administrator here

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome