stock dash board issues or worse? - Ford Bronco Forum
 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 05-02-2016, 03:06 AM Thread Starter
Registered User
 
Join Date: May 2016
Posts: 1
iTrader: (0)
Garage
stock dash board issues or worse?

So i recently purchaced a1992 bronco eddie baurer ed. Has 171xxx miles. I just had it all timed looked at tuned up oil changed all that good stuff. Now i noticed that my lights on thw bottom left hand corner (like the left hamd blinker)dont work the cruise control doesnt work and when i open the driver side door the lights dont come on. Thays not it just yet. The oil pressure gauge is fine when i first start up and drive for about 15 20 mins than it starts fluctuating at idle in park or driving down the road and so will the volt meter will go up and down and the gas gauge goes up and down about am 1/8 of a tank as im driving. Now my main concern is the oil gauge. Now there is no knock ticks or lifter noises even when the gauge drops to nothing and when i say nothing i mean the gauge is maxed out low. No odd smells noises or drive ability. It has 20w50 oil in it and i just replaced the oil pressure sender unit which is a single wire. And tore my dash board apart hoping to fine a bad connector in it with no shorts that i believe so if im having all these problems electrically is the the wire harness f***ed up somewhere or am i just imagining things. Any help would b appricated
92 broncotank is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 05-02-2016, 08:49 AM
Charlie doesn't surf!!
 
jermil01's Avatar
 
Join Date: Apr 2003
Location: JAX, FLA
Posts: 13,766
Bronco Info: 1992 xlt, 351EFI, .040, E4OD, D44 SAS w/Trutrac,Detroit locked 8.8, MAF conv, Tweeced
iTrader: (32)
Garage
welcome to the site..sounds like you have quite a few things going on there, something electrical for sure. Best bet is to head over to the newbie section and start a new thread, you'll get a lot more visibility there.
jermil01 is offline  
Reply

  Ford Bronco Forum > Wheeling > Northeast Chapter

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Bronco Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself. DO NOT USE Gmail.com accounts. If you only have a Gmail.com email please contact the administrator here

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome