89 Bronco running rich - FSB Forums
Register Home Forums Active Topics Photo Gallery All Albums Mark Forums Read Auto EscrowInsurance FSB Store
FullsizeBronco.com is the premier Ford Bronco Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools Display Modes
Old 10-04-2008, 11:22 AM   #1
bronco boy 12
Registered User
 
Join Date: Sep 2008
Location: Dallas,GA
Posts: 14
iTrader: (0)
Bronco Info: 1989 Bronco 351w C6 32's
Angry 89 Bronco running rich

Hi i have an 89 bronco with a 351 and a c6. it is sped density and runs great while driving. it just idles rough and blows black smoke out when it shifts gears or at initial startup. every time you start it 2 clouds of black smoke appear out the sides, and all the time it runs it smells very very rich. lately it gets crap for gas mileage used to get 14 now gets 7. i ran 93 octane in it and no difference.
bronco boy 12 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 10-04-2008, 11:30 AM   #2
Bilzhorse
Big feet, big hands & a
 
Bilzhorse's Avatar
 
Join Date: Oct 2003
Location: Stafford, Va
Posts: 767
iTrader: (5)
Bronco Info: 89 XLT, 5.8, C-6, BW1356, factory LSDs, 33s
If you haven't checked for codes do it now. There are many threads on how to do this. Faulty O2 sensor, bad EGR are a couple of things that could be wrong. But def. check the codes first.
Bilzhorse is offline   Reply With Quote
Old 10-04-2008, 11:44 AM   #3
sackman9975
*~*~*~*~*~*~*~*
 
sackman9975's Avatar
 
Join Date: Dec 2007
Location: Livonia Michigan
Posts: 6,567
iTrader: (41)
Bronco Info: 1995 Eddie Bauer 357w, E303 cam on S/D, Warn premium hubs, 3 inch exhaust with flowmaster 40
Quote:
Originally Posted by Bilzhorse View Post
If you haven't checked for codes do it now. There are many threads on how to do this. Faulty O2 sensor, bad EGR are a couple of things that could be wrong. But def. check the codes first.
Or ECT (engine coolant temp) sensor........... But yes pull codes first.
__________________

~ Scott ~

~My Exhaust clip on YouTube ~ 208k on the odometer. Now my daily driver once again. ~
~ Bronco owner/Driver/Mechanic/Enthusiast for 22 years ~
sackman9975 is offline   Reply With Quote
Old 10-04-2008, 12:07 PM   #4
seawalkersee
Registered User
 
seawalkersee's Avatar
 
Join Date: Dec 2006
Location: Outside KCMO
Posts: 1,248
iTrader: (2)
Bronco Info: 84 FSB with a 6.9 diesel/zf 5, supercharger, and 33s.
Or BAP sensor. Or bad PCM. Or a bad fuel pressure regulator. I could go on and on. Also, you are wasting your lute if you are running anything over 87 octane and there is no ping. The function of octane is to slow down the burn of the gas (thus losing power if you do not need it). Ping is gasoline exploding in the combustion chamber prematurily. So if you do not have that, you will be good ta go with 87.

The problem with the older systems is that the ECT, BAP, FPR, and a few other problems may not trip a code (including the PCM AND at times the 02s). So try the codes first and then you will have to start with a wiring diagram and a break out box.

Chris
__________________
After Midnight Project music. Subscribe and see how good they are, and how good you will feel.
http://www.youtube.com/watch?v=1HPBejDwWVI
seawalkersee is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  FSB Forums > Bronco Discussions > 1980-'96 Bronco Tech


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 02:28 PM.


2003-2009 FullSizeBronco.com. All rights reserved