No Vacuum To EGR (Computer/sensor problem?) - FSB Forums
Register Home Forums Active Topics Photo Gallery All Albums Mark Forums Read Auto EscrowInsurance FSB Store
FullsizeBronco.com is the premier Ford Bronco Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools Display Modes
Old 08-15-2012, 07:42 PM   #1
ZappyShawrk
Registered User
 
ZappyShawrk's Avatar
 
Join Date: Aug 2012
Location: Sunnyvale, CA
Posts: 1
iTrader: (0)
Bronco Info: 1989 Ford Bronco XLT
No Vacuum To EGR (Computer/sensor problem?)

Hi everyone!

So first off, this is my first post, I was driven to this forum trying to find answers to my current problem. I did search for a while trying to find exactly what my issue was, but I didn't quite seem to find it. I have never worked on any car or truck, and the used 1989 Ford Bronco I just bought is my first truck, EVER!

And I love it! But it didn't pass smog...

Now, when I bought this beast, it had brand new tires, a brand new engine, motor and transmission, with only about 40,000 miles on the new stuff. The guy who sold it to me had taken it in for a smog pretest, and it passed with flying colors.

I took it in two days ago, and it failed the 25mph test.

Now, I took it to a mechanic, who looked over it for me. He said that everything was checking out fine, that he EGR valve, solenoid, Engine and Motor all looked beautiful, but that something to do with the COMPUTER or SENSOR seemed to not be working (if this makes sense). There is NO VACUUM TO THE EGR VALVE.

I've noticed on some of the other threads that this is a pretty common problem among older Broncos.

My Questions Are:

1) Is there a possibility that when the new engine, motor, transmission were replaced, the wiring for the sensor or computer might not have been hooked up properly? Causing the vacuum to not turn on, and thus, there being no vacuum in the EGR?

2) If it is a simple wiring problem, how would I go about checking, or fixing it? Is it something easy to reach? And is it something someone with little to no experience working on cars might be able to handle as a first project?

3) Is this sort of problem worth taking the truck in to the Ford Mechanic, who is going to charge me an arm and a leg JUST for DIAGNOSTIC, let alone any repair work? Or should any, reasonably priced technician, be able to fix this?

Thanks so much for any help with this, I have little to no knowledge about tech work, but I want to start learning, and since this is the first major issue I've found with my new baby, I'd like to see if I can handle it first. Please let me know how you guys would handle it! And I'm so sorry if this is a re-post! (I definitely did check, first!)
ZappyShawrk is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 08-16-2012, 01:27 AM   #2
4NIC8R
Registered User
 
4NIC8R's Avatar
 
Join Date: Jul 2012
Location: Nevada
Posts: 193
iTrader: (0)
Bronco Info: 91 Silver Anniversary
First, I'd find out if the computer is throwing any codes. You have two obvious choices, do it yourself, or have someone do it for you.

If you do it yourself, based upon your stated experience, I would advise you to get a code reader like this one. It comes with easy to follow directions.

If you decide to have someone else do it for you, many autoparts stores offer free code scanning. Just go to an Autozone or Napa and ask them to do it. May or may not be offered in your area so you should call first. Or, take it to a mechanic and have him/her do it.
4NIC8R is offline   Reply With Quote
Old 08-16-2012, 12:43 PM   #3
miesk5
Fullsize Member
 
miesk5's Avatar
 
Join Date: Oct 2003
Location: NJ
Posts: 12,464
iTrader: (2)
Bronco Info: 96 XL 5.0 E4OD, Man Xfer/Hubs
yo ZAPPY, until you check for Codes as 4NIC8R Advised;

here is a Self Test for Diagnostic Trouble Codes (DTC)s by my pal, BroncoJoe19
http://broncozone.com/topic/14269-co...mode__threaded


Run it around to heat the engine up and shift thru all gears incl Reverse. Then turn off all accessories/lights, etc.

Make sure A/C is off and transmission is in Park (automatic) or in Neutral for a Manual & release clutch.

Do Key On Engine Off (KOEO) portion first.

Look Codes up in my broncolinks.com site using the new Search function.

And Post em here according to:
KOEO
&
KOER



Testing; "...There shouldn't be any vacuum at the EGR valve at idle or any time your ass is under the hood fiddling with it, to put it plainly, except for perhaps a very light residual vacuum from the EVR. Check ALL of your vacuum lines FIRST, and the vacuum reservoir for leaks..."
Source: by SigEpBlue (Steve) at FSB http://fullsizebronco.com/forum/showthread.php?t=163513

Testing; "...Follow this procedure to rule out the EGR/EVP/EVR and then look elsewhere. As a side note, on one truck I had an EVP that tested good, but after replacement it cured my problem. The EVP is a potentiometer that can mechanically wear and the EVR solenoid can become stuck. On another truck, I eliminated the EGR Code 334 with a TPS replacement and adjustment. The EGR should only operate during cruising, never during Idle and WOT. Start by deleting the code and see if it returns. Then, perform a DTC Test and observe the EGR. When the PCM is in test mode, at some point during the test the diaphram should move and the engine rpms drop. We now know if the EEC is in control of the EGR. If the DTC returns, continue on. If no or inadequate change is seen, test the Manifold Red Vacuum line between the Manifold Vacuum Tree and VRESER (MAN port), then the VRESER Check Valve (AMP port) and then Black Vacuum Lines between the VRESER and lower ports on the TAB/TAD/EVR Solenoids. We have now ruled out an Emissions Manifold Vacuum Leak. With the engine off, locate the green vacuum line at the EVR (EGR Vacuum Regulator) located in front of the TAD and TAB Solenoids next to the coil. Attach a vacuum tester to the upper vacuum line and see if applied vacuum can operate and hold the EGR Diaphram. Disconnect the other end of the green vacuum line at the EGR. I you want, plug the end of the line with your finger and test again just to be sure. We have now ruled out the EGR vacuum line and EGR diaphram. If the line is good and the EGR is not holding vacuum, reattach the EGR vacuum line and remove the EVP (EGR Valve Postion Sensor) located on top of the EGR. The three attachment screws should not be loose causing an air leak. When removed, check the bottom of the EVP for an O-ring and if the position sensor pole can be moved up and down. Next, manually block the now open hole on top of the EGR with your hand and vacuum test again. We have now ruled out the mechanical portion of the EVP. Next, reinstall the EVP. With KOEO, check the unplugged harness connector with a DVOM for 5v reference voltage at pins VREF and SIG RTN. Then test the unplugged EVP Sensor for approximately 5000 ohms resistance at sensor pins VREF and EVP. Now apply 10 in. Hg. vacuum to the EGR. You should see a gradual decrease in resistance to approximately 100 ohms. If the vacuum, EGR and EVP test good, reconnect everything, except for the vacuum tester at the EGR and continue on. We have now ruled out the electrical portion of the EVP. Disconnect the harness connector to the IAC (Idle Air Controller) located on the side of the Throttle Body and start the engine. Start the engine and note that the idle should be lower than normal as the IAC is no longer in control. Apply vacuum to the EGR and watch for the engine idle to drop. Release the vacuum and the engine idle should return. If all is good, turn off the engine and reconnect the IAC and the green vacuum line to the EVR. Relocate the vacuum tester to the EGR end of the green line and connect using a "tee" between the vacuum line and the EGR. Start the engine and idle to warm. Idle vacuum from the EVR should be below 1 in. Hg. Now have someone raise the engine speed to 3500 rpm and observe the vacuum gauge for increase and the EGR Diaphram for movement. We have now ruled out the mechanical portion of the EVR. If the vacuum lines are good, next start KOER DTC Test with the Vacuum Hand Pump once again located at a "tee" at the EGR. While watching the vacuum gauge, observe for a change in vacuum and EGR Diaphram movement when the PCM activates the EGR during the test. If the test once again fails, either the EVR Solenoid is stuck or the there is a short to the EVR. Electrically test the EVR. The EVR has two connector pins. One to 12v battery power and the other to PCM Pin #33. Test the 12v to ground and the Signal wire to the PCM for continuity. Then you can mechanically test the EVR. The bottom port should hold vacuum and the upper port will not unless 12v are applied to the connector pins. Apply 12v, plug the lower port with your finger or cap and see if you can apply vacuum to the upper port. We have now ruled out the electrical portion of the EVR. If all is good at this point, start at the top of the page and look at the TPS link..." see EVP pin-out diagram & pics
Source: by Seattle FSB (SeattleFSB) at FSB http://fullsizebronco.com/forum/showthread.php?t=207645

SEE MY VACUUM LEAK TEST here @ http://fullsizebronco.com/forum/show...Test%3B+idling
__________________
96 XL 5.0 E4OD, Man Xfer/Hubs
USN & DoD Planner (ret)
THANKS to ALL WHO SERVE!

my broncolinks.com was "disturbed"; but some sections are archived @ [url]http://web.archive.org/web/20121009110424/http://www.broncolinks.com/index.php
select a LINK, Right Click & Hit Properties; copy the second HTTP address; paste in a new browser window or Tab to see original page
miesk5 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  FSB Forums > Bronco Discussions > Noobie Bronco Tech Questions. Flame free zone!


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 02:03 PM.


2003-2009 FullSizeBronco.com. All rights reserved