Mystery Fuel Injector Harness Part - FSB Forums
Register Home Forums Active Topics Photo Gallery All Albums Mark Forums Read Auto EscrowInsurance FSB Store
FullsizeBronco.com is the premier Ford Bronco Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools Display Modes
Old 11-20-2012, 11:46 AM   #1
fishingnut
Registered User
 
Join Date: Jun 2012
Location: New Orleans, LA
Posts: 11
iTrader: (0)
Bronco Info: 86 XLT
Mystery Fuel Injector Harness Part

I have an 86 Bronco. It has developed an ENORMOUS amount of pressure and smoke in the crank case. So much so that if the hose between the oil cap and the breather comes off the engine smokes like it's on fire at every stop sign.

Does anyone have any idea what might be causing this? It isn't running great, but it does seem to idle fine. Hasn't had any top end for some time, and the problem is noticibly worse when the weather is hot. It's fairly cool down here now, so I'm able to get up to 65 or 70 MPH. When the weather is warm 50MPH is about all I can get. Someone told me that there's some sort of ventilation filter on the back side of the block, nearest the firewall, that I need to pull out and clean. I could use some direction here. I'm not even sure what to google to find out what he was talking about.

My next problem. After checking the oil the other day the hose between the oil cap and the breather came off. While I was reconnecting it I found what appeared to be a loose connector that seemed to be part of the harness for the fuel injection. On closer inspection it seems to be a plug from the harness with whatever it was plugged into broken off inside the plug. This plug seems to be bundled with one of the injectors wires on the driver's side, just under the hose between the oil cap and breather. Can anyone help me identify what this is? I'm thinking this might be part of my over all trouble.

Thanks in advance for any help.
fishingnut is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 11-20-2012, 11:53 AM   #2
Ewgoetz
FSM Lifetime
 
Ewgoetz's Avatar
 
Join Date: Jan 2010
Location: Venice, FL
Posts: 3,526
iTrader: (1)
Bronco Info: 1996 EB Bronco 5.8, E4OD, BW1356 Transfercase, 6 inch BDS Lift w/Procomp Leafs, 200,010Miles
This thread is pointless with out pics.
As for the breather hose, sounds like you have worn out pistons or rings.... Or both. Get a compression check and see what the numbers are.
__________________
"hold my beer and watch this"
Hydroboost walkthrought

My Build Thread!! II

My Build Thread!! - retired
Ewgoetz is offline   Reply With Quote
Old 11-20-2012, 11:59 AM   #3
Steve83
Registered User
 
Steve83's Avatar
 
Join Date: Jul 2003
Location: Memphis, TN
Posts: 34,843
iTrader: (100)
Bronco Info: '83 VIN & title on '93 frame/body w/'95 4.9L & EB paint
Quote:
Originally Posted by fishingnut View Post
It's fairly cool down here now...
WHERE? Read this caption, then fill in your profile & signature.

Quote:
Originally Posted by fishingnut View Post
...some sort of ventilation filter on the back side of the block, nearest the firewall, that I need to pull out and clean.


But the damage is probably already done. Do this test:

Quote:
Originally Posted by fishingnut View Post
Can anyone help me identify what this is?
There's a thread at the top of this forum for identifying parts. If you want any more help with it, post your own pics:
http://www.supermotors.net/forums/th...-and-or-videos
__________________
Walk softly & carry a BIG SIX ! ! !

. .
Steve83 is offline   Reply With Quote
Old 11-20-2012, 12:17 PM   #4
fishingnut
Registered User
 
Join Date: Jun 2012
Location: New Orleans, LA
Posts: 11
iTrader: (0)
Bronco Info: 86 XLT
OK. I'll do the compression check on Friday and post a pic of the piece of the harness that's below the crankcase vent hose, just aft of the oil filler cap.
fishingnut is offline   Reply With Quote
Old 11-20-2012, 12:50 PM   #5
theramsey3
#1 Asshole
 
theramsey3's Avatar
 
Join Date: Mar 2010
Location: starke fl
Posts: 1,452
iTrader: (2)
Bronco Info: 90 5.0 H.O. E4OD BW1356 3.54 3L55 32/11.50R15 Black not the one in the pic ^^^
perhaps something like a pcv valve would help reduce the amount of smoke coming from the breather? just a suggestion. Have you done anything to vacuum hoses or removed the intake lately? The PCV is located under the intake at the rear of the passenger side valve cover.
__________________

Gotta get going again soon. my supermotors for before and after.
Quote:
Originally Posted by ford_munky_man View Post
I was always taught u got to lube it up before you stick it in. My friends said the teacher yesterday said that too.
theramsey3 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  FSB Forums > Bronco Discussions > Noobie Bronco Tech Questions. Flame free zone!


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 05:11 PM.


2003-2009 FullSizeBronco.com. All rights reserved