96 351w supercharged problems - FSB Forums
Register Home Forums Active Topics Photo Gallery All Albums Mark Forums Read Auto EscrowInsurance FSB Store
FullsizeBronco.com is the premier Ford Bronco Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools Display Modes
Old 01-16-2013, 07:22 PM   #1
86oleblue
Registered User
 
86oleblue's Avatar
 
Join Date: Sep 2009
Posts: 249
iTrader: (0)
Bronco Info: 1986 5.0, 33's and procomp 15's. stock for now
96 351w supercharged problems

Sup guys,
Well this is my brothers truck. He bought it has a power dyne supercharger on it. It ran great for awhile and started to buck around 30 mph 3rd gear. I took it to my local mechanic and they thought it was fuel injectors since they were stock and it was supercharged. Well we called a guy in town that tunes so,he said its needs 42 lb injectors so I get them and put them in and it would start just ran like crap. Well we took it to him he tuned it says it has a good tune and it would idle great you could rev up and dent things would turn up....well when u go to put in gear and get on it will shut right off....we replaced module coil pack and distributor ....none of it has fixed it and it also has great fuel pressure...anyone that's knows these computers or trucks....we need help don't understand what goin on....sry this is so long just running out of options...thanks any help is appreciated

Jason
86oleblue is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 01-16-2013, 07:54 PM   #2
RngTrtl
Registered User
 
RngTrtl's Avatar
 
Join Date: Mar 2010
Location: Jackson, MS
Posts: 219
iTrader: (0)
Bronco Info: 1994 5.8L, Auto, 1356
i have experience with forced induction and I can say that one really had to know what they are doing to be able to make it work right, or have the money to pay someone who does. What your bro is trying to make work is not a trivial endevour.
__________________
1994 Ford Bronco, 5.8L, E40D Auto, 4wd
1987 Ford Bronco II, 5.0L, AOD Auto, 4wd
1985 Porsche 928, 5.0L 32V V-8
1991 Suzuki Katana, 1100cc
2000 Ford Focus Wagon (wifes grocery getter)
RngTrtl is offline   Reply With Quote
Old 01-16-2013, 08:09 PM   #3
Diabolic
Registered User
 
Join Date: Oct 2012
Posts: 215
iTrader: (0)
Ok first of all you need a wideband on that thing or you are just guessing. Take off the belt and floor it. Does it fall on its face? What are the plugs gapped at? Did you remove the FMU when you went with larger injectors?
__________________
1995 Bronco, OJ Edition, 5.8/E4OD, Towing Package, LS 3.55's, 32/11.50/15's, 15x10 wheels, Warn Manual Premium Hubs, Panel K&N, Moates QH. Stock as a rock.
Diabolic is offline   Reply With Quote
Old 01-16-2013, 08:13 PM   #4
Diabolic
Registered User
 
Join Date: Oct 2012
Posts: 215
iTrader: (0)
If it's hard to start and runs bad then he didn't adjust for the 42's right. Sounds like its dumping too much fuel. I'd throw a 12:1 FMU and the 19# injectors back in there.
__________________
1995 Bronco, OJ Edition, 5.8/E4OD, Towing Package, LS 3.55's, 32/11.50/15's, 15x10 wheels, Warn Manual Premium Hubs, Panel K&N, Moates QH. Stock as a rock.
Diabolic is offline   Reply With Quote
Old 01-16-2013, 08:18 PM   #5
86oleblue
Registered User
 
86oleblue's Avatar
 
Join Date: Sep 2009
Posts: 249
iTrader: (0)
Bronco Info: 1986 5.0, 33's and procomp 15's. stock for now
It runs perfect in idle u can rev it up runs perfect until a load....fmu? Not sure what that is....the spark plugs not sure on that either didn't adjust....I know it shuts off like u turned it off and the lights come on on the dash
86oleblue is offline   Reply With Quote
Old 01-16-2013, 08:25 PM   #6
86oleblue
Registered User
 
86oleblue's Avatar
 
Join Date: Sep 2009
Posts: 249
iTrader: (0)
Bronco Info: 1986 5.0, 33's and procomp 15's. stock for now
There was already aftermarket fmu on it
86oleblue is offline   Reply With Quote
Old 01-16-2013, 09:40 PM   #7
Diabolic
Registered User
 
Join Date: Oct 2012
Posts: 215
iTrader: (0)
If you have 42's and a tune there is absolutely no need for an FMU. If the tuner looked at it and didn't notice it then he sucks bad and I wouldn't use his tune. As soon as you hit even a little boost you are waaaaay flooding the engine with that FMU. Options.....

Reinstall the stock 19's and keep the FMU. Lets hope it's a 12:1 FMU disk.
Or
Remove FMU, have the tuner decrease the injector minimum pulse width during crank mode.
__________________
1995 Bronco, OJ Edition, 5.8/E4OD, Towing Package, LS 3.55's, 32/11.50/15's, 15x10 wheels, Warn Manual Premium Hubs, Panel K&N, Moates QH. Stock as a rock.
Diabolic is offline   Reply With Quote
Old 01-16-2013, 10:38 PM   #8
bluebolt
Fullsize Member
 
Join Date: Oct 2012
Location: Benton LA near Shreveport
Posts: 187
iTrader: (3)
Bronco Info: 1974 Bronco with 351w, 1978 F150 4x4 with 1966 F100 cab
A few questions:

What did the "tuner" use to tune it? Did he actually change the computer settings?

A 96 is OBDII, do you have a check engine light? Engine codes if you do?

This is a Mass Air truck right? Normally the mass air is calibrated for a particular size injectors, was there any change to the mass air meter?

And you say it ran great at one time, how long did that last? Days, weeks, months?
bluebolt is offline   Reply With Quote
Old 01-17-2013, 06:46 AM   #9
86oleblue
Registered User
 
86oleblue's Avatar
 
Join Date: Sep 2009
Posts: 249
iTrader: (0)
Bronco Info: 1986 5.0, 33's and procomp 15's. stock for now
Months it ran fine...he actually has a dyno and computer software not sure what though....no engine codes......no change to mass air.....it ran great before it started bucking and we changed injectors amd tuned and wont run when u go to get on it. Could too much fuel from fmu be making the computer shut it down
86oleblue is offline   Reply With Quote
Old 01-17-2013, 08:02 AM   #10
Swat
Fullsize Member
 
Swat's Avatar
 
Join Date: Dec 2005
Location: Littleton, Colorado
Posts: 3,810
iTrader: (7)
Bronco Info: 1993 F150 Flare Side
It should be throwing codes and a cell. These rigs will usually tell you what's wrong. You can, in some cases tune around a faulty part, but you shouldn't. The engine has to be mechanically sound and all the electronics working right before a tune.

Sound like something with the EEC, ignition, or even a relay if it just shuts down.

I tried a Powerdyne on a 1990 with speed density. It never ran to it's potential and once I pushed=it up to 9lbs of boost I lost a head gasket from predentonation. I had a bunch of problems with it till I did a mass air conversion, added a higher volume fuel pump, larger injectors, and a good tune with a Tweecer. Anything less thana good tune with a custom chip, Tweecer or Moates tuner is a band-aid!

The problem came before the tune, something else is wrong and the tuner should have caught that.

How much boost?

Did your tuner burn a chip, make a custom tune and install it?
__________________
01, Ranger Edge 4X4, 4.10's and 32's......getting "Super" status in 2014.
Swat is offline   Reply With Quote
Old 01-17-2013, 08:14 AM   #11
86oleblue
Registered User
 
86oleblue's Avatar
 
Join Date: Sep 2009
Posts: 249
iTrader: (0)
Bronco Info: 1986 5.0, 33's and procomp 15's. stock for now
Yea he put on dyno and went in with his laptop but never could really never do anything cause of it shutting off
86oleblue is offline   Reply With Quote
Old 01-17-2013, 08:15 AM   #12
86oleblue
Registered User
 
86oleblue's Avatar
 
Join Date: Sep 2009
Posts: 249
iTrader: (0)
Bronco Info: 1986 5.0, 33's and procomp 15's. stock for now
Eec?
86oleblue is offline   Reply With Quote
Old 01-17-2013, 08:30 AM   #13
Diabolic
Registered User
 
Join Date: Oct 2012
Posts: 215
iTrader: (0)
Now we are getting somewhere. So when you floor it the Bronco dies completely and you have to restart it? This only happens at wot? What about part throttle but using half like trying to go 90mph?. I would suspect a bad tps or MAF Meter.

Why did the tuner leave the FMU hooked up with 42's? What MAF meter does it have? Can you list all the mods?

Since the tuner couldn't go to full throttle he really tuned almost nothing. I would resolve this and ask for another tune.
__________________
1995 Bronco, OJ Edition, 5.8/E4OD, Towing Package, LS 3.55's, 32/11.50/15's, 15x10 wheels, Warn Manual Premium Hubs, Panel K&N, Moates QH. Stock as a rock.
Diabolic is offline   Reply With Quote
Old 01-17-2013, 08:45 AM   #14
86oleblue
Registered User
 
86oleblue's Avatar
 
Join Date: Sep 2009
Posts: 249
iTrader: (0)
Bronco Info: 1986 5.0, 33's and procomp 15's. stock for now
Well i went there yesterday to check it out they put the new distributor in and pulled it out and went to go not full throttle like 1/4 throttle and dies like u turned the key off....so i jump in it and go in reverse it idles fine and revved it to about 3500 no problems. Put it in drive and shut off...started back and put in drive was good and gave it a bump of gas and it shut off...will sit and idle all day but once under load nope. As far as maf its the oem one.....and i always wondered what the fmu was and finally figured out it had one when he bought it....as far as mods just injectors power dyne and headers . Its just super weird cause it never did what it was doin....the only thing it did before was kinda the same thing it woulf shut off randomly at like say a light or whatever but u could go 1 day or 7 without it doing it.....and i dont want him to keep sinking money in it if they cant figure it out but we just cant take it because of the tune on it after we already put time into the injectors....
But 42s do seem very drastic for 5 lbs of boost.....and thanks guys for the help i know alot of u know a bunch about these motors....
86oleblue is offline   Reply With Quote
Old 01-17-2013, 10:49 AM   #15
kemicalburns
Never Done
 
kemicalburns's Avatar
 
Join Date: Mar 2003
Location: OC,Oregon
Posts: 6,486
iTrader: (5)
is the blow off valve working properly? get that fmu out of there, you didnt really say if you did that or not.

only 5lbs of boost? perhaps those 42's are to big as well? I also didnt think the stock fuel pump in our broncos could handle forced induction fuel needs and thats why folks have upgraded to the walbro pump???
__________________
94 XLT 357/E4OD Trans-go stage II
6" Stage II ProComp,35x12.50BFG/AT
4.88 f (aussie) / r (open) / Custom Sliders
JBA headers,Custom Y pipe hi flow cat & Full 3"
kemicalburns is offline   Reply With Quote
Old 01-17-2013, 10:52 AM   #16
Diabolic
Registered User
 
Join Date: Oct 2012
Posts: 215
iTrader: (0)
Fuel pressure needs to be verified first. First when u rev it at idle and again when it stalls.
__________________
1995 Bronco, OJ Edition, 5.8/E4OD, Towing Package, LS 3.55's, 32/11.50/15's, 15x10 wheels, Warn Manual Premium Hubs, Panel K&N, Moates QH. Stock as a rock.
Diabolic is offline   Reply With Quote
Old 01-17-2013, 02:58 PM   #17
86oleblue
Registered User
 
86oleblue's Avatar
 
Join Date: Sep 2009
Posts: 249
iTrader: (0)
Bronco Info: 1986 5.0, 33's and procomp 15's. stock for now
Fmu is still there havnt had a chance to talk to them....they say fuel pressure stays good
86oleblue is offline   Reply With Quote
Old 01-17-2013, 03:08 PM   #18
86oleblue
Registered User
 
86oleblue's Avatar
 
Join Date: Sep 2009
Posts: 249
iTrader: (0)
Bronco Info: 1986 5.0, 33's and procomp 15's. stock for now
Well my brother said hes done with it. They keep dickin around should he get it tuned back to stock
86oleblue is offline   Reply With Quote
Old 01-17-2013, 03:44 PM   #19
kemicalburns
Never Done
 
kemicalburns's Avatar
 
Join Date: Mar 2003
Location: OC,Oregon
Posts: 6,486
iTrader: (5)
Find another shop
__________________
94 XLT 357/E4OD Trans-go stage II
6" Stage II ProComp,35x12.50BFG/AT
4.88 f (aussie) / r (open) / Custom Sliders
JBA headers,Custom Y pipe hi flow cat & Full 3"
kemicalburns is offline   Reply With Quote
Old 01-17-2013, 03:57 PM   #20
86oleblue
Registered User
 
86oleblue's Avatar
 
Join Date: Sep 2009
Posts: 249
iTrader: (0)
Bronco Info: 1986 5.0, 33's and procomp 15's. stock for now
They bypassed fmu
86oleblue is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  FSB Forums > Bronco Discussions > 1980-'96 Bronco Tech


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 02:47 AM.


2003-2009 FullSizeBronco.com. All rights reserved