What did you do to your bronco today? - Page 867 - Ford Bronco Forum
 8915Likes
 
LinkBack Thread Tools Display Modes
post #17321 of 18379 (permalink) Old 03-31-2019, 04:12 PM
Registered User
 
Tkd001's Avatar
 
Join Date: Jul 2018
Location: Austin, TX
Posts: 77
Bronco Info: 1991 Eddie Bauer, 5.8L 351w, E4OD
iTrader: (0)
Garage
Replaced all the lug nuts and gave it a wash.
Tkd001 is offline  
Sponsored Links
Advertisement
 
post #17322 of 18379 (permalink) Old 03-31-2019, 09:36 PM
Registered User
 
makersneat's Avatar
 
Join Date: Mar 2017
Location: Sierra Madre, CA
Posts: 398
Bronco Info: 1991 XLT/351w/E4OD/3" lift/4.56/33" tires/LS FR+RR
iTrader: (0)
Garage
Failed CA smog today...I had to spend $60 to be told I'm a failure... runs clean but failed the EVAP test.... However, I'm a little warry of the results cuz I had to tell the guy where the EVAP canister was so he could pinch it off with his oversized roach clip.. Who knows if he's even running his test equipment right...

Next step for me is to inspect possible gaps. If I can't find any, either I can have the system pressure tested or take it to another shop for smog test.... Last year it failed cuz it ran dirty.. EVAP was fine, so I'm a little crossed. This year it's the reverse. I've read where people have filled their gas tanks to pass EVAP... What do you think?

I used have a guy who would fudge it to pass. His shop closed.. probably got pinched by the law.

makersneat is offline  
post #17323 of 18379 (permalink) Old 03-31-2019, 10:16 PM
House of Windsor 4ever!
 
Handy_andy_cv64's Avatar
 
Join Date: Jul 2006
Location: Everett, WA
Posts: 10,440
Bronco Info: 79 Ranchero GT "Babe the Blue Ox"/97 Eddie Bauer Exploder 5.0 AWD
iTrader: (2)
Garage
Full tank is fine, just don't overfill it. Getting gasoline in someone's expensive test equipment, I hear, can have dire consequences. Just make sure each rubber hose is not split or dry, and all components are fully installed in the tank. I once had something pop the rollover valve out of Eddie's tank (likely heat/vapor expansion) because the factory rubber ring was dry rotted. dumped a gallon or more of gas on the ground before I discovered it.

Quote:
That battery is barely over 1 yr. so if it's gone bad, I should have a replacement coming.
We'll see how it goes today after trickle charging over-night.
Make sure the main cable connections at the battery and on the solenoid are clean and tight. Turn on the headlights for a quick check of whether you actually have juice flowing into the harness.
BikerPepe` likes this.

_____________________________________________

LINK??? Link yourself down to Walmart!
Handy_andy_cv64 is offline  
post #17324 of 18379 (permalink) Old 04-01-2019, 01:56 PM
Registered User
 
TheHalfJamaican's Avatar
 
Join Date: Sep 2018
Location: Peach State
Posts: 113
Bronco Info: 1988 Bronco XLT 302, M5OD, 32" BF Baja Champions
iTrader: (0)
Garage
Well, I haven't done it YET, but...
My power steering hose is leaking like a sieve. The truck originally had no power steering, so I bought a new pump, but I kept the hose that came with it. It started leaking so I pulled one off some junkyard truck which unsurprisingly, also started leaking. This time, it was far worse: the blow-back was so bad that the whole corner of the engine (along with my spot where I park) was coated in a thin layer of power steering fluid. So I broke down and bought a new hose for the pump. I was nervous initially, because it didn't come with the pressure switch, but when I got it, I noticed that it had a hole to screw the switch into on the bottom end of the hose. So hopefully I can get that sorted out after work today, 'cause I can't stand that whining...

TheHalfJamaican
TheHalfJamaican is offline  
post #17325 of 18379 (permalink) Old 04-02-2019, 03:20 AM
House of Windsor 4ever!
 
Handy_andy_cv64's Avatar
 
Join Date: Jul 2006
Location: Everett, WA
Posts: 10,440
Bronco Info: 79 Ranchero GT "Babe the Blue Ox"/97 Eddie Bauer Exploder 5.0 AWD
iTrader: (2)
Garage
Wassa matta, you don't like Moaning Sickness?
White Dragon likes this.

_____________________________________________

LINK??? Link yourself down to Walmart!
Handy_andy_cv64 is offline  
post #17326 of 18379 (permalink) Old 04-02-2019, 09:39 AM
Fullsize Member
 
joshbronco's Avatar
 
Join Date: May 2003
Location: Torrance, CA
Posts: 305
Bronco Info: 89 Bronco, EB 302eng,sixlitre tune up,Edelbrock Upper/Lower & headers,Eaton rear, 192,000+
iTrader: (1)
Discovered a coolent leak at the lower rad hose to waterpump. Guess I'll be dropping the truck off later this week for repair. Not sure I'll be able to get to it this weekend.

joshbronco is offline  
post #17327 of 18379 (permalink) Old 04-02-2019, 05:18 PM
Registered User
 
youngDUMP's Avatar
 
Join Date: Feb 2016
Location: North MS
Posts: 264
Bronco Info: 1989 EB Bronco, 5.0, AOD, 5.5" lift, 35" tires, 4.56s, locked fr/LS rr
iTrader: (0)
Dropped my fuel tank and ordered a new one. The right front corner had been repaired by the PO with some epoxy putty and it started leaking. Rockauto had the best price around. After shipping the beat the zone by $20 and the NAPA by $50. It was $98 shipped. Should be here Monday
BikerPepe`, TS 90F150 and latvius like this.

IG @schaeferlight
youngDUMP is offline  
post #17328 of 18379 (permalink) Old 04-06-2019, 12:40 AM
Registered User
 
youngDUMP's Avatar
 
Join Date: Feb 2016
Location: North MS
Posts: 264
Bronco Info: 1989 EB Bronco, 5.0, AOD, 5.5" lift, 35" tires, 4.56s, locked fr/LS rr
iTrader: (0)
New tank came in today. Got it installed after work and my top bolted back down. Put 5 gallons of gas in. That should get me to the gas station, Iím driving it to work tomorrow.
EMO42 and Frank Lanzisera like this.

IG @schaeferlight
youngDUMP is offline  
post #17329 of 18379 (permalink) Old 04-06-2019, 12:56 AM
TTB makes me sad
 
Ford 4x4's Avatar
 
Join Date: Aug 2007
Location: The Big D
Posts: 132
Bronco Info: 1996 XLT 5.8 E4OD 6" lift? on 33s manual hubs
iTrader: (0)
@youngDUMP , did you get one with a complete Spectre with fuel pump and sender from Rock Auto? I got one for the rear tank on my F150 and it's already having issues when it's hot not wanting to run right and it has less than 1000 miles on it.

96 XLT Green 5.8 E4OD on 33s
Ford 4x4 is online now  
post #17330 of 18379 (permalink) Old 04-06-2019, 10:42 AM
Registered User
 
Bogie's Avatar
 
Join Date: Apr 2012
Location: Catawba, WI
Posts: 154
Bronco Info: 92 Eddie Bauer, 5.0, 15X10 Outlaw II's/33-12.50 BFG KO2, 2" lift
iTrader: (0)
Replaced my keyless entry module. The one I installed 7 years ago gave up the farm.
Bogie is offline  
post #17331 of 18379 (permalink) Old 04-06-2019, 02:10 PM
Registered User
 
youngDUMP's Avatar
 
Join Date: Feb 2016
Location: North MS
Posts: 264
Bronco Info: 1989 EB Bronco, 5.0, AOD, 5.5" lift, 35" tires, 4.56s, locked fr/LS rr
iTrader: (0)
Quote:
Originally Posted by Ford 4x4 View Post
@youngDUMP , did you get one with a complete Spectre with fuel pump and sender from Rock Auto? I got one for the rear tank on my F150 and it's already having issues when it's hot not wanting to run right and it has less than 1000 miles on it.


I got the spectra premium F8E tank from them. I reused the sending unit that was in the old tank as well as the rubber sounding unit gasket from the old tank. The gasket that came with the tank was very dinky compared to the other. The sending unit looked to have been replaced by the PO but Iím not sure what brand or where from.

IG @schaeferlight
youngDUMP is offline  
post #17332 of 18379 (permalink) Old 04-06-2019, 08:38 PM
Fullsize Member
 
Frank Lanzisera's Avatar
 
Join Date: Nov 2018
Location: Tampa
Posts: 309
Bronco Info: 95 XLT 5.8 E4OD auto xfer/hubs
iTrader: (0)
Put a gauge on the A/C low pressure port to check her out.
Frank Lanzisera is offline  
post #17333 of 18379 (permalink) Old 04-06-2019, 10:10 PM
Registered User
 
Rlsfoot12's Avatar
 
Join Date: Apr 2019
Location: New Kent Va
Posts: 99
Bronco Info: 1993
iTrader: (0)
Garage
I got the 4Ē lift installed on the rear end today and put the 35Ē tires on it ..work is in progress
Frank Lanzisera likes this.
Rlsfoot12 is offline  
post #17334 of 18379 (permalink) Old 04-06-2019, 10:12 PM
Fullsize Member
 
67galax's Avatar
 
Join Date: Nov 2005
Location: Southeast Iowa
Posts: 1,053
Bronco Info: 1996 XLT currently motorless, ZF5 trans, sitting on old 33's
iTrader: (0)
Garage
Rusty Red got a workout today.

I took a load of junk to the dump, then went to the junkyard to see if anything new had shown up.

Then I went to the quarry to get some road rock to fill in some pot holes. I told them 1500 lbs. Only got around 1200. Filled what holes I could and went back. Asked to make sure they gave me 1500 this time, and the loader gave me 2400. Smartass.





After that, I hooked up the winch and pulled some downed tress up the hill and chainsawed them into firewood.

If its not raining tomorrow, I'll probably continue.

It's Hard To Beat A Good Sandwich
67galax is online now  
post #17335 of 18379 (permalink) Old 04-07-2019, 03:30 PM
Fullsize Member
 
Frank Lanzisera's Avatar
 
Join Date: Nov 2018
Location: Tampa
Posts: 309
Bronco Info: 95 XLT 5.8 E4OD auto xfer/hubs
iTrader: (0)
Hooked her up to the skiff for first trailer trip.
Attached Thumbnails
Click image for larger version

Name:	7203FF9A-B76A-4912-AEF9-7A591C8E7F99_1554665385090.jpg
Views:	16
Size:	573.8 KB
ID:	134756  

Click image for larger version

Name:	57F9C4DF-FF06-4267-91AE-5F2B1FE4B246_1554665406378.jpg
Views:	13
Size:	546.1 KB
ID:	134758  

Click image for larger version

Name:	A7F756DE-94DE-4DE6-A927-E0B990DB2D4E_1554665419987.jpg
Views:	14
Size:	582.9 KB
ID:	134760  

Frank Lanzisera is offline  
post #17336 of 18379 (permalink) Old 04-07-2019, 06:05 PM
Fullsize Member
 
Join Date: May 2009
Location: Upstate SC
Posts: 1,668
Bronco Info: 1990 F150, 5.8 w/GT40X heads, Lightning intake, E4OD, 33" tires, detroit locker rear & true trac fro
iTrader: (5)
Quote:
Originally Posted by 67galax View Post
Rusty Red got a workout today.

I took a load of junk to the dump, then went to the junkyard to see if anything new had shown up.

Then I went to the quarry to get some road rock to fill in some pot holes. I told them 1500 lbs. Only got around 1200. Filled what holes I could and went back. Asked to make sure they gave me 1500 this time, and the loader gave me 2400. Smartass.





After that, I hooked up the winch and pulled some downed tress up the hill and chainsawed them into firewood.

If its not raining tomorrow, I'll probably continue.
That is a good looking truck. Hope you have plans to fix and maintain it as well. :)

tim
Frank Lanzisera likes this.
TS 90F150 is offline  
post #17337 of 18379 (permalink) Old 04-07-2019, 06:43 PM
Registered User
 
Rlsfoot12's Avatar
 
Join Date: Apr 2019
Location: New Kent Va
Posts: 99
Bronco Info: 1993
iTrader: (0)
Garage
Got the engine out of my 93 today in the gravel driveway.. use of tractor helped a lot
Going to take off the front 4Ē liftoff wrecked 96 tomorrow during daylight and install on 93 later this week I hope to
Rlsfoot12 is offline  
post #17338 of 18379 (permalink) Old 04-07-2019, 06:54 PM
Registered User
 
johnnyk8's Avatar
 
Join Date: Nov 2014
Location: Rockton IL
Posts: 531
Bronco Info: 1984 Rebuilt 5.0 Free Wheeling Package
iTrader: (0)
Garage
Put it up for sale. The market is RIPE for Broncos right now. I wish people would stop asking for a trade though.

Only gonna last about a week I bet. Listed at$6k

We'll get another one I'm sure.

Sent from my Lenovo TB-8504F using Tapatalk

1984 Full Size Ford Bronco w rebuilt 302 and Auto w/OD
Lotsa Rust - Lotsa Noise - Lotsa fabricating
Project Alpha Bronco
F.O.T.M Nominee for July - Get Out the Vote
johnnyk8 is offline  
post #17339 of 18379 (permalink) Old 04-07-2019, 07:28 PM
Fullsize Member
 
Ogeechee 4x4's Avatar
 
Join Date: May 2003
Location: Brooklet, Georgia
Posts: 7,409
Bronco Info: '95 Bronco, 351W, NP435/205, Solid D44 front, 35" MTR's, 3.55 gears
iTrader: (12)
Made a catback exhaust. Single 3” with 12” glasspack. Figured I’d try something different and have it exit in front of the rear tire.

Fired it up and noticed that the odo wasn’t working. #8 fuse was blown. It’s a 15 amp. I installed a 20 amp and it immediately blew. Went to disconnect negative battery cable and the terminal fell apart in my hand.

Soo.... Bronco still doesn’t run.

My SuperFord
'95 Eddie Bauer-- 351W, NP435/205, D44 SAS
Ogeechee 4x4 is offline  
post #17340 of 18379 (permalink) Old 04-07-2019, 08:16 PM
House of Windsor 4ever!
 
Handy_andy_cv64's Avatar
 
Join Date: Jul 2006
Location: Everett, WA
Posts: 10,440
Bronco Info: 79 Ranchero GT "Babe the Blue Ox"/97 Eddie Bauer Exploder 5.0 AWD
iTrader: (2)
Garage
Geech! How are ya, man?! Long time, no see!

_____________________________________________

LINK??? Link yourself down to Walmart!
Handy_andy_cv64 is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Bronco Forum > Other Forums > General Discussion/ Bronco and Wheeling related.

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Bronco Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself. DO NOT USE Gmail.com accounts. If you only have a Gmail.com email please contact the administrator here

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome