Ford Bronco Forum - View Single Post - Defective Parts Listing
View Single Post
post #17 of (permalink) Old 12-03-2010, 08:58 PM
RickyB
OUT OF BUSINESS / M.I.A
 
Join Date: Feb 2008
Location: Redondo Beach, Cali
Posts: 4,659
Bronco Info: '87 XLT, new crate 5.0, rebuilt AOD, new 31"s, new Warn Premiums, all stock w/125K original miles
iTrader: (2)
Quote:
Originally Posted by Mudman78 View Post
Been running ANCO winter blades for years. The blade rubber is so thick I can get almost two years out of the blades before they start streaking and need to be replaced. Regular ANCO's......six months.
For whatever reason, Walmart and everyone for that matter, stopped carrying them. Every time I went to a different state, I would check Walmart's clearance section and a couple times i got lucky, but my stock didn't last long. I switched to NAPA winter blades. They cost more and I only got a little less than a year out of them.
Finally, the othert day, I noticed Walmart started carrying the winter blades again, so I stocked up for all the vehicles (didn't care how much they cost). They fit with no problems at all. I just went and checked the packaging after reading the first post and they're made in Mexico, which I'm now considering the new USA, since we don't manufacture anything anymore. Everything I have that's made in Mexico (auto parts, power tools, etc.) are a thousand times better quality than any Chinese crap out there.
I've always been a "Made in USA" guy, but since that label is more scarce that Bigfoot these days.........VIVA LA MEXICO!!!
The only bitch I have about some of the Mexi stuff were my (early 2000's) Makita tool switches dying an early death. Like on 5 different tools. Hopefully they've ramped it a notch since then........
RickyB is offline  
 
 
For the best viewing experience please update your browser to Google Chrome