Wipers not working - Ford Bronco Forum
 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 07-31-2018, 02:52 PM Thread Starter
Registered User
 
Join Date: Dec 2015
Posts: 98
Bronco Info: 1996 EB Bronco, 4.09 LSD D44, 4.10 Track lock 8.8, 2" lift/leveled, 351W complete rebuild
iTrader: (0)
Wipers not working

I have a wiper issue and wanted to ask a few questions.

With the truck turned off, should I be able to actuate the wipers by hand? If the wiper motor is getting power as it should but the motor is seized up, should I still hear the relay clicking or not?

I ask because the wipers worked perfect last year. I bought a new switch and installed new blades and all was well. This year they won't turn on at all, thinking I forgot to plug in the harness I popped the hood and inadvertently placed my hand on the motor as I was wiggling the connector and found that it was burning hot. After I let it cool, I plugged in the harness with the wiper switch off and still the motor got extremely hot very quickly. The fuse has not blown. Anyone come across this before? There's a lot of wiper stuff that I had read but most of it is wipers acting crazy and no posts mention if I should be able to actuate by hand. Any help is appreciated.
ZackAttack is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 07-31-2018, 04:32 PM
Moderator
 
miesk5's Avatar
 
Join Date: Oct 2003
Location: Coronado, CA
Posts: 22,531
Bronco Info: 96 Bronco XL 5.0 E4OD, Man Xfer/Hubs
iTrader: (2)
Garage
Yo Zack,
Please fill out your Bronco Info with year, engine size, transmission type, transfer case type (manual or electric shift), locking hub type (automatic or manual) info & major mods such as a Lift, etc. for better responses.
Click User CP
Edit Your Details,
Scroll down to Bronco Info

For now:
Windshield Wipers Inoperative — All Control Switch Positions
Blown fuse.
Windshield wiper motor.
Multi-function switch.
Bent or damaged windshield wiper motor linkage.
Wiper control module.
Open wire or connector.

See my partially recovered Bronco web site. Thanks to Mr. Schwim!
Navy & DoD (retired) ... THANKS to ALL WHO SERVE!
Please Participate & VOTE in our Full-Size of the Month (F.O.T.M.) & Full-Size of the Year (F.O.T.Y.) Contests[/B] @ https://www.fullsizebronco.com/forum/27-f-o-t-m-voting/
miesk5 is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Bronco Forum > Bronco Discussions > 1980-'96 Bronco Tech

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Bronco Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself. DO NOT USE Gmail.com accounts. If you only have a Gmail.com email please contact the administrator here

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome