Ford Bronco Forum - Reply to Topic
Thread: What did you do to your bronco today? Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 
   

Register Now



In order to be able to post messages on the Ford Bronco Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself. DO NOT USE Gmail.com accounts. If you only have a Gmail.com email please contact the administrator here

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
Today 04:30 AM
BikerPepe` Spent 5 hours drilling in to remove a broken motor mount bolt on Dad's 400, on the stand.
3 bits and maybe 1/2" of progress. Yay.
Yesterday 09:36 PM
Desert Bronco Qk, so yesterday I put 50 miles on the Holley Sniper kit. Soooo much better than the AFB ... I have a vacuum leak but no biggie.
Yesterday 07:46 PM
bsd4083 I DID THE IMPOSSIBLE: (not moving)

While sitting in the drive-thru line at a Dunking doughnuts.. I seized up the 15monthold smog-pump and shredded the serpentine belt in about 10 seconds.. there goes another 240$ wow...
Yesterday 05:53 PM
Handy_andy_cv64
Quote:
Originally Posted by Kingfish999 View Post
Spent most of the day diagnosing my misfire issue. Found out it was the fuel injector on cylinder 1 not firing. Eventually found the PCM was burnt. Swapped a damaged one in for now. Seems good.
Dad's #4 injector is dumping fuel, and I'm hoping it's just a bad injector, but since I worked on the engine nearly two years ago and I had done stupid things, I won't rule out something I did just yet. But I'm glad you found the problem quickly.
Yesterday 03:41 PM
oshere Went topless

Sent from my SM-N920V using Tapatalk
Yesterday 09:26 AM
92BroncoXLT Got two of the 6 rivets knocked out of the passenger beam mount on the crossmember.

At this rate ill finish this lift install sometime between next month and 3 years from now
09-15-2019 09:14 PM
Ford 4x4 Put in a new coil, cap, and rotor. New wires and plugs to come.
09-15-2019 09:03 PM
Kingfish999 Spent most of the day diagnosing my misfire issue. Found out it was the fuel injector on cylinder 1 not firing. Eventually found the PCM was burnt. Swapped a damaged one in for now. Seems good. Rain killing most of the day. Did replace the coil with a Holley Sniper EFI coil which is basically a ordinary TFI coil but with a cool remote mount bracket and only cost like 40$ which I need due to my aftermarket mustang style intake manifold. Old coil was an Accel Ultracoil which was also remote mount
09-15-2019 04:23 PM
Frank Lanzisera Front and rear plastics done
09-15-2019 01:27 PM
Want2BS8ed Cleaned her up inside and out and moved all my junk back in after the engine swap.

Nice to have the truck back.
09-15-2019 12:50 PM
BroncMom Pulled the cargo panel mounting bars and the rear speaker mounting brackets in prep for rust removal & monstaliner application this week. Hubby's bringing home an angle grinder for me to play with
09-15-2019 12:26 PM
biggum Tried out my Holley mods on some steep stuff final. Works great!


Sent from my iPhone using Tapatalk Pro
09-15-2019 08:28 AM
MS88Bronc Went to play in the rocks and dirt yesterday. Will be posting more pics and vids in the FOTM thread soon - need to figure out how to edit some video.
09-14-2019 11:20 PM
Kingfish999 replaced the harmonic balancer on the 96 today with one rebuilt by DamperDudes. now i can detect misfires again. had another rebuilt for the 88 since its also using 96 EFI also and will probably do it tomarrow. now that it shows misfire data, it shows cylidner 1 is where my misfires are coming from so i replaced its spark plug hoping for a simple fix but was not the cause. then suddenly my ignition coil decided to die while im at the auto parts store (luckily for me) so i have a temporary one in for now. going to try a leakdown test tomarrow and check the fuel injector.

09-14-2019 07:23 PM
Frank Lanzisera Took the front bumper trim off to coat with the Eastwood plastic resurfacer. Clips came out in 10 minutes. Finish it tomorrow.
09-14-2019 05:54 PM
nra1ifer Added a Tekonsha T-One trailer connector to our 1981 Bronco. Piece of cake to install other than some existing brittle wiring near the connectors that are separated for this install....

https://www.etrailer.com/Custom-Fit-...ID=19811171796
09-14-2019 05:43 PM
67galax I mentioned it in my build thread, but I started the 4-bolt steering swap. Ordered the AN fittings and hose today.
09-14-2019 05:18 PM
Frank Lanzisera
Quote:
Originally Posted by Want2BS8ed View Post
That’s impressive looking Frank. What paint are you using on the air dam?
Eastwood plastic resurfacer. Used their xylene paint prep first. Matte black.
09-14-2019 03:59 PM
Want2BS8ed
Quote:
Originally Posted by Frank Lanzisera View Post
Half the front spoiler done half not

Thatís impressive looking Frank. What paint are you using on the air dam?
09-14-2019 03:49 PM
Frank Lanzisera Half the front spoiler done half not
This thread has more than 20 replies. Click here to review the whole thread.

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

 
For the best viewing experience please update your browser to Google Chrome