Full Size Ford Bronco Forum banner

Reaction score
55

Profile posts Latest activity Discussions About

  • miesk5 ·
    Yo Six,
    HAPPY BIRTHDAY TO YOU MY FRIEND⚠
    :happybirth:happybirth:happybirth:upup::upup:

    BTW, don't think of it as getting older, think of it as becoming a classic,:thumbup
    miesk5 ·
    Ⓨⓞ Ⓜⓐⓛⓒⓞⓛⓜ,
    Ⓦⓘⓢⓗⓘⓝⓖ ⓨⓞⓤ ⓐ Ⓗⓐⓟⓟⓨ Ⓑⓘⓡⓣⓗⓓⓐⓨ ⓦⓘⓣⓗ ⓜⓐⓝⓨ ⓜⓞⓡⓔ ⓣⓞ ⓒⓞⓜⓔ!
    Ⓐⓛ
    bullseye 77 ·
    I have run 2 awg wire from - battey to chassis, to frame, to motor. I then run + wire from battery to starter relay on fender. Should I run a 2 wire to starter as well, and should I go from starter to alternator?
    Thanks
    bullseye 77 ·
    Hi, I am trying to increase grounding in my 96, 351, 8 cylinder, 4x4, with 2 gauge awg wire. I have run one from neg of battery to chassis, 1 to block, 1 to alternator, a braided ground is from frame to chassis midway of Bronco. My question is about the positive line from battery. Do I just add the 2 guage wire from battery to the starter, one to relay on side, one to alternator, and do I replace all the positive wires to relay? Thanks for feedback. I have 4.10 gears, flomax's, k&N flow air sensor/filter, 31x10.50 tires. Excell wires, caps, and coil. Runs great;however, I was looking for a little better gas mileage, and less radio noise.
    Thanks
    cb [email protected]
    chilkatbronco ·
    hey, i'm very new to this sight. but i ordered the parts for you're tune up and was wondering if it changes for a 5.8 any i know its for the 5.0. but i'm curious if the timing advance is any different or the gapping of the plugs? thanks
    JKossarides ·
    OK I figured out what the problem was, this morning I decided to return the new MSD cap & rotor for a new set just on principal you know and had cleaned up the old cap & rotor and noticed the old rotor was grey plastic with sliver contacts where as the new one was red plastic with brass color contacts on the rotor so when I fired it it ran just great so I got my $38.00 back, I even drove down our steep hill to O'Reilly's and coming up it was doing fine as well.

    Funny I was watching the Velocity channel this morning with Fhantom Works and it inspired me to give it one more try so now on to making a smog appt. and it should pass...

    Thanks ~ :thumbup
    JKossarides ·
    Hey Brother I need some help, it's smog time again for me in Sept and I wanted to get ahead of the curve....the BKO's been running really great this last year and I decided to put on a new MSD cap, rotor and a set of Autolite #24 plugs. I cleaned the IAC, topped off fluids and when I was done installing the ignition parts and fired it up, it ran like absolute crap with a hunting, stumbling idle up and down and only smoothing out when the rpms were up around 1500.

    I've doubled checked every thing even putting in another set of plugs and the ones I took out where all fuel rich black soot, the Bosch O2 is from 2008 when I put in the new engine and it passed the smog least year

    I cleaned the IAC initially then swapped in a spare, no improvement, fuel pump, FPR and injectors all where new last year...........

    I'm stumped so any input is greatly appreciated....hope all is well on your end...:thumbup
    JKossarides ·
    Hey Brother just checking in to see how you're holding up, got the new injectors in yesterday and it runs great after a few adjustments like hooking up the TPS connector correctly.....lol lol.

    Funny thing is when I looked at the current injectors I had from 2008 upon close inspection they were 4 hole spay as well but maybe these will help because they're new, going for the smog test in a day or two.

    Give me a shout and let me know how you're doing OK.....
    Sixlitre ·
    Sho nuff dew Paintballdude

    http://www.supermotors.net/clubs/2bigbroncosdixie/users/users/registry/4970/19835

    Tips ? Yup, forget adding soap. Every imbecile (previous owner) before you added enough soap to kill a horse already.

    Just flush that crap out, with the electric pressure washer you borrow off Flanders, until it stops pumping white foam (usually 10 minutes or more, believe it or not).

    Soap may help get rid of stains, when them POs hand scrubbed the rug, but left in the rug, when it dries it acts like glue, letting dirt stick to the rug, worse (and faster) than before.

    I've seen some miraculous improvements on rugs you would have counted out for dead. NO aftermarket rug I've ever seen is the quality of the original rugs Ford paid for.

    Sides, why waste money on rugs, when there's so many other places you want to spend it.

    Sixlitre
    paintballdude902 ·
    hey man do you have a link for ur carpet cleaning thread? ive been searching for it. got mine all pulled out, any tips for getting it clean again?
    Sixlitre ·
    No Bubba

    they're no walk in the park. Pretty involved actually. Here's the thread of my install;

    http://www.supermotors.net/clubs/2bigbroncosdixie/users/users/registry/4970/19605

    I pre-painted, pre-undercoated and glued mine on with 3M panel adhesive so's it wouldn't be off the road for long..........it still was.

    Not for the faint of heart or first project types. You can just buy $26.00 patch panels for the parts over the rear wheels, if that's all that's gone.

    Sixlitre
    JDbigmoney ·
    Hiya Sixlitre,

    My big thing is I'm wondering if you know of anywhere in Canada a guy can buy bronco parts. For example....new quarter panels. The freight out of the states is enough to make me cry.
    Rop3r ·
    Hey Sixlitre,
    I was wondering if you had a video or know of a video simulair to the exhaust set up that you have.
    Thanks,
    Rop3r
  • Loading…
  • Loading…
  • Loading…
Top