Bronco Forum - Full Size Ford Bronco Forum banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-6 of 6 Results
  1. 1980-'96 Bronco Tech
    Hi Everyone, So this is a weird question, but I'll provide some info on why I ask. My Bronco has the 3G Alternator (upgraded to 120 amps), Factory AC/PS, however, it does have a C/F delete - replaced with Aluminium radiator (with larger core) and dual electric fans, temp controlled with...
  2. 1980-'96 Bronco Tech
    ok so i've got a 95 bronco 5.8 e40d and its SD not MAF and im looking to get some better power without changing to MAF. i've been looking at blueprint 408 engine, 408 stroker kit or just a whole new engine swap, id like to keep it to around 6-8k budget. i know broncos aren't suppose to be tow...
  3. 78 - 96 Build Forum....Builds only
    Hey y’all So this is my first post on here but I’ve been using this site for years. I have an 82 bronco that I've been restoring and modding for about three years now. The most recent upgrades I did to it was swapping in an M5R2 and comp thumpr series cam kit. Now my next upgrade is building and...
  4. Noobie Bronco Tech Questions. Flame free zone!
    Hey guys! First time poster. Long time reader and user of the information and knowledge spread on this site! Has helped me immensely for my own bronco! My model is 1988 5.8 v8 351w efi xlt. Recently Ive hit a snag First let me go over all of the work done so far. All new ignition system...
  5. 1980-'96 Bronco Tech
    Hi thanks for reading and any positive suggestions/opinions. I’ve got a ‘93 with a 351w and an e4OD. Bought it from a gal who said the trans was “bad” because it was leaking fluid out of the inspection plug. She bought a new car the next day and didn’t even consider taking it in. Anyways I...
  6. Noobie Bronco Tech Questions. Flame free zone!
    My 351W with EFI I believe idles a little to High. When looking through the tech pubs I believe my engine is suppose to be 700-800 in park When first started in goes to 1700ish then with in a few seconds drops to 1200ish, no hunting surging etc.... When I put it in reverse/drive drops to 900ish...
1-6 of 6 Results
Top