Bronco Forum - Full Size Ford Bronco Forum banner

eec

  1. EEC-IV self test not working

    1980-'96 Bronco Tech
    Hi all, I'm having an issue that I've been racking my brain about for the last couple of weeks. My truck has a check engine light and bogs down when I hit the gas and kinda stumbles. I tried the jumper wire method to pull codes which I have done before and it has worked no problem but when I try...
  2. Ignition Control Module Confusion

    Noobie Bronco Tech Questions. Flame free zone!
    I have read a ton of information on this forum regarding the Ignition Control Module. I am more confused now than I was when I started. The module on the Bronco is gray. It is mounted on the distributor. The module on it must have been an aftermarket with a label. No embossed or engraved...
  3. Rough idle and drives rough!!!! HELP

    Blog
    Have a 88 bronco 5.0. Ive replaced every sensor on the motor. It recently started to idle rough and drive stupid. Starts jerking and wont shift right. It sounds like the air/fuel isnt right but ive changed everything i can think of. FPR, EGR,TPS,O2 sensor, water temp sensor, even the...
  4. Odd loss in throttle response

    Noobie Bronco Tech Questions. Flame free zone!
    I know this is very vague, and it's hard to troubleshoot over a forum, but any ideas would be appreciated. Yesterday I drove my bronco after it had sat for 3 weeks. It was running perfectly fine before the 3 weeks of sitting. When I first started it up the idle was really erratic. Halfway out...
Top