Bronco Forum - Full Size Ford Bronco Forum banner

electrical issue

  1. Transfer case clutch connector pin

    Noobie Bronco Tech Questions. Flame free zone!
    I'm trying to repair the wire from the magnetic clutch in my bw1356 electric shift transfer case. The wire is broke and missing the pin that goes into the connector off the transfer case shift motor. The picture below is of the pins from the speed sensor that goes in the same connector. Anyone...
  2. A little help with Turn Signals/Flashers

    1980-'96 Bronco Tech
    Hi everyone, I've scoured the forums but I'm stuck chasing a ghost and hope you can help. 96 XLT keeps blowing fuses when I turn on the left turn signal or the flashers. Blowing both the #7 & #13 fuses. So far I've done all of the following and still can't seem to find the problem. Replaced...
  3. Up in smoke....

    1980-'96 Bronco Tech
    My wiper switch fell apart and shorted out in my 89. It went up in smoke as I was driving and I lost all power except headlights I believe. I had to go to work so I haven't had an opportunity to dig in yet, I'm hoping someone has an idea of where I should start? I just know that it won't start...
  4. No more honk honk.

    Noobie Bronco Tech Questions. Flame free zone!
    A few weeks back while on vacation my wife called frantically because my horn was blowing and they couldn't make it stop. It stopped right before they got the battery unhooked. 90 fsb 302 no air bag, aftermarket cruise control that I don't think is wired thru the horn does work. I replaced a...
  5. Electrical issues with a 81 302 bronco

    Noobie Bronco Tech Questions. Flame free zone!
    Hi all. So a little backstory. I was cleaning up some wiring under my dash and without noticing I knocked my ammeter gauge, and it was touching the metal bracket. I go to fire the truck up later that evening and under the hood starts smoking. I shut it off and run to pull the negative cable and...
  6. 86 Full Size Bronco No fuel, No spark

    Blog
    I have a full size 86 bronco and it wont start. Im not get fuel or any kind of spark. just replaced the plugs,plug wires,tfi module,ignition coil,rotor button,distributor cap,fuel pump,and fuel filter. I am just out of ideas.
Top