Bronco Forum - Full Size Ford Bronco Forum banner

fuel injection

  1. What else could it be 94 bronco

    1980-'96 Bronco Tech
    Just replaced 302 with a new 302. Symptoms: runs rough when accelerating, idles fine though, loss of power, Exhaust manifold gets red hot. What I've tried to fix it: Adjusted timing even took it to a shop to ensure it was right, removed cats, sprayed carb cleaner around intake while running...
  2. 1996 Bronco stalls when coming to stop after it is warm

    1980-'96 Bronco Tech
    I need some help. I am having an issue with my 1996 Ford Bronco. It starts fine, idles fine, runs fine.......until it gets warm. Then it stalls when coming to a stop. Only when coming to a stop. It cranks right back up then shuts off at the next stop sign. I can sometimes catch it and throw it...
  3. 1989 Bronco no start

    Blog
    so I have a 89 bronco with a brand new 5.0 302 in it, I put about 25 miles on the new engine just taking it on a test drive, and I noticed it sounded like it didn't want to start when I stopped about halfway through the test drive but it did start. I drove it home just fine it ran great and felt...
  4. California speed density EFI for sale from 1990 302.

    Bronco and Ford Parts/Accessories
    Hey i pulled the fuel injected 302 out of my bronco in favor of a new build, and i'm selling all the fuel injection stuff from it. everything except the long block which i'm giving to a friend for in his volvo (hehh heh!) anyhow it includes the wiring harness, computer, and everything else you...
Top