Bronco Forum - Full Size Ford Bronco Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Ok so i bought this bronco cheap for shits and giggles and cause I'm tired of being held hostage in my house after heavy rains (Miami, Hurricane capitol of the world), its runs pretty good for needing a desperate tuneup, motor doesn't knock or smoke too bad (smokes briefly until it warms up; sat for a long time).

What I did notice is that when it fires up, oil pressure is fine. After running it a few blocks, oil pressure drops real fast to 0. I checked the oil and its in normal range. I know it has an oil leak at the rear main seal, but its a couple drips a day, not enough to leave the motor dry. When the pressure does drop, the motor doesn't rattle or act up, runs fine.

Any help will be appreciated
 

·
FSB warrior
Joined
·
6,117 Posts
you might get better response if you put this in the right section............this isnt like any tech write up ive ever seen
 

·
Registered
Joined
·
127 Posts
Could just be the guage. I don't suppose it would continue to run fine with no oil pressure. Try a mechanical guage, the stock guages don't seem to be so reliable. Besides they are 21 years old.
 

·
Practicing Infidel
Joined
·
15,309 Posts
downsouth said:
Ok so i bought this bronco cheap for shits and giggles and cause I'm tired of being held hostage in my house after heavy rains (Miami, Hurricane capitol of the world), its runs pretty good for needing a desperate tuneup, motor doesn't knock or smoke too bad (smokes briefly until it warms up; sat for a long time).

What I did notice is that when it fires up, oil pressure is fine. After running it a few blocks, oil pressure drops real fast to 0. I checked the oil and its in normal range. I know it has an oil leak at the rear main seal, but its a couple drips a day, not enough to leave the motor dry. When the pressure does drop, the motor doesn't rattle or act up, runs fine.

Any help will be appreciated

Before you throw any cash into a tune up

you'd better make sure your motor is gonna stay together. Oil pressure is critical to an engine and it will die if your gauge is telling the truth.

The good news it may not be telling the truth. Do this;

http://www.supermotors.org/vehicles/registry/detail.php?id=4970&s=22156#content

first and you'll be able to tell the real oil pressure. If you can't afford to do that then you probably ain't gonna like dropping the oil pan and changing the oil pump either.

Again the good news is that it's an old Bronco and it could be that the screen on the oil pump pick up is nearly clogged from all the regular oil changes it never got.

There are many additives you can add to your oil just before you change it that will hopefully help disolve some of this sludge.

You should put the gauge on and change the oil every two weeks for two months using vicious additives and see if things don't improve, they did for me.

BTW your rear main seal leak is likely partly due to a clogged PCV valve and oil breather filter not letting pressure out of your crankcase.

Sixlitre
 

·
green ones make me horny
Joined
·
11,155 Posts
put a mechanical guage on it first. then in the correct forum tell us what the pressure really is
 

·
Registered
Joined
·
16 Posts
Alot of times when your oil presure starts out fine then drops expecially on a tired motor, means you got bearings going bad, thats what ive seen in the past with our other motors and what the motor guy told me about my FSB
 

·
Registered
Joined
·
3,425 Posts
its gonna need a bottom end rebuild...assuming the pump is bad...most likely bearings, pump and pick up.,..assuming the cranks OK...check the sending unit..thats only like 18 bux to replace...the bottom end work will cost you like 900+ for a shop to do...

just pray its not your pump but stop driving it until u figure out the problem

DC
 

·
Registered
Joined
·
566 Posts
My '90 Bronco 351W did that, it ended up being the oil pressure regulator going bad. Quick fix and then it was reading again.
 

·
Registered
Joined
·
304 Posts
Mine did that too... thats why I got the truck I took my cunnent engine from for so cheap... bottom end bearing were shot...
 
1 - 10 of 10 Posts
Top