Bronco Forum - Full Size Ford Bronco Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I recently purchased a nice running 1988 SuperCab Lariat, F-150 4x4, V8, AT/OD. It has the following issues:

1) Air Conditioner & fan were working perfectly (its been converted to 134A), I used yesterday. Today neither the fan or AC will come on, the "blue" light on the push button AC switch does not come on and again the fan does not work in any position. I checked the fuse, charge level and the connections. Whats wrong? Could it be the AC relay, if so where is the relay located?

2) The turn signals stopped working at the same time as the AC & fan, i have emergency flashers and brake lights, parking and headlights working.

3) Consistant power steering leak, i changed the high pressure line, the leak appears to be coming from the top of the PS box, What do you think is wrong?

4) I replaced the high pressure power steering line and pressure switch today.

5) Which V8 engine do I have and is it possible to find out if its been replaced? The truck runs great, ive never had a 4x4, AT/OD truck squeal 32 inch tires by just tapping the gas, its much more powerfull than my LT-1 Roadmaster.

I was told the truck had a "crate engine" installed about 40k miles back, it doesn't appear to me to have been replaced, but with the flood of PS fluid and grime covering everything, its hard to tell. I pressure washed the engine compartment and that helped some.

[email protected]
 

·
Registered
Joined
·
3 Posts
Discussion Starter #2
Update: I hit a pothole and now everything is back to working as it should (for now), I assume I have a short somewhere?

Update: Everything stopped working again :)
 
1 - 2 of 2 Posts
Top