Bronco Forum - Full Size Ford Bronco Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
184 Posts
Discussion Starter #1
I've got a 1992 with the 302 and auto trans. Its been getting worse and worse, but today was especially bad. When I hit the gas from a dead stop, the trucks engine stumbles and wants to die but picks up and goes after a second. Also when starting, I need to prime the fuelpump atleast twice or else it wont start. It has this "old gas smell" once it fires up... I've replaced cap, rotor, wires, fuel filter and fuel pressure regulator with no fix. Would tps be a culpret? any other ideas??
 

·
#1 Asshole
Joined
·
1,452 Posts
Have you checked fuel pressure and pulled codes from the ecu? Which auto transmission do you have aod or e4od? Having to prime the fuel pump twice like that you are having fuel pressure issues check it and report back it may be a bad pump or kinked/pinched line on the supply side. It may have had rust inside the tank or varnish cloging the filter or injectors. Rust could have worn the gears on the pump not allowing it to make the proper pressure but what ever it is you have fuel pressure issues.
 

·
Registered
Joined
·
202 Posts
Have you checked fuel pressure and pulled codes from the ecu? Which auto transmission do you have aod or e4od? Having to prime the fuel pump twice like that you are having fuel pressure issues check it and report back it may be a bad pump or kinked/pinched line on the supply side. It may have had rust inside the tank or varnish cloging the filter or injectors. Rust could have worn the gears on the pump not allowing it to make the proper pressure but what ever it is you have fuel pressure issues.
x2 sounds like fuel pressure issue. and really, with my experience, if you have to prime it more than just the one time to start it. It's the fuel pump. But first, be cheap and try the pressure test. That will tell you alot.
 

·
I Paid for this sh!t
Joined
·
675 Posts
even more important is check the leakdown of the pump, My bronco had a fuel pump issue and it would make proper pressure while running, but if you shut it off it instatly went to 0 (which means bad)
 
1 - 5 of 5 Posts
Top