Full Size Ford Bronco Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
OK, so my bronco sat in my buddy's barn for 3 years. Before I even tried to turn the key I replaced the fuel tank, fuel pump, fuel filter, spark plugs, wires cap, rotor and change motor oil and tranny fluid. Also has new ECC. Motor fires right up idles nice revs up just fine but when I try to take off it has no power. Tranny seems to shift fine during all of this. So I checked for vacuum leaks (Had 2 small ones by ac} also smog pump delete was done several years ago. So decided to check the timing and found it was reading 18 degrees BTDC backed it off to 12 everything sounded ok then shutout off and then wouldn't start... returned it to 18 and fired right up WTH?! :mad: Oh and yes I removed the spout connector.
 

·
The Tennessee Warden
96 XL, 5.8L, E4OD, BW1356, 4.56 gears
Joined
·
2,813 Posts
Sounds like you need to pull the dizzy and stab it back in correctly. Could be that someone put it in wrong. Turn the engine manually (socket on the crank pulley bolt) to TDC (with the puff of air from the number 1 spark plug hole technique) and reinsert the distributor so that when it’s all the way in, the rotor points to the number 1 plug wire. Reinstall the number 1 plug and wire. Then manually advance it a little (counterclockwise) and crank the engine with the spout out. Try setting to 10° BTDC, reinstall spout, and report back with results.
 

·
Registered
95 5.8L XLT, Hedman Shorties/MF SS Y & Muff, E4OD, Electric, Manual, KYB Quads, 31x10.5x15's, 299K
Joined
·
693 Posts
What @[U]MS88Bronc[/U] said. (y) Start with the Basics and see where you're at. Check your vacuum at Idle in park and drive and what it does when you bleep the throttle in park.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4
Yeah I'm going to do that once it stops raining but even with the dizzy stabbed a little off I still can't figure out what is making it lose power. I guess what I'm getting at is the damn thing was running just fine for 5 years with the distributor that way?
 

·
Registered
95 5.8L XLT, Hedman Shorties/MF SS Y & Muff, E4OD, Electric, Manual, KYB Quads, 31x10.5x15's, 299K
Joined
·
693 Posts
Yeah I'm going to do that once it stops raining but even with the dizzy stabbed a little off I still can't figure out what is making it lose power. I guess what I'm getting at is the damn thing was running just fine for 5 years with the distributor that way?
Well this is another story now it was fine for 5 years this way so the Distr wasn't touched!!!!!
 

·
Registered
Joined
·
3 Posts
Discussion Starter #6
Well I'm not sure? The reason I say that is that I sold the Bronco to a friend of mine who parked it in his barn when at that time his mechanic told him the fuel pump was bad, hence why I decided to replace the items listed in my original post. My buddy doesn't know crap about cars so his input on what it was doing is worthless, other than it was doing the same thing before I replaced the parts listed.
 

·
Registered
95 5.8L XLT, Hedman Shorties/MF SS Y & Muff, E4OD, Electric, Manual, KYB Quads, 31x10.5x15's, 299K
Joined
·
693 Posts
Ahhhhh the saga continues!!!! Little by little we get more info, keep it coming whatever bits and pieces you can offer-up.
 
1 - 7 of 7 Posts
Top