Bronco Forum - Full Size Ford Bronco Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
I have a 1995 bronco eddie bauer eddition with a 302 engine. It seems to lack power. I have to give it lots of throttle to go and on any small hill or head wind it downshifts alot and I have to keep it wound up.No check engine lights. Any good advice?
 

·
FSB Pimpster & Recruiter
Joined
·
5,716 Posts
I have a 1995 bronco eddie bauer eddition with a 302 engine. It seems to lack power. I have to give it lots of throttle to go and on any small hill or head wind it downshifts alot and I have to keep it wound up.No check engine lights. Any good advice?
First off Welcome to Our Home!

As mentioned above, searching would get you the answers you are looking for.

If I had to guess, My first guess is you having an issue with your Catalytic Converter.

Allcruisen :imp :usa
 

·
Registered
Joined
·
1,383 Posts
Check fuel pressure, timing, do a tune up - plugs, wires, cap and rotor.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #11
I did replace the throttle position sensor when I first got it because there was no throttle response hardly at all. There was a code for that. But it improved it quite a bit, but it still seems slugish to me.
 

·
aka: kemicalburns
Joined
·
7,830 Posts
your running 33's with a stock gearing. that is part of your issue. you should have at least a 4.10 gear front/rear to move those tires especially with a 302.

search and do the Sixlitre Tune up. then figure on either a gear swap or running a 31" tire.
 
1 - 13 of 13 Posts
Top