Bronco Forum - Full Size Ford Bronco Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
130 Posts
Discussion Starter #1
To start off, I did read everyy thread I could find before and after I rebuilt the carb.
The truck will not idle unless the gas is held or the fast idle cam is on.

Ok so based on the condition of the other "new stuff" the p.o put on the truck I decided the carb did most likely need a rebuild ( gaskets are old and does smell rich all the time). I bought a rebuild kit from autozone and completed the rebuild yesterday. When I first put it on and cranked the truck I had to let it sit and and come back out and crank again. Well the fast idle kicked in and it ran fine at 1800 rpms i touched the throttle to see if it would idle normal circuit and it will not. I kept giving it gas to let it warm up and it will not idle! I can hold it at 7-900 rpms and it sounds like a cylinder or two is missing and if I let off then it dies. But i can rev it clear to redline with noo problems whatsoever.

* I did not touch idle mixture screws when carb was off truck.
*I followed a great write up to the key =http://www.ifsja.org/forums/vb/showthread.php?t=101921&page=2

* The bowl is full of fuel, the choke works fine.
I am a nooob when it comes to carbs this is my first carbed vehicle to date.
Any Suggestions? Tips? Guesses?
 

·
Registered
Joined
·
130 Posts
Discussion Starter #2
Update: to start off :doh0715:.. The whole time i was testing it was with the air cleaner on. Well i just tried again with it off (complete accident) and it idles perfect...so with a 1/4 turn to richen idle it should be perfect! sorry for wasted space!
 
1 - 2 of 2 Posts
Top