Bronco Forum - Full Size Ford Bronco Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter · #1 ·
Tell me if it is worn out or just some other problem. I have blow by from the breather cap that goes into the air filter, and leaves oil in there and I have to clean it out every so often. It never smokes out the tailpipe. Have to add a quart of oil between 2000 and 2500 miles using Castrol 10-40 in it. The plugs burn clean and I did advance the timing a little bit for more power. It also has some what sounds like lifters rattling around 2000 and higher rpm but not all the time, doesn't sound like rocker arms or rod at all. Just trying to convince myself it isn't rings or valve train problem but something else. The bronco gets 14mpg in town and 17mpg on hwy still. It only has 110,00 miles, 83 Bronco with 300, C-6, we don't have emission check where I live so I did away with cat, EGR is still there, but not hooked up and air pump still running; I did away with all the plastic emission lines. This model does not have the feedback system. Thanks for any ideas on this issue.
 

·
Registered
Joined
·
162 Posts
if your actually wiping oil out of the air cleaner then id say the rings are starting to get weak, i had a 82 2wd with the 300 and had the same problem, lots of blowby but no plug fouling, ran it for 3 years that way until it started runnin rough at idle and found weak compression on 2 out of the 6 cylinders. but still had good power, i sold it to a guy from work, and he ran it that way for another year until it started smoking out the exhaust, by then the body was shot so he junked it, id say its giving you the signs of a needed rebuild, but i think you have some time left, that ol 300 had close to 250,000 before it gave up
 

·
Registered
Joined
·
18 Posts
Discussion Starter · #3 ·
Ok wrenchturner, thanks for the input; I guess I will drive it a while longer and decide when to rebuild it or get another long block, I really like the 300 engine, I actually thought about putting a 351w in it but will likely stay with the iron horse 300.
 

·
Registered
Joined
·
2,691 Posts
Tell me if it is worn out or just some other problem. I have blow by from the breather cap that goes into the air filter, and leaves oil in there and I have to clean it out every so often. It never smokes out the tailpipe. Have to add a quart of oil between 2000 and 2500 miles using Castrol 10-40 in it. The plugs burn clean and I did advance the timing a little bit for more power. It also has some what sounds like lifters rattling around 2000 and higher rpm but not all the time, doesn't sound like rocker arms or rod at all. Just trying to convince myself it isn't rings or valve train problem but something else. The bronco gets 14mpg in town and 17mpg on hwy still. It only has 110,00 miles, 83 Bronco with 300, C-6, we don't have emission check where I live so I did away with cat, EGR is still there, but not hooked up and air pump still running; I did away with all the plastic emission lines. This model does not have the feedback system. Thanks for any ideas on this issue.
Wow if you had a 302 then or situations would look identical. I had the exact same problem out of my 302. Drove it for 3 years like that and ran it down the interstate like that. Recently it started running like crap and idling terribly also. I am currently putting a new engine in my BKO because of that reason. All in all you can drive it like that for a little while but I would be planning for a replacement engine soon.

And keep that 300. It's a great engine.
 
1 - 4 of 4 Posts
Top