Bronco Forum - Full Size Ford Bronco Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter #1
put a computer out of a non 4x4 f150 in my bronco. would this cus my 4x4 not to work? just curious. or is the computer the same?
 

·
Registered
Joined
·
1,779 Posts
Most likely not the ecm.

Push Button 4x4 or do you have a transfer case shifter?
 

·
Wrenching for a Livin'
Joined
·
6,949 Posts
I don't see any way that the ecm would cause the 4x4 to not work. They are completely seperate from each other.

The module that runs the push button 4x4 is behind the passanger side kick panel. It has a little light to flash codes or daignostic info i think
 

·
Registered
Joined
·
19 Posts
Discussion Starter #5
Yeah I tested box with little white switch in box. Tested good. I have power to the push button and it works. But the box behind kick panel does not click when I push the 4x4 buttons. I tested direct current from push button to box behind kick panel and that tested ok. Haha don't know what else too check to see why I don't hear clicking from my switch box haha
 

·
Wrenching for a Livin'
Joined
·
6,949 Posts
Did you try to apply power and ground directly to the motor on the transfer case? there is a thread or wiring diagram on here somewhere that explains it. That way you know if the motor is working. If so then its a wiring issue, or a problem in your control module
 

·
Wrenching for a Livin'
Joined
·
6,949 Posts
i would think so too, but its been a LOOOONG time since i messed with that system.

Do you have a wiring diagram? make sure the power and grounds are good.

Also, the motors go out all the time....wouldn't hurt to grab a module and motor from the 'yard and just keep whichever isn't bad for a spare. As long as its not a wiring issue that should fix it. Its throwing parts at it, but with the push button stuff you are always going to need parts.
 

·
Registered
Joined
·
19 Posts
Discussion Starter #9
yeah i have a lot of spare parts. lol i decided to test my push buttons again. and yup its bad. i must of read the wiring diagram wrong the first time lol thanks for the help :)
 
1 - 9 of 9 Posts
Top