Bronco Forum - Full Size Ford Bronco Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
63 Posts
Discussion Starter #1
O.K. my rebuilt 400m had a broke exhaust valve spring on cylinder #1 replaced both springs drove it and it broke the exhaust spring on cylinder 5 and 7. I talk to the builder and I am having it towed to his shop.He going to get the specs. on the compcam that he installed a friend of my said the.springs needs shimed even new ones the builder disagreed who's right? I didn't put new springs when it was built builder said cam wasn't big enough to require new springs.
 

·
Registered
Joined
·
1,779 Posts
O.K. my rebuilt 400m had a broke exhaust valve spring on cylinder #1 replaced both springs drove it and it broke the exhaust spring on cylinder 5 and 7. I talk to the builder and I am having it towed to his shop.He going to get the specs. on the compcam that he installed a friend of my said the.springs needs shimed even new ones the builder disagreed who's right? I didn't put new springs when it was built builder said cam wasn't big enough to require new springs.
I would say they are all wrong. Call Comp Cams help line with cam number and get part #'s for what you need. Likely you will need valve springs and retainers at least. Valve springs should be installed at comp cams recommended height, you may have to shim to get to this height. My $0.02
 

·
Registered
Joined
·
63 Posts
Discussion Starter #4
I called builder he contacted cam manufacturer and is replacing all springs to their specs. I should get it back today I hope it fixed finally thanks for the advice.
 
1 - 4 of 4 Posts
Top