Bronco Forum - Full Size Ford Bronco Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
1,448 Posts
Discussion Starter #1
351 M, 2150 carb, all of a sudden stumbling at WOT. think this is fuel or ignition?
 

·
Registered
Joined
·
1,448 Posts
Discussion Starter #3
did nothing, one day running great, next not. i did remove A/C stuff for Ranger429, but doubt i moved anything else.
we did get tons of rain, maybe dist cap has mositure?
cant really get it up to garage,its outback out of the way while we have 70 pine trees cut down and hauled away. next week should be able to look at it.
 

·
Registered
Joined
·
1,448 Posts
Discussion Starter #5
today i looked at carb and engine. the fuel hose going into carb was leaking. hoseclampwas loose. tighten the clamp seems all good now
 

·
Premium Member
Joined
·
23,549 Posts
might as well replace your fuel filter as well.
 

·
Registered
Joined
·
1,448 Posts
Discussion Starter #8
yes several times, of course it wasnt leaking when it wasnt running. but after pushing and poking around looking for loose vac line as suggested, i found the loose fuel clamp. Besides i need a 6 foot step ladder to climb up there so its not easy as opening the hood and looking. Why did my post waste your bandwidth to braincells?


 

·
Im scared of jopes
Joined
·
1,660 Posts
Nope not at all, Like I said I was just curious. Makes sense about not leaking while not running. Just seemed like such a simple fix for how smart you are, Always loved your truck. Mine is a minier version and not as nice body. Mines on 38's though.
 

·
Registered
Joined
·
1,448 Posts
Discussion Starter #10
dont be fooled by the photos,, the body isnt that nice. it is rust free and solid, but many imperfections. I should have spent about a month on the body work instead of a week.
 

·
Registered
Joined
·
1,448 Posts
Discussion Starter #13
thx, in hidesite i shouldnt have put a 6" lift in the F150 since its a tow rig now...oh well live and learn
 
1 - 14 of 14 Posts
Top