Bronco Forum - Full Size Ford Bronco Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
39 Posts
Discussion Starter #1
recently my starter broke so today i replaced it, it sounds great but i also replaced the distributor cap and the rotor and i also replaced all the spark plugs. i did some other tune up stuff but that is all that dealt with the ignition process.
it basically just sounds like it is not firing, any help at all would be so appreciated. i will load my profile and stuff tomorrow.
ps it doesnt sound like a big deal i rechecked all the wiring from cap to plugs it is all in the correct order any way just any tips please i need it to start running again.
 

·
trying to go fast!!
Joined
·
1,082 Posts
dang that sounds like when i got my dis cap wet i hope it works out iam have some problems with my bronco right now to
 

·
Registered
Joined
·
1,024 Posts
is the starter engaging, or is it just dead?
 

·
Registered
Joined
·
1,024 Posts
also have you checked for spark?
 

·
Registered
Joined
·
143 Posts
I'm not sure what its called, but check both pieces of the cap. I'm not sure if the 80 has the two-piece cap setup. Mine does and the piece that is below what most people would call the cap can get loose.
 

·
Registered
Joined
·
71 Posts
Any chance you knocked it way out of time whiel messing with the distributor?
 
X

·
Guest
Joined
·
0 Posts
Any chance you fowled up the firing order? I did that once. Plus make sure all you connectors are secure and in place.:toothless
 
1 - 9 of 9 Posts
Top