Bronco Forum - Full Size Ford Bronco Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
hi guys. i got a 89 351 auto. and it doesnt like to stay running. i did a general checkup (lubes and filters and what not) still doesnt like to run. it chugs and has very rough LOW idle.
i just discovered that it only does that on flat ground. as i was barely making it up the driveway, i got to the incline and it started to run just fine. i was wondering what would make it so it only ran fine on a slope?

and for common sense. yes it does have about 6 gals. of gas.

thanks
 

·
Registered
Joined
·
90 Posts
Few things to check out. Check fuel pressure on the fuel rail ( I assume if an 89 it's EFI) Check the IAC ( valve on side of intake by throttle, controls idle) Would need more info for more ideas.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #5
yes it is efi. i checked the pressure on the rail and its fine.

(also when i give it hard acceleration. little pops come out of the intake?)
 

·
Satyr of the Midwest
Joined
·
17,736 Posts
I think you should start looking for vacuum leaks.

Just out of curiosity, what was your fuel pressure, both with and without manifold vacuum applied to the regulator?
 

·
Registered
Joined
·
9 Posts
Discussion Starter #7
i dont know the pressure. i didnt use a pressure tester just a screwdriver on the valve to see if it had any. also there is a vacuum leak. it starts on the valve right next to the passenger side hood hinge, and goes somewhere underneath dash i think. i checked IAC and its 9 ohms so its fine. and there would be no way of me checking the cat unless i cut it.
 

·
Registered
Joined
·
1,030 Posts
-89-BuckinBronc said:
yes it is efi. i checked the pressure on the rail and its fine.

(also when i give it hard acceleration. little pops come out of the intake?)
Timing?? Make sure you take out the SPOUT. Don't know why it runs better on an incline though.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #12
yeah ill double check timing. what is a spout? also that line goes into the wire harness and through the firewall. after that im lost. but before i cut off the cat. could that be a reason it would run like its choked? but i dont know how a hill or incline could affect that? my first thought was the fuel pickup inside the tank is in the back so when im sloped it gets gas.?
 
1 - 15 of 15 Posts
Top