Bronco Forum - Full Size Ford Bronco Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
OK, before you start flogging me I searched and found nothing final to help with my problem.

Stats: '95, 351, E4OD, 90K miles.

Problem: Starts fine, stutters when cold or when taking off from a stop even when warm after start up.

Things I have tried: Pulled the codes and system pass code is all I get. I have replaced the O2 sensor, EGR valve, spark plugs. When that didn't work it spent 3 days at the dealer.

Dealer cleaned the fuel system, replaced the fuel filter, and said it was fixed. Well it is not.

Since I'm not getting any codes and the engine is in sound mechanical condition I might try to replace the TPS sensor, or IAC. I don't know where to go from here to any help is greatly appreciated.

Thank you! :banghead
 

·
Former owner of Shadofax
Joined
·
17,025 Posts
OK, before you start flogging me I searched and found nothing final to help with my problem.

Stats: '95, 351, E4OD, 90K miles.

Problem: Starts fine, stutters when cold or when taking off from a stop even when warm after start up.

Things I have tried: Pulled the codes and system pass code is all I get. I have replaced the O2 sensor, EGR valve, spark plugs. When that didn't work it spent 3 days at the dealer.

Dealer cleaned the fuel system, replaced the fuel filter, and said it was fixed. Well it is not.

Since I'm not getting any codes and the engine is in sound mechanical condition I might try to replace the TPS sensor, or IAC. I don't know where to go from here to any help is greatly appreciated.

Thank you! :banghead
Mine was kind of doing that for awhile too, '95 with 133k. I regularly put in a complete fuel system cleaner and change the fuel filter roughly every 9-10k. I cleaned the IAC dealy and that seemed to help some, and frankly until you brought this up, I had forgotton it kinda idled rough at startup, and these days, once warm I have no issues.

I'd just go ahead and pull the IAC and clean that (there is a thread here somewhere on it). See if that helps before going any further.
 

·
Satyr of the Midwest
Joined
·
17,734 Posts
Not a good idea to clean it if it's not a cleanable design IAC.



Only the TOP Hitachi (non-vented) design is okay to clean. Sometimes it'll fix things for a while, but replacement is the only real solution.
 
1 - 3 of 3 Posts
Top