Bronco Forum - Full Size Ford Bronco Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
Hi guys, I know its typical to have some noise from the front end when in 4x4 on tight turns. My 08 F250 made a noise on sharp turns when the 4x4 was engaged.

My 95 bronco makes a noise sounds a lot like a dry bushing or rubbing noise when I make a sharp turn when the 4x4 is engaged. It doesn't do it all the time, only on a certain part when the wheel turns. Wondering about possible solutions?

My 08 F250 was a work truck and I never did the maintenance to it, a ford dealership did. I know it did it from day 1 with 0 miles, but I am fairly ignorant (or new, depending on how you look at it) when it comes to 4x4 systems and whatnot. Any recommendations are greatly appreciated. This site is an amazing wealth of knowledge and I'm happy to be a part of it (however small a part I am)
 

·
I scrape on both sides
Joined
·
3,035 Posts
.... are your tires simply just rubbing on something?

do you have oversized tires?

are they rubbing on something?

do you have a lift kit with dropped radius arms and larger than normal tires?

are they rubbing on something?
 

·
Registered
Joined
·
9 Posts
Discussion Starter #3
No to all. Stock everything, no suspension mods whatsoever. Tires dont appear to be rubbing on anything. Only does with 4x4 engaged. No noises whatsoever in 2wd.
 

·
Registered
Joined
·
616 Posts
Do you have auto or manual hubs? Auto hubs pop when their going bad.
 

·
I scrape on both sides
Joined
·
3,035 Posts
do it in both directions?
 

·
Registered
Joined
·
9 Posts
Discussion Starter #7
Good question. I'll have to check. For some reason I didn't bother to check the other direction. I'll get back to you.
 
1 - 8 of 8 Posts
Top