Bronco Forum - Full Size Ford Bronco Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
39 Posts
Discussion Starter #1
Ok my accelerator cable broke on my 1991 fsb. I found out that apparently theres about 6 different lengths on these things. The closest one i coul find has a mounted length of 30" and a overall of 39.74". I put this on my truck and now with my foot on the floor its only opening enough to get me to about 2300 rpm max. Any suggestions?

I also have 4hi but when i try to engage 4lo it never goes in and the light just flashes.
 

·
Man of endless projects
Joined
·
9,289 Posts
you can try the ziptie trick to take slack out of the cable for temporary use. you will have to look it up but its just a simple trick oputting zipties on the end of the cable by the pedal to take up slack. but I would try to get a different brand. a lot of the throttle cables they sell now days are always off in one way or the other. the advertised length doesn't change anything tho. its just how long the cable is which doesn't matter.

im assuming you have electronic shift 4x4. im not too familiar with them but to get in 4low, you have to put the tranny in Neutral.
 

·
Registered
Joined
·
39 Posts
Discussion Starter #3
Is there a brand you would suggest? I put my tranny in neutral shift to 4hi then press 4lo and the light just flashes.
 

·
Registered
Joined
·
17 Posts
I found this "Shiftster" to replace the electronic switch to manual selector. Yes you have to get on your knees to switch it but it will not fail like the electonic button. Hope this helps.

http://theshiftster.com/
 

·
Registered
Joined
·
39 Posts
Discussion Starter #5
Looked today and my cable is properly mounted and between the last aluminum keeper should be setting in the holder when you are using no throttle there is about 3/8 slack. Will post pic later
 

·
Registered
Joined
·
39 Posts
Discussion Starter #6
This is with the truck on and idling. This is the only cable I can find with the correct mounting length of 30 inches and a overall of 39.74. Thinking pioneer is a
Little off on their measurements or they have shit quality control. Anybody have any suggestions or maybe a different parts manufacturer to try?
 

Attachments

·
Man of endless projects
Joined
·
9,289 Posts
as I said you can do the zip tie trick. you put a zip tie or 2 between the betal on the very end of the cable and the little plastic bushing that goes on the pedal. it will take slack out till you find a new cable that works
 

·
Registered
Joined
·
4,871 Posts
...
I also have 4hi but when i try to engage 4lo it never goes in and the light just flashes.
You do know that in order to engage 4-low you need to be in neutral? (NOT Park, Not Drive)
 

·
Registered
Joined
·
32 Posts
I have an old acc cable plastic stopper piece broke, and I temporarily but a different metal piece there until the truck is running well. I took it for a ride and could only get to about 20-25 mph with the pedal all the way down. Would this also be from the acc cable ?
 

·
Registered
Joined
·
32 Posts
My old old acc cable's plastic stopper piece broke, and I temporarily put a different metal piece there until the truck is running well(It's been sitting for a few years outside). I took it for a ride and could only get to about 20-25 mph with the pedal all the way down. Would this also be from the acc cable ?
 
1 - 11 of 11 Posts
Top