Bronco Forum - Full Size Ford Bronco Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
326 Posts
Discussion Starter #1
Yet another problem. I took my 78 to a mechanic tonight so they could look at my brake problem tomorrow. When I got there I noticed axle oil all over the undercarrage. I think it was coming out the venting tube. With the amount that came out I don't think it is normal. What could be the problem now?
 

·
Registered
Joined
·
326 Posts
Discussion Starter #3
BrokeCuzWheelin said:
It probably wasn't coming out of the vent. Probably needs a pinion seal.
the reason I think it was coming out the vent tube is because my vt routes up to the frame rail on the drivers side. It seemed like that was where the most fluid was.
Another thing I have noticed is that when I put the front axle on jack stands it leaks oil. Not sure from where. somewhere on the diff. I didn't really inspect it that close.
 

·
Registered
Joined
·
231 Posts
Have you been playing in water/mud? check the fluid level, if it starts coming out when you pull the fill plug it has water in it....which leads to pulling the cover cleaning, and refilling....it's easy
 

·
Registered
Joined
·
326 Posts
Discussion Starter #5
countryboy79mi said:
Have you been playing in water/mud? check the fluid level, if it starts coming out when you pull the fill plug it has water in it....which leads to pulling the cover cleaning, and refilling....it's easy
I have been fighting with this thing pretty much since I got in 5 months ago. I have not driven it in water or mud at all. I checked the oil level a few months ago and topped it off.
 

·
Registered
Joined
·
326 Posts
Discussion Starter #7
BrokeCuzWheelin said:
I still think it sounds like a pinion seal that is flinging oil everywhere or an engine oil leak that is dripping on to the front diff.
I'm not ruling it out. Once I get it back I will look at it closer
 
1 - 7 of 7 Posts
Top