Bronco Forum - Full Size Ford Bronco Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
90 Posts
Discussion Starter · #1 ·
Hey all,

So I've been having some charging system problems lately. I keep having to jump my truck, after putting in a brand new battery.

I have narrowed this down to three causes i can think of, without having checked fuses.

I noticed that if i turn the key towards off a little, i can get rid of an annoying door chime. Every time it seems i do this, the battery is dead the next morning. I have no idea if this could be the problem so i was wondering if anyone could shed some insight.

More likely however, I think might be my electric transfer case. I bought the truck 2 months ago, and for shits n giggles i pressed the 4x4 button while the truck was off. It started really rough after that, and that was when my first battery problems appeared. Also, even though the truck isn't in 4x4, since the day i pushed the button, the 4x4 light shows all day long and it doesn't shift into 4x4 or low range.

Finally, I have an amp that sits with a blue light on even when the truck is off, so i would not be surprised at all if i need to rewire this somehow.

I've read about checking the fuses and what not and hopefully will be able to do that this weekend. Please let me know if any of this seems realistic, and i apologize ahead of time if i missed any of this in my searches.
 

·
Premium Member
Joined
·
5,104 Posts
You have a battery drain somewhere... I would start with the amp. It sounds like its staying powered even when the truck is off. Also, it would be a good idea to fix the issue with the 4x4 button just so that is working properly. There are quite a few threads on this site that address the push button transfer cases and the various issues they have.... do some searching and you will most likely find your answer.
 

·
~*~*~*~*~*~*~
Joined
·
10,493 Posts
Hey all,

So I've been having some charging system problems lately. I keep having to jump my truck, after putting in a brand new battery.

I have narrowed this down to three causes i can think of, without having checked fuses.

I noticed that if i turn the key towards off a little, i can get rid of an annoying door chime. Every time it seems i do this, the battery is dead the next morning. I have no idea if this could be the problem so i was wondering if anyone could shed some insight.

More likely however, I think might be my electric transfer case. I bought the truck 2 months ago, and for shits n giggles i pressed the 4x4 button while the truck was off. It started really rough after that, and that was when my first battery problems appeared. Also, even though the truck isn't in 4x4, since the day i pushed the button, the 4x4 light shows all day long and it doesn't shift into 4x4 or low range.

Finally, I have an amp that sits with a blue light on even when the truck is off, so i would not be surprised at all if i need to rewire this somehow.
I've read about checking the fuses and what not and hopefully will be able to do that this weekend. Please let me know if any of this seems realistic, and i apologize ahead of time if i missed any of this in my searches.

I'm betting on the amp. Its not wired to the remote wire off the radio. This will cause your battery to drain.
 

·
my bko ate my money
Joined
·
2,319 Posts
yep prolly the amp mine did it too before i wired it to the radio remote wire,

but you can try these things to find out whats doin it, just unplug your transfer case motor, and unhook your amp for a day or so maybe even a week and see if the problem stop if not then its none of those devices causing the problem:thumbup
 

·
Registered
Joined
·
61 Posts
Forgot to do the search..sorry

Forgot to do the search..sorry, Found some good suggestions. Is it true that the alternator can have a short but just generate enough power to keep it running with the help of the battery. I mean I drove it from vegas to flagstaff and back. Now if I charge the battery fully it still won't start without the start switch on my charger,

:whiteflagThink the black widow alarm could be the culprit? I've got the alternator, battery and starter out to get tested tonight. Any other ideas appreciated.
 

·
my bko ate my money
Joined
·
2,319 Posts
key is easy cost $20 at parts store, put key in turn to run not start, push pin in from underneither steering column, pull key cylinder out, put new in and done:thumbup

as for the rest, get those parts tested and let us know what you find, we`ll go from there
 

·
Registered
Joined
·
812 Posts
I'd be willing to bet my savings that it's the amp. If the amp isn't turning off with the truck, it's going to easily drain the battery in a matter of 12 hours. I'm paranoid to even listen to my radio for 10 mins with the engine off due to draining the battery.
 

·
my bko ate my money
Joined
·
2,319 Posts
I'd be willing to bet my savings that it's the amp. If the amp isn't turning off with the truck, it's going to easily drain the battery in a matter of 12 hours. I'm paranoid to even listen to my radio for 10 mins with the engine off due to draining the battery.
same here, i always start mine if im gonna be listening to the radio
 

·
Registered
Joined
·
116 Posts
same problem

just fixed my amp/sub battery-draining problem too.
i can post a tech write up if your interested.

its definatly your amp thats draining your battery.
as for your 4x4button,....ouch! :twak that sucks!
 
1 - 11 of 11 Posts
Top