Bronco Forum - Full Size Ford Bronco Forum banner
1 - 16 of 16 Posts

· Registered
1990 EB, 5.0
Joined
·
734 Posts
Discussion Starter · #1 ·
Today my serpentine belt came apart on me. It was getting chewed up and half gone by the time I made it home.

Figured it was old. I went to put in the new one, started the truck and it’s off a little on the smog pulley. I align it, start again and it’s off a little of the harmonic balancer. I align it, start up, it’s off again on the balancer. Try again. Still off on the balancer. Soon as I start up it works off the edge of the harmonic balancer pulley.

last month I replaced the power steering pump so I’m guessing that is where the misalignment is coming from. I assume I just didn’t notice until the belt got chewed up. Never had a belt problem before.

Also installed a K&N cold air intake 3 days ago and there is bracket that I attached to the ac compressor. Perhaps that the cause?

Any ideas before I begin troubleshooting?
 

· Registered
1990 EB, 5.0
Joined
·
734 Posts
Discussion Starter · #4 ·
My belt tensioner and idler pulley are new. Last few months. I do have a slight wobble in the smog pulley
 
  • Like
Reactions: miesk5

· Registered
1990 EB, 5.0
Joined
·
734 Posts
Discussion Starter · #5 ·
My belt tensioner and idler pulley are new. Last few months. I do have a slight wobble in the smog pulley
Thanks Miesk.
Today I’m going to autozone to pick up a pulley puller and new pulleys for my smog and power steering. It’s the easiest fix I can think of based on the troubleshooting guide. I’ll see how that goes first.
 
  • Like
Reactions: canuckistan97

· Registered
1990 EB, 5.0
Joined
·
734 Posts
Discussion Starter · #6 ·
Replaced the smog pulley, but it still has a wobble. Must be the shaft. Thought about eliminating it, but I still have cats connected.

I’ll get a puller tomorrow to replace the power steering pulley.
When I re-seat the new poly belt then start up, the belt comes off the crankshaft pulley and smog pulley both by one notch. I may try to replace the crankshaft pulley as well but not sure that will make a difference
 

· Registered
1990 EB, 5.0
Joined
·
734 Posts
Discussion Starter · #8 · (Edited)
Rank has a rubber damper around it, I’ve had toyota loose a crank maybe this is happening as well
Back in July I replaced the timing chain cover, timing chain and Harmonic balancer. Haven't had any issues so I don't think the rubber damper is going bad.

The problem has me vexed so here's my next step. Since I think the slight wobble in the smog pulley is part of the issue I'm going to bypass it and get a shorter belt like folks have suggested. Put new pulleys on the power steering and crank shaft, just for good measure, and see how it goes.

Right now I have the fan and shroud off to give me room to replace all the pulleys, just waiting on the pulleys, shorter belt, to arrive now. Hope to have it back together before end of the week, with fingers crossed this solves the issue. I'm reading threads now on the details of bypassing the smog pulley. Looks like I need to do something with the hoses.
 
  • Like
Reactions: miesk5

· Registered
1990 EB, 5.0
Joined
·
734 Posts
Discussion Starter · #10 ·
Yo Siggy,
This is as close as I can offer wight now:
Removal, Belt in an 88 5.0; "...I tried an 89.5" first, 2 inches shorter than stock and it was too long. So I went back hoping for something about 88 or so and all they had was a 87.5. It was a bit short and a royal pita to put on but it is running fine. A lil tight but it should hold till I get an 88.2 which they can order." by fright88

Removal, Belt Part Number 882K6 in an 88 5.0 by Barbaric35

Removal, Belt Part Number in an 89 5.8; NAPA Belt Part # 060825*by Cucamongan (Scotty) at SuperMotors.net
Thanks again miesk5. After combing through all the threads I've ordered an 87 and a 89 inch belt from Gates so one of those should work. Figure the belt tensioner will allow for some room to play with. I plan to remove the pulley and go with the shorter belt. Seems like the logical choice if emissions aren't a factor.

I've also read about folks getting their CATs clogged if the air pump isn't forcing things through, so I'm planning to cut out the CATs with a sawsall, to avoid any issues, and install a piece of straight pipe with seal clamps in it's place. I'll see how that goes, but may have to get it welded.
 
  • Like
Reactions: miesk5

· Registered
1990 EB, 5.0
Joined
·
734 Posts
Discussion Starter · #11 ·
Well when I got home today I went and looked under the truck to see how much exhaust pipe I'd be replacing. It was in that moment I realized this job would be bigger than I cared to take on. Especially for zero performance gain. So I'm taking the easy way out and ordering a new SMOG pump. I cancelled all the belts and exhaust pipe stuff I ordered earlier. Found a pump on Amazon for $165, Replacing the pump, combined with all new pulleys, should hopefully fix the belt issue. Should have it done by Thursday. I'll let you all know how it goes.
 

· Registered
1990 EB, 5.0
Joined
·
734 Posts
Discussion Starter · #13 · (Edited)
So it seems the issue was/is the power steering pulley. I put everything back together and the belt stil jumps one notch over. But now I’m sure it is the PS pulley. With the truck running I can see how the belt come off the ps pulley and is further out on the fan pulley which causes it to come off the crankshaft and smog pulleys.

here’s the problem. I can’t get the ps pulley seated any further on. There is room on the shaft, and clearance from the bolts, but my ps puller/installer won’t push it any further and I think it’s breaking screws.
Auto part Automotive engine part Metal

Any suggestions? Is this a tool problem? If I could just get the pulley on another 1/4 - 1/2 inch I’d be set. So I think I’ll go buy a tap tomorrow and a propane torch. Should be able to remove the pulley, heat it up and slide it on. If not I’ll go the tap route.
 

· Registered
1990 EB, 5.0
Joined
·
734 Posts
Discussion Starter · #14 ·
So last night I tried to heat the pulley up in the over and tap in on with a rubber mallet. Didn't work. Bought a torch and tap set this morning on the way to work. This afternoon I'll try to torch the center. If that doesn't work I'll have to open my $60 DeWalt tap set to see if I can fix the threads.
 

· Registered
1990 EB, 5.0
Joined
·
734 Posts
Discussion Starter · #15 ·
So last night I tried to heat the pulley up in the over and tap in on with a rubber mallet. Didn't work. Bought a torch and tap set this morning on the way to work. This afternoon I'll try to torch the center. If that doesn't work I'll have to open my $60 DeWalt tap set to see if I can fix the threads.
And now the saga comes to an end. I fixed it. I bought a tap and die set and tapped the 3/8 hole in the PS pump. This created additional room to thread in the removal tool. Then I could push the ps pulley I’m far enough to align the belt. Huzzah! All is right with the world. If you have a belt issue, suspect the power steering pulley first.
 
  • Like
Reactions: miesk5

· Registered
1990 EB, 5.0
Joined
·
734 Posts
Discussion Starter · #17 ·
Dont use the harbor freight pulley remover/ NOT installer. If you ever tried it; it sucks at pulley installations.
I used a cheap one I bought for $17 off amazon.
 

· Registered
1990 EB, 5.0
Joined
·
734 Posts
Discussion Starter · #18 ·
Well crap. Now the power steering pulley cracked and came off on me. Of course the belt went with it. Stranded on the roadside. Got someone coming to pick me up to go to autozone for a puller, pulley and new belt.

Any ideas why this would crack and come apart? Thought I finally had the issue solved.
 
  • Like
Reactions: canuckistan97

· Registered
1990 EB, 5.0
Joined
·
734 Posts
Discussion Starter · #19 ·
Wheel Auto part Tire Rim Automotive tire
Tire Automotive tire Auto part Automotive wheel system Wheel
Wheel Auto part Tire Rim Automotive tire
Tire Automotive tire Auto part Automotive wheel system Wheel
Well crap. Now the power steering pulley cracked and came off on me. Of course the belt went with it. Stranded on the roadside. Got someone coming to pick me up to go to autozone for a puller, pulley and new belt.

Any ideas why this would crack and come apart? Thought I finally had the issue solved.
 
  • Like
Reactions: canuckistan97

· Registered
1990 EB, 5.0
Joined
·
734 Posts
Discussion Starter · #21 ·
There is no chirping noise. But I managemed to remove/reinstall the PS pulley. However the belt still doesn't line up. I put it on straight, but as soon as I start the engine the belts moves over one rib on the balancer pulley. I was good enough to drive me the 1.5 hours home. I'm fairly certain I've got the pulley pushed on as far as it will go, so I'm looking for solutions.

Since I did change out the PS pump 2 months ago I'm wondering if there could be a bolt somewhere that isn't as tight as it should be? That's the only was I can think to move the PS pulley further inward to align the belt.
 

· Registered
1990 EB, 5.0
Joined
·
734 Posts
Discussion Starter · #22 ·
I removed the pulley, unbolted the PS pump and reinstalled. No difference. Belt is still one rib off on the harmonic balancer. But it gets on before it leaves and enters the smog pulley. Can’t figure it out.

for now I’ll live with it and carry a back up belt it case it breaks.
 

· Registered
1990 EB, 5.0
Joined
·
734 Posts
Discussion Starter · #25 ·
You probably should just swap to a saginaw pump. Cardone makes bad pumps; dont use them.

That dorman pulley seems like the application is a large amount of vehicles that never had the same pulley from the factory. Dorman Products - 300-003
I'm starting to look at saginaw swap threads now. It is just confounding to me that I can't solve this problem. If the pulley would just go on another 1/4 inch all would be well, but I can't even force it. Plus I don't want to force it since that probably led to the last pulley cracking and flying off.
 
1 - 16 of 16 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top