Bronco Forum - Full Size Ford Bronco Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
1,193 Posts
Discussion Starter #1
well around 10 i decided to install a new oil pan that i've had lying around for some time now. the old one was rusting through and leaking. about 4 hours later i was reinstalling the upper intake and pouring oil into the truck. i thought wow that went well and fairly quick, spoke too soon.
i started the truck and a horrible metal to metal noise commensed. quickly i shut it down. thinking that i had just destroyed the engine with a loose bolt i began to feel my stomach turn.
i decided to pull the dipstick to see if there were any obvious culprits, it won't come out. what the hell, i spun the engine backwards by hand and tried again, still it wouldn't come out. i unbolted the tube and yanked the whole assembly from the block.
what a relief, here the dipstick had been tweeked a bit when i reinstalled the pan and it had just contacted the crank when the assembly rotated. a small z bend was put into the dipstick that kept it from being pulled from the tube. no pieces were missing from it, it was just spring like and slapping off the crank. fixed the bend and reinstalled, started the truck and ahhh, nice normal idle.
that is all, sorry no ppics
 

·
Lick my balls
Joined
·
13,023 Posts
I can relate. I've been careless and had awful sounds eminate from the motor and like you I reacted quickly and with great fear of the possible cause.
 

·
House of Windsor 4ever!
Joined
·
10,518 Posts
Yup, been there, done that, but with customer's cars.... :brownbag
 

·
Registered
Joined
·
311 Posts
Reminds me of when I was detailing my Bronco last summer. I turned the key on and got smoke up out of the dash. I almost sh*t my pants. Turned the key off and disconnected the battery pronto. I pulled the stereo out to take a look and lo-and-behold (spelling?) that was the culprit, the stereo had fried. WHEW!!! :chili:dodged a bullet there! I thought I was going to spend the next 2 years chasing wiring gremlins.
 

·
Registered
Joined
·
904 Posts
yeah, had that happen but with a much less happy outcome. A weld on the oil pump by the PO prevented a new dist. from tightening down all the way, 'naded the cam and the dist gear...
 
1 - 7 of 7 Posts
Top