Bronco Forum - Full Size Ford Bronco Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
155 Posts
Discussion Starter · #1 ·
Ok...lets start of by saying.My truck has all new brakes well, 5 months old anyway. From the rear to the front...rear has new wheel cylders shoes...spring set and adjusters.Front has new drive side rotor and caliper and new pads...brakes were pretty good but lately, they have been going south.
The other night my E brake light came on, and has not gone off. The pedel is diffrent everytime i get in the truck.Some times the brakes are right there were u need them..like the new brakes that they are.Other times i hvae to go about all the way down till about a half inch before the end of the pedle before they even start to slow the truck down. Now when i did the rear brakes i bled every wheel, but when i did the new calipor i just bled the front..i know a mistake i now regret. so for starters tomaorw im goin to bleed all the brakes and hopfully get this problem sorted out...but if not im searchin on here and hope u guys can give me some input...btw its a 91 xlt 5.0
 

·
Registered
Joined
·
101 Posts
porportioning valve reset, you need two people cant be done on your own, well its really really hard if you try , a contact moves left and right in the valve and needs to be reset by bleeding slightly or pumping slightly. explained in the repair manual and useing................?

i know he posted e-brake, thats not what your talking about right cause thats toooo easy ?
 

·
Registered
Joined
·
155 Posts
Discussion Starter · #3 ·
well the park brake light....and no the park brake is not ingaged lol...but when i do set the brake the loght gets brighter..and i have a hanse...will that tell me how to reset it?
 
1 - 4 of 4 Posts
Top