Bronco Forum - Full Size Ford Bronco Forum banner

1 - 18 of 18 Posts

·
Banned
Joined
·
11,038 Posts
The switch is the white plastic one at the far L of this image, but installed it would be at the top center of the mechanism. Its contacts are exposed, so you can clean them. The dash light should come on if you turn the key to RUN & short the switch's wire to the brake mechanism chassis.

 

·
Banned
Joined
·
11,038 Posts
I think the wire terminal is visible installed, but I don't remember how deep up in the dash it sits. The switch contacts probably aren't visible installed, but it looks like there's just 1 mounting screw for the switch.
 

·
Registered
Joined
·
2,945 Posts
Discussion Starter · #10 ·
alright, heres an update. I pulled the ebrake unit out like in you picture and made sure the contacts were clean and that everythi8ng operated correctly. The light still isnt working. so now i guess i will follow the red/green wire and so where its not connected, it was the only wire i saw. is this right? where does it go?? what should i look for?
 

·
Banned
Joined
·
11,038 Posts
Did you not try this???
Steve83 said:
The dash light should come on if you turn the key to RUN & short the switch's wire to the brake mechanism chassis.
With the key in RUN, check that wire for 12V. If it's dead, my next guess would be a burnt bulb in the cluster. Use the Haynes manual wiring diagrams to see how it's hooked up.
 

·
Registered
Joined
·
2,945 Posts
Discussion Starter · #12 ·
Steve83 said:
Did you not try this???

With the key in RUN, check that wire for 12V. If it's dead, my next guess would be a burnt bulb in the cluster. Use the Haynes manual wiring diagrams to see how it's hooked up.
well, the bulb will come on when you start the truck, ya know, when all the lights come on. so i should see if the wire has 12 volts, and that means the light would be off?? and if the wire has no volts, the light should be on??
 

·
Banned
Joined
·
11,038 Posts
Steve83 said:
The switch...contacts are exposed, so ...clean them. The dash light should come on if you turn the key to RUN & short the switch's wire to the brake mechanism chassis.
If it comes on when it's grounded, but it doesn't come on when you press the pedal, and the pedal ONLY allows the switch to ground it, then the switch isn't grounding it. Fix the switch. It's either dirty contacts, or a weak spring, or some kind of mechanical interference.
 
1 - 18 of 18 Posts
Top