Bronco Forum - Full Size Ford Bronco Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
50 Posts
Discussion Starter · #1 ·
Maybe someone can help. Bronco started to idle real low= 550 600 rpm. Sputtering , stumbling ,shuttering up to about 1500 or better. I pulled the codes and nothing came up. I replaced the fuel filter last week. Seems to to be better above 2000rpm. Muffler has been broken for a while =since summer ,don't know if that would have anything to do with it. New plugs and wires and dist. about 4 months ago. Any ideas? Thanks
 

·
aka: kemicalburns
Joined
·
7,931 Posts
your tps sensor might be dirty or shot, whats the timing set at should be around 10* btdc . your cat could be plugged to and not having a muffler probably isnt helping either.
late
 

·
Ex Navy Nuke
Joined
·
5,421 Posts
Could be a few things, timing could be off, the fuel pressure reg could be bad. Start eliminating possibilities.
 

·
Registered
Joined
·
50 Posts
Discussion Starter · #4 ·
would'nt I get codes for most of those things? Or, is it possible for the tps to be bad and not get a code?
 

·
Registered
Joined
·
237 Posts
The computer sets a code when it thinks there is a problem.
Yes. You can have faulty components with no codes. You can also have codes that point towards good components.
I am *not an expert, but stuttering and stumbling sound like fuel or timing to me.
Could be as simple as a dirty fuel filter. Or could be a worn timing chain.
How many miles on the engine (or timing chain if its been replaced)?
Start with the little things. Check the filters. Check fuel preasure. Check the TPS sensor.
 

·
Are those REAL?!?!
Joined
·
1,702 Posts
look at the vaccuum line for the fuel pressure regulator... just anther idea...
 
1 - 7 of 7 Posts
Top