Bronco Forum - Full Size Ford Bronco Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
156 Posts
Discussion Starter #1
My c-6 is burning up Fluid
( at least i think it is, it doesnt smell burnt but the stuff im leeking under my bronk is oil and my Anti Freeze is good)

Well i seem to loose my ATF because ill top off the fluid and then a couple weeks later my trany will slip and then ill top off my fluid and then ill check again and its pretty obvious that im loosing it but i dont think im burning it

and im quite sure im not leaking it because theres no red leakege

and last but not least my anti freeze is good so i know its not leaking into there

Well i guess what im getting to is

Should i start saving up for a new tranny (or a junkyard replacement) or are there ways to stop this

If you guys got any ideas id really like them because my gut feelings telling me this things not gunna lasts much longer



Thanx matt --


(sorry for all the questions but i figured id get them out of the way all in one day)
 

·
But what does mine say?
Joined
·
954 Posts
Why do you think your tranny fluid is leaking into your antifreeze? Drop the pan to drain the fluid. Spray everything with break parts cleaner to clean it off. (thouroughly) Pop on a new filter, and replace the pan and fluid, and then see what it does. You might wanna try a seal conditioner too while you're at it. That's what I'd do. Then you know it's fresh and full, and then you can monitor it. The new fluid should fix the slipping problem too.
If you know you are leaking oil, then that's more than likely what you are smelling. A little splash hear and there on your exhaust can make a big stink. If you can't tell the difference between the smell of burnt oil and burnt tranny fluid, get a quart of each and go play with fire:goodfinge !!! hehehe

good luck
 

·
But what does mine say?
Joined
·
954 Posts
I just read your post again, and thought I should mention that tranny fluid can get pretty nasty. Nasty enough to look like dirty oil!! And reading mine, I meant re-install the pan, not replace.

Good luck
 

·
Original FSB.COM Owner
Joined
·
9,560 Posts
mine had a similar problem, took it to the shop, (i'm mechanicaly challenged) and the guy changed some kind of transmission modulater thing, said it went bad and was leaking into the engine and getting into a vacuum line :shrug
 

·
Registered
Joined
·
237 Posts
The modulator valve has a vacuum hose running from the tranny to a vacuum port on the intake(most likely). Trace this hose from the tranny to the motor and pull it off. If the modulator valve is bad there will be Atf in the hose. If the Mod-valve is ok it will be dry.
 

·
Registered
Joined
·
156 Posts
Discussion Starter #6
Dovepower said:
The modulator valve has a vacuum hose running from the tranny to a vacuum port on the intake(most likely). Trace this hose from the tranny to the motor and pull it off. If the modulator valve is bad there will be Atf in the hose. If the Mod-valve is ok it will be dry.

Thanx A ALOt

I just pulled the vacum hose of the modulator and ATF Spilled like a mofo so i guess that would be the prob (lets hope )

Thanx fer the help


Matt--

Ps all the Atf has left little red circles on the keyboard.

:D
 
1 - 6 of 6 Posts
Top