Bronco Forum - Full Size Ford Bronco Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
490 Posts
Discussion Starter · #1 ·
ok im having problems with the c6 now. and i dont want to drop it cause i have long tube headers. Fri i noticed a bad sounds liek rocks turning in the tranny. but shifted fine. i drove it home. next day i went and order some lift parts from a parts store liek 20 or so miles away. on the way back i noticed i was leaving a smoke trail. (never seen cars stay so far back). o Sat in the pooring rain i figured it must be the tranny pan. when and got everything i needed to do a tranny pan/filter, and since my brother picked up a nice new chrome tranny pan with a drain bolt i decided to put that on. all goes well except the rain. i reason i decided to do the pan to begin with was because i noticed it leaking and it is definetly hitting my headers. only one problem with this. leak wasnt comming from the pan. its comming from the inspection plate where you get access to the torque converter bolts. uhoh. im think the noise is the nuts lossing up and hitting the tranny plate. I hope. and maybe its leaking cause the torque converter is unseated. also before the did the tranny filter the tranny was NOT slipping. now it is slippign liek a mofo. i realize the C6 is a bitch to kill. but i might have accomplished it in 11k miles.
 

·
Registered
Joined
·
490 Posts
Discussion Starter · #2 ·
uh oh sh!t. its not the torque converter bolts. but i remeber when i put the new pan on it was shallower then the original by liek a 1/.2 inch and i had to flip this medaltub around to let the new pan fit. it went in the grommet in the filter. thats the only thing i can think off that can be makign it do this now. i need some input asap. as this is my DD
 

·
Registered
Joined
·
490 Posts
Discussion Starter · #4 ·
kf4amu said:
I'd like to help but I'm not sure I saw a question anywhere in your posts...

Front seal leak maybe?
the question is. what makes a tranny sound liek it go rocks in it. its not grinding. makes me think of the sound of a diesel engine. front seal. i cant think of a reason why the seal would have went know at 11k miles. i dont think its the seal. worst case im goign to have to dump the filter agaon and see wtf i missed. but im wonder know if the piece i flipped has anything to do with it.

what is wierd is i changed the filter once before at 3k miles and didnt come with this cup. and didnt come with the cup in this second kit at 11k miles. and looking at summit its not included with the kits. none of them. yet it came with the rebuilt tranny.

this is the same pan i just put on. http://cgi.ebay.com/ebaymotors/NEW-...hZ019QQitemZ8048877824QQrdZ1QQsspagenameZWD1V
i just realize what that piece is. it most likly suck the oil from the bottom of the pan as apposed to getting it at that very top. so your tranny will always get lubed unless its completely empty. which explains why when i put my hand on the pan it was really hot. if that cone is to low and hitting the bottom of the pan. not enough oil will lub the tranny. so i think i have 2 choice. remove the tube from the filter and let it suck from the top or put back on the old pan.
 

·
Registered
Joined
·
490 Posts
Discussion Starter · #5 ·
fixed the filter. now its quite liek normal but leaking from the front. damn thing has to come down. noooo!!!

yup ill assume it was the front seal. i got everythign down. only to fidn ouyt it was the flywheel with the problem. flywheel turned into 2 wheels. a inner and outer. both wheels still on it as 2 bolts are stripped. i would have put it all back together but the damn bolts stopped me. i original had 3 stripped but then we went and got one of them bolt grips. unfortunetly it only worked once. looks liek the teeth in it got screwed with the first bolt. so i have to return it. have to goto sears to buy an american set not the cheapies. if that dont work i dunno wtf im gonna do. i dunno if i should torch the flywheel bolts as the rear main seal is there. i dont trust easy outs. anyone with any bright ideas. im goign to try it again tommarrow. while the tranny is down im goign to replace the front seal anyway. im assumign the flywheel was making the torque converter unseat as it turned. seal looks fine. but better safe then sorry. flywheel $50 seal $5 tool i dont got a clue.cheapie was $27. im really goign to have to take pics of this for ppl.
 
1 - 5 of 5 Posts
Top