Bronco Forum - Full Size Ford Bronco Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
87 Posts
Discussion Starter · #1 ·
Guys

Been all over town and most of the parts stores don't even have a part number. Neither one of the Ford dealerships stock it and they want $50 to order it. Napa has one for a 5.0 and I figured it was the same, but can't find any confirmation on that, so I thought I would ask here. Here is a pic of it. I would take it off and take it into the part store, but then I would have to find someone to haul me around. Thanks. :whiteflag

 

·
Satyr of the Midwest
Joined
·
17,747 Posts
I can't imagine why it'd be much different than any years close to yours. Mine was built in July of '93, and it looks identical to the one there in the picture. In fact, now that I think about it, almost every Ford automatic transmission mount I've ever seen looks just like that.

I went to AZ's website and looked one up for my '93, and it comes up with Anchor #2557, but for a '94 it comes up with something completely different. I think the easiest way to check would be to take center-to-center measurements of the fasteners on the one that's on your truck, and then compare it to one for a '93. Hopefully, the differences aren't critical; knowing Ford, you might have some sort of hydraulic or other noise-dampening device in the factory piece, making it expensive, unique, and nonexistant in parts stores.
 

·
Roller rockers are gay
Joined
·
19,191 Posts
mine looks exactly the same, and i have a 1996 F150 with a 5 speed. the parts catalog didn't show anything for a 96 truck so i got one for a 95 truck.
 

·
Registered
Joined
·
2,379 Posts
i once got a trans mount from the local autopart store. it looked like the same but didnt fit so i tried another store and it was the same thing. the bolts were like .5" closer then the originial. i ended up just buying a new one from the dealership.
 

·
Registered
Joined
·
87 Posts
Discussion Starter · #6 ·
Chris85xlt said:
i once got a trans mount from the local autopart store. it looked like the same but didnt fit so i tried another store and it was the same thing. the bolts were like .5" closer then the originial. i ended up just buying a new one from the dealership.
Chris is exactly right. I bought one for a 93 for $17 and widened the holes on the crossmember. Then I used some flat washers on the studs. One problem I ran into is that the original mount has what I believe are metric threads and the new mount had std threads. Oh, and both of my local Ford dealerships wanted $50 for the OEM mount.
 
1 - 6 of 6 Posts
Top