Bronco Forum - Full Size Ford Bronco Forum banner

1 - 16 of 16 Posts

·
Registered
Joined
·
432 Posts
Discussion Starter #1
O.k. About 2 weeks ago I was trying to get codes from my computer because it felt like it was missing like it wasnt getting fuel, but it was intemittent. When I tried to pull the codes the computer did not flash out any codes the light just stayed on all of the time. when I tried to dicsonnect the wiresI had an electro static discharge into the computer from me and my fleece sweater :brownbag . Now sometimes the fuelpump comes on sometimes it doesnt. sometimes it operates like it is supposed to sometimes it comes on and never shuts off even if the truck is off and the keys are in my pocket. when it does this I have to pull the relay to shut off the fuel pump.

I know the pump is good, the inertia switch is good and I have 2 relays both are good and I get the same problems with both relays.
I Pretty much positive the computer is shot, but is there anything else I should check before replacing it?? this has pretty much blew my mind so any help is good help. :banghead :banghead
 

·
Registered
Joined
·
432 Posts
Discussion Starter #3
Fireguy50 said:
you check the ingition switch and key cylinder?
Sounds like something on the colum is failing.
I thought about that I think I will drop the column this weekend and check it out.
 
B

·
Guest
Joined
·
0 Posts
Crap! Don't we all hate it when that happens! Hope it's your ignition switch. I recently bought an extra computer. I got an A9L for $100 used. I think that was a little high priced, but I couldn't find one in colorado. It came from a national part finder and was shipped from a yard in Virginia. I do have an extra if you are in need, PM me. Good Luck!
 

·
Registered
Joined
·
432 Posts
Discussion Starter #5
still no luck

O.K. STILL NEED HELP ad to the list of stuff it isnt the ignition switch I just replaced it and that did nothing no biggie though its just 10 bucks. anyway I racking my brain here. Any more ideas anybody??
 

·
Registered
Joined
·
432 Posts
Discussion Starter #7
The no code thing is the least of my worry right now. I have to leave the Fuel pump relay out of the truck all of the time because the fuel pump never turns on. also when the relay is in and the fuel pump is on now it wont start(I havent even began to dive into that yet.) Basically what I want to know is what exactly activates the fuel pump relay and also deactivates it because that is whare the first of my problems are.the relay is always on so a switch either in the computer or somewhere alse is shorted and always closed.
 

·
OUT OF BUSINESS / M.I.A.
Joined
·
10,874 Posts
your link doesn't work.
doubt they have EFI diagrams thatI don't have
You have the EFI and Ful relays not the others:

Fuel pump relay is powered by the ingition key.
Computer grounds it to turn it on. It should turn it on for 2 seconds once key is on to prime system. then it turns on the pumps when it senses engine rotation from the dizzy.

I still sugest you check out the nocode page. a lot of the problems on that page will cause drastic problems like yours. It's very helpful to check for fatal errors in your harness.
 

·
Registered
Joined
·
432 Posts
Discussion Starter #10
sounds good that is the info i was looking for thanks Ill check it all out shortly
 

·
Registered
Joined
·
432 Posts
Discussion Starter #11
I think I am getting closer

:banghead Fireguy, I checked everything on your nocode page everything looked good except there is 0 voltage on pins 37 and 57 can you give me a good diagram and some idea where or what I should be looking at?
 
B

·
Guest
Joined
·
0 Posts
Damn, I feel your frustration! Have you checked for power to the EEC relay? No power there looks like no power to pins unless the relay or eek4 is bad. If it checks out you need to find a spare computer to try. If I was close you could use one of mine. Good Luck!
 

·
Registered
Joined
·
432 Posts
Discussion Starter #13
Blown said:
Damn, I feel your frustration! Have you checked for power to the EEC relay? No power there looks like no power to pins unless the relay or eek4 is bad. If it checks out you need to find a spare computer to try. If I was close you could use one of mine. Good Luck!

the relay is new power into it is good and I have a spare computer, It didnt help either. needless to say I am a bit aggravated.
 
B

·
Guest
Joined
·
0 Posts
I'm considering taking mine to Fort Carson and donating it for an artillery target. :cry :banghead :banghead :banghead :banghead

That's the most positive thing I can think of doing with it now!!!!!!!!!!!!!!!!!!!!!!!1
 

·
Registered
Joined
·
432 Posts
Discussion Starter #15
my wife says I should just find a different one, but why get rid of my problem just to get someone elses problem. its a 15 year old truck sh*t is bound to go bad.
 

·
Registered
Joined
·
432 Posts
Discussion Starter #16
ITS FIXED!!!!!

Finally figured it out ok first off the reason it was skipping to begin with is the plugs for the eec relay and fuel pump relay were broken the connections were bad.

the reason the fuel pump never shut off is the new relay advance gave me was the wrong relay it was normally closed instead of normally open

the reason the correct relay didnt fix it was the computer pin 22 never applied ground to the relay.

so I have now replaced:

2 bad realys,2 bad relay plugs,1bad computer and my truck runs like a champ.
Thanks everyone for your help particularly fireguy. :rebelflag
Now I can start on my lift install monday :rockon
 
1 - 16 of 16 Posts
Top