Bronco Forum - Full Size Ford Bronco Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
676 Posts
Discussion Starter #1
has anyone ever had a computer burn up like this......





I don't know why it happened It was working fine then it all stopped :shrug

Changed it out and it checks good now. :D
 

·
Registered
Joined
·
676 Posts
Discussion Starter #3
I started it up drove it to the stop sign about 500 ft and everything went dead and i got a bad stench of burnt computer

before that it was running fine no problems at all it was a rebuilt computer. I replaced with one from a junk yard today out of a 96 ford truck with out mass air flow It works fine . Oh my friend oscar noticed the fuel pump was working continuosly with just the key on we replaced the fuel pump relay also
it all works good now :shrug
 

·
Charlie don't surf..
'92 Ford Bronco XLT
Joined
·
15,252 Posts
A short??:shrug :shrug . One of those soldered connections probably just crapped out, just a guess.
 

·
Registered
Joined
·
573 Posts
Lucky it was in a '93. Mine roasted in my '89, and Ford has already discontinued that computer, so my mechanic buddy had to "rewire" (Tim Allen style) a computer for an '85 Mustang and make it work.
 

·
Registered
Joined
·
2,379 Posts
i had no problem getting a rebuild computer from Ford for my 85 bronco. i'm on my 3rd one right now. the first one was accidently replaced by the mechanic who thought it went bad. the second one didnt burn either but was reacting slow so i carry it as a spare. it was like $350

good luck
 
1 - 8 of 8 Posts
Top