Bronco Forum - Full Size Ford Bronco Forum banner
1 - 20 of 23 Posts

·
IM FAT, YOUR UGLY!
Joined
·
3,783 Posts
Discussion Starter · #1 ·
Ok after replacing the calipers on the front when the passenger side was frozen, and my dying booster and a new MC for $100 (cheap i know) my dad took it to work this morning.

Good things to know.. 85, 5.8 351, 140k miles

He said that when he was at 65mph it felt like he was towing a trailer and going 45mph. He was saying that it felt like it was dragging really bad.

Both back brakes were checked and are not sticking and neither are the front brakes so now I know its giong to be drive-line or engine related.

All fluids are up to par, oil change has less than a few hundred miles on it. Transmission hasnt been emptied and filter changed since i bought the truck but all fluid levels are fine and it shifts without problems.

Tire pressure is at 40psi on all 4 tires so i know they are not low.

The front end needs an alignment but I was told that it couldn't be done because my (not for sure) tie-rod on the passenger side inner and outer? was going out or shot or something along that lines and they also recommended to replace the radius arm bushings and some other stuff.

I did have a random backfire yesterday while driving it but i have no exhaust leaks. The camshaft is new along with the harmonic balancer since it broke when replacing the worn out camshaft a few months back. Its been timed and tuned by a mechanic and its set to 12 timing and it idles at around 400rpm nice and smooth in drive.

Im going to replace the fuel filter tonight before i go to work anyone recommend anything else?
 

·
IM FAT, YOUR UGLY!
Joined
·
3,783 Posts
Discussion Starter · #3 ·
pops didn't leave the e-brake on or something huh?i know you said they were good....but just for shitz & giggles, i would jack one side up and make sure they spin freely by hand, then go from there.
Nah the e-brake was off when i got home last night so unless he put it on before he went to work it shouldn't be on.

but could bad tie-rods cause major dragging? or bad u-joints on the front end?

I also know i have some crappy camber, wears tires in the front unevenly on the sides, so is that balljoints?

EDIT***

Forgot to mention that the 2 cats on the truck are the original cats im pretty sure. So since i dont have to get smogged after this years im going to go get it done for the last time (test good for 1 year) and than cut both of them off and leave my flow 40 on there and see if that helps.
 

·
Registered
Joined
·
228 Posts
severely off toe will drag it down alot and wear the bejeesus out of your tires. Imagine the right wheel turning right while the left turns left, you end up going straight but its pushing it to do that. When you jack it up to check the brakes, grab the wheel and check for play right to left on both fronts, if it wiggles and while doesen't turn the steering box, then you need some tirerod ends. Get a reamer and upgrade to some 1-ton Chevys while youre at it.
 

·
IM FAT, YOUR UGLY!
Joined
·
3,783 Posts
Discussion Starter · #6 ·
severely off toe will drag it down alot and wear the bejeesus out of your tires. Imagine the right wheel turning right while the left turns left, you end up going straight but its pushing it to do that. When you jack it up to check the brakes, grab the wheel and check for play right to left on both fronts, if it wiggles and while doesen't turn the steering box, then you need some tirerod ends. Get a reamer and upgrade to some 1-ton Chevys while youre at it.
its not off-toe its more like the inside of my tires wear alot faster than the outside which is camber.

and do you mean both the upper and lower tierod or just one? cause i can do everything and just get it over with, upper and lower balljoints and rods and new ujoints lol

im going to take it in this weekend sometime and see what the guy says about an alignment. It pulls right quite a bit with no hands on the wheel, and on top of the camber problem that probably will lose a mpg or 2 there too.. who knows
 

·
Registered
Joined
·
762 Posts
If your tie rods and ball joints are shot then your not going to get an alignment. Your dad says it feels like it is dragging. have you driven it?

Since you just did you brakes yesterday ( and the day before, and the day before that) and the issue is new, then I would stop looking at steering issues and look at the last thing you worked on. Maybe dad stomped on the brakes backing out of your spot and the rears self adjusted.

You know where I'm at if you need a hand this weekend.
 

·
IM FAT, YOUR UGLY!
Joined
·
3,783 Posts
Discussion Starter · #9 ·
If your tie rods and ball joints are shot then your not going to get an alignment. Your dad says it feels like it is dragging. have you driven it?

Since you just did you brakes yesterday ( and the day before, and the day before that) and the issue is new, then I would stop looking at steering issues and look at the last thing you worked on. Maybe dad stomped on the brakes backing out of your spot and the rears self adjusted.

You know where I'm at if you need a hand this weekend.
well right now im going to drive it tonight so ill let you guys know more this weekend. im pretty sure my balljoints are ok because they didnt say anything about that but my tierods they said were shot so there goes my alignment.

But right now im leaning towards the cats and since its a quick and cheap fix and they were going to be cut off in a few weeks anyways, just probably get to do it faster.

and as for the maxing out with my c6. well my truck runs fine at 65-80 mph without a problem up until a week ago, and apparently if my cats are clogged and or gutted themselves the symptoms im having match perfectly with screwed cats and the almost instant drop in fuel economy even at highway its under 8mpg. And up until a week ago when this started i wasnt getting any backfire, but it backfires randomly now which makes me think its not letting out the exhaust good enough. I dont have any holes in the system and my manifolds arent leaking either (already checked the exhaust for leaks and holes) or also was told that bad cats will make the engine run hotter than usual, i have a brand new thermostat in there and it runs a lot hotter than it used to.

They probably gutted themselves and need to be cut off. ill double check and have the cats checked before i make a decision. But a few feet of pipe and a torch cutter and a welder and they are gone anyways.
 

·
It's BTW Not AKA!
Joined
·
5,354 Posts
Tire rods will not have anything to with a drag. They are steering components. Misalignment is about the worst sympton you'll see. And loose steering. Same for balljoints.

Any front driveline components shouldn't even be spinning with the truck in 2wd.

I would say to still check the free spin status of every wheel. New calipers stick every day. Especialy cheap ones.
 

·
IM FAT, YOUR UGLY!
Joined
·
3,783 Posts
Discussion Starter · #12 ·
Tire rods will not have anything to with a drag. They are steering components. Misalignment is about the worst sympton you'll see. And loose steering. Same for balljoints.

Any front driveline components shouldn't even be spinning with the truck in 2wd.

I would say to still check the free spin status of every wheel. New calipers stick every day. Especialy cheap ones.
will double check everything with the brakes.

Right now i dont have lose steering just really really really crappy alignment. So that tells me my passenger side tie-rods should be replaced. Maybe ill do all 4 just to make sure i can get an alignment.
 

·
Practicing Infidel
Joined
·
15,299 Posts
But right now im leaning towards the cats and since its a quick and cheap fix and they were going to be cut off in a few weeks anyways, just probably get to do it faster.

and as for the maxing out with my c6. well my truck runs fine at 65-80 mph without a problem up until a week ago, and apparently if my cats are clogged and or gutted themselves the symptoms im having match perfectly with screwed cats and the almost instant drop in fuel economy even at highway its under 8mpg. And up until a week ago when this started i wasnt getting any backfire, but it backfires randomly now which makes me think its not letting out the exhaust good enough. I dont have any holes in the system and my manifolds arent leaking either (already checked the exhaust for leaks and holes) or also was told that bad cats will make the engine run hotter than usual, i have a brand new thermostat in there and it runs a lot hotter than it used to.

They probably gutted themselves and need to be cut off. ill double check and have the cats checked before i make a decision. But a few feet of pipe and a torch cutter and a welder and they are gone anyways.
You're going to be emission exempt soon ain't you Spiked ?

If so, you know what to do;) Make sure there ain't blue smoke running out the back pipe. That's often an indicator of a hemorrhaging carb (internally). That'll kill performance just as well as a vacuum leak.

Keep us posted

Sixlitre
 

·
IM FAT, YOUR UGLY!
Joined
·
3,783 Posts
Discussion Starter · #14 ·
Actually saturday if I pass ill finally be exempt which means no more cats anyways. As for exhaust its not blue in fact I rarely even notice the exhaust it rarely if at any time puffs big enough to notice a color.

I'm at work now and on the freeway I notced the car overheating and it having problems keeping a cruising speed. It only does it when its warm. It feels like an anchor gets tossed out the back until you slow down for a bit, stop or slam the gas lol.

I'm getting a rotten egg/rich fuel smell after shutting down the truck when I got to my post. Which makes me believe even more that its the cats. Which also means no more CA smog equiptment lol.
 

·
Registered
Joined
·
511 Posts
Replace your cats, dont remove them. I'm not going to debate on why, but c'mon.
 

·
Practicing Infidel
Joined
·
15,299 Posts
Actually saturday if I pass ill finally be exempt which means no more cats anyways. As for exhaust its not blue in fact I rarely even notice the exhaust it rarely if at any time puffs big enough to notice a color.

I'm at work now and on the freeway I notced the car overheating and it having problems keeping a cruising speed. It only does it when its warm. It feels like an anchor gets tossed out the back until you slow down for a bit, stop or slam the gas lol.

I'm getting a rotten egg/rich fuel smell after shutting down the truck when I got to my post. Which makes me believe even more that its the cats. Which also means no more CA smog equiptment lol.
Whatever it is seems like a bad omen for passing the test, but who knows.

You could get a Bassani (if they make you) and remove the cat later (after the test).

Sixlitre
 

·
IM FAT, YOUR UGLY!
Joined
·
3,783 Posts
Discussion Starter · #17 ·
I don't plan on doing anything to the cats till after I pass my final smog which I'm taking saturday. If I pass than I will start making final decisions. I've been having bad omens all week for some reason six.

But I see absolutely no reason to keep the cats since ill be exempt, a basani maybe but I've read through numerous threads and don't find a need for them after this last test.

As for your post decker, why the hell even post it? You give absolutely no reason or credit in your post at all. Why would I spend an extra $100 or so on 2 cats that have no reason to be there?
 

·
IM FAT, YOUR UGLY!
Joined
·
3,783 Posts
Discussion Starter · #19 ·
Well I've been talking with a tech I know that's done the same thing I'm about to do on his 80s f150 and he has no problems. I do however need to get the state legal mumbo jumbo from a rep just to be safe lol.
 

·
Registered
Joined
·
11,117 Posts
But I see absolutely no reason to keep the cats since ill be exempt, a basani maybe but I've read through numerous threads and don't find a need for them after this last test.

As for your post decker, why the hell even post it? You give absolutely no reason or credit in your post at all. Why would I spend an extra $100 or so on 2 cats that have no reason to be there?
Other then it's still illegal by federal law to remove working smog equipment and not replace it.

Why does he post it, because you should put a cat back on... it doesn't rob you of horsepower or mileage (increases it if anything), and you don't need two like the factory setup was....

A cheap ~60 some dollar Catco high flow cat will do the functions of both stock converters, while keeping the little bit of backpressure you need and helping keep the exhaust a little cleaner.

Also, quit being a bitch and go EFI. Carbs suck. :goodfinge
 
1 - 20 of 23 Posts
Top