Bronco Forum - Full Size Ford Bronco Forum banner
1 - 12 of 12 Posts

Registered
Joined
14 Posts
Discussion Starter · #1 ·
Hey guys, I have a 96 bronco 5.8 4x4 with a serious issue 馃槴 apparently everything was fine and all of a sudden my cruise control doesn鈥檛 activate. Has new brake pedal switch,release switch on brake master,new battery,,speed sensors,abs,everything is getting a signal from steering wheel and down to the switches. My mechanic spent 5 hours on it, AAA shop spent an additional 5 hours and couldn鈥檛 figure out the problem. Computer reads brakes are on but they are not! All lights work fine, other than that it鈥檚 perfect. No other issues, aside from everyone wanting to buy it, I鈥檝e decided to die with it and pass it on to my only son. Please help me figure this out guys,馃 I鈥檝e fixed all other issues because of all of you. Thanks to all of you in this awesome community, I鈥檓 hard head and trying to avoid the ( DEALER ) 馃槫 Lets get started!!!鉁婐煣犫湂
173786
 

Banned
Joined
31 Posts
Did you check you abs system, I'm no mechanic, but seems If the computer sences that brakes are on, I would check the abs system for something, as seems that cruise controle will not work if computer sais that brakes are on and they are not.
just a thought
 

Registered
Joined
14 Posts
Discussion Starter · #3 ·
Did you check you abs system, I'm no mechanic, but seems If the computer sences that brakes are on, I would check the abs system for something, as seems that cruise controle will not work if computer sais that brakes are on and they are not.
just a thought
Hey Rich, no abs issues, sensors are all replacd,, did not test on the computer though. I did remove and clean some shavings off the rear one above the diff, had it upgraded to a 4.10 with new oil about 15,000 miles agp.
 

Banned
Joined
31 Posts
Did you check you abs system, I'm no mechanic, but seems If the computer sences that brakes are on, I would check the abs system for something, as seems that cruise controle will not work if computer sais that brakes are on and they are not.
just a thought
What about unhooking battery for 15 min, and resetting the computer
 

Registered
Joined
329 Posts
Led tail lights will also cause this issue. Don't know if you have them.

third brake light being burned out can lead to this issue along with poor transmission shifting.
 

Super Moderator
Joined
29,143 Posts
Yo Big Ace,
Confirm speed control recall work was completed. Contact the Ford Customer Relationship Center:
US: 800-392-3673 | CA: 800-565-3673
Note: 3673 spells "FORD" on phone keys
For the hearing- or speech-impaired: Please contact the Telecommunication Relay Service by dialing 71
... have VIN ready.

By Ford:
"Visual inspection is an important part of diagnosis. The inspection is performed to locate obvious problems. During the visual inspection, check items for abnormal condition. Inspect for bare, broken or disconnected wires. Inspect the servo throttle actuator function and free operation of throttle linkage.

If the amber check anti-lock brake indicator remains lit when the ignition switch is in the Run position, service the rear anti-lock brakes before continuing the speed control diagnosis.


173798
173799
173800

173806

173804

173801
173802
 

Attachments

Registered
Joined
14 Posts
Discussion Starter · #7 ·
Yo Big Ace,
Confirm speed control recall work was completed. Contact the Ford Customer Relationship Center:
US: 800-392-3673 | CA: 800-565-3673
Note: 3673 spells "FORD" on phone keys
For the hearing- or speech-impaired: Please contact the Telecommunication Relay Service by dialing 71
... have VIN ready.

By Ford:
"Visual inspection is an important part of diagnosis. The inspection is performed to locate obvious problems. During the visual inspection, check items for abnormal condition. Inspect for bare, broken or disconnected wires. Inspect the servo throttle actuator function and free operation of throttle linkage.

If the amber check anti-lock brake indicator remains lit when the ignition switch is in the Run position, service the rear anti-lock brakes before continuing the speed control diagnosis.


View attachment 173798 View attachment 173799 View attachment 173800
View attachment 173806
View attachment 173804
View attachment 173801 View attachment 173802
Hey guys thanks for the feedback, tomorrow I will call to check on the recall and will also try the 15 minute disconnect. Will respond tomorrow after with follow up.馃憤馃徑
 

Registered
Joined
14 Posts
Discussion Starter · #8 ·
Hey guys sorry for getting back so late. Plug on recall has vendio replaced, disconnected battery also. Still not working, I took off on an overland trip with no cruise control 馃槪also I found out I'm only getting about 10mpg with 410 diff and 32inch Cooper at3xlt. Heart breaking. I'm going to upgrade to 35s for better mpg . Not to change the subject but does anyone know what this plug is?
175318
 

Registered
Joined
14 Posts
Discussion Starter · #9 ·
Hey guys sorry for getting back so late. Plug on recall has vendio replaced, disconnected battery also. Still not working, I took off on an overland trip with no cruise control 馃槪also I found out I'm only getting about 10mpg with 410 diff and 32inch Cooper at3xlt. Heart breaking. I'm going to upgrade to 35s for better mpg . Not to change the subject but does anyone know what this plug is? View attachment 175318
I also noticed when it got worked on they bypassed the speed return signal wire from the transfer case
 

Attachments

Registered
Joined
14 Posts
Discussion Starter · #10 ·
Hey guys, first I鈥檇 like to thank you all for the response on this issue. Let me start by saying it鈥檚 fixed 馃憦馃憦馃憦馃憦馃憦 I removed the new led tail lights and went back to halogen. Problem solved. I guess my bronco don鈥檛 like chinese parts. I have to keep it O.G going forward, thank you to the whole Bronco community 鉁婐煆
 

Registered
Joined
329 Posts
Glad you solved your issue, see my post here: Light socket type and Info on LEDs

if you want to add leds to your Bronco. Requires some work but worth it in the effort.
 
1 - 12 of 12 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top