Bronco Forum - Full Size Ford Bronco Forum banner

1 - 19 of 19 Posts

·
Registered
Joined
·
135 Posts
Discussion Starter #1
my cruise is not working. where do i start. anyone have any thoughts on why it my not work. thanks dave
 

·
Registered
Joined
·
6,177 Posts
broncos&bombs said:
mine craped out a couple years ago, im not even gonna fool with it. cruise aint that important.
'Tis for me.

I've done searches, but haven't found my solution yet. I've been looking for months :cry
 

·
Registered
Joined
·
135 Posts
Discussion Starter #4
-Spazmatic- said:
'Tis for me.

I've done searches, but haven't found my solution yet. I've been looking for months :cry
i also have done the searches. all of my lights work, my airbag is working, and my horn works, plus none of my fuses are blown. i do want the cruise cause when i go get my children i drive 170 miles one way, so it is nice for that trip. any more help would be helpful. thanks dave
 

·
Registered
Joined
·
52 Posts
there was a recal on newer broncos for their cruise control in february... i got a letter but i never went.. they fail and they can catch on fire and u can bring it to a dealer and they put a new one in for free. i still havn't bothered to go
 

·
FSB Pimpster & Recruiter
Joined
·
5,715 Posts
ogre said:
there was a recal on newer broncos for their cruise control in february... i got a letter but i never went.. they fail and they can catch on fire and u can bring it to a dealer and they put a new one in for free. i still havn't bothered to go
First off, The recall is for the brake switch that turns the CC off....

Second, Steve is correct, there are plenty of things that can go wrong and if you use the SEARCH section, you might find the problem....

Third, You did not mention watt year is your Bronco???????? :shrug

Now, If its Vacumn operated, it could be as simple as a hose. If its the new Electronic one, I will tell you watt happened to mine and you can go from there.....

My module was bad. Its the electronic piece on top. Where the Cruise Control cable goes....You can remove that cover and see if its melted some of the electric gue that is to protect the electronics....

Now, For those that have ignored your recall. I would suggest that you disconnect the harness at the end of your Master Cyl.

I have seen too many of these things catch on fire. Some because of this and some because of other things. Why take a chance. MY .02

Allcruisen :imp :usa
 

·
Registered
Joined
·
636 Posts
The recalled switch only turns off the cruise if you lose brake pressure. I disconnected mine, since Ford has none in stock. I plugged a jumper wire in it so I have cruise again. Also, start out by testing the switches with an ohmmeter per the ford troubleshooting manuals. You have to troubleshoot and test to find the problem before you go replacing parts. 1st part of the process is a thorough visual inspection of the system, looking for fuses, cables, hoses, etc that may be bad.
 

·
Garage kept
Joined
·
1,186 Posts
My 93 is not working and i was wondering if it is vaccum operated.
 

·
Are those REAL?!?!
Joined
·
1,702 Posts
'93's would be electronic... the module is located on the drivers side inner fender behind the hood hinge.. just follow the cable from the throttle body...

:thumbup
 

·
FSB Pimpster & Recruiter
Joined
·
5,715 Posts
Tomh971 said:
'93's would be electronic... the module is located on the drivers side inner fender behind the hood hinge.. just follow the cable from the throttle body...

:thumbup
Yeah, Watt ^ he said......:thumbup :thumbup :thumbup

Allcruisen :imp :usa
 

·
Registered
Joined
·
2,132 Posts
don't know if you guys are having the same issues i had. my cruise control would engage but then cancel out seconds later. problem ended up being the leds weren't seated properly in its socket and had a short that was causing the brake light filment to come on. it wasn't on like if i was stepping on the brake pedal but just enough to cancel out the cruise. you couldn't even see that the light was on with the light housing installed only with it off
 

·
Registered
Joined
·
135 Posts
Discussion Starter #12
sorry about that. my bronco is a 96 eddie bauer. i called the dealer and he told me about that recall so i went and had it done. thanks dave
 

·
Designated Tranny Killer
Joined
·
6,960 Posts
i don't even bother with mine
 

·
Registered
Joined
·
135 Posts
Discussion Starter #14
can i unplug the switch on the MC and jump a wire across the plug in the wiring harness and see it the switch is bad or will this not work. thanks dave
 

·
Registered
Joined
·
135 Posts
Discussion Starter #15
the switch on my MC is covered with this green corrosion. can i unplug the switch and jump a wire across the plug in the wiring harness and see it the switch is bad or will this not work. thanks dave
 

·
Registered
Joined
·
636 Posts
Steve83 said:
:twak Wrong. It's a pressure switch. It opens the circuit, killing the cruise servo's clutch, when you APPLY the brake.
Steve, you're right. I thought about it when I had a little more time. It is a normally closed switch that opens when pressure is applied. It is a backup to the BOO switch (brakelight switch) if I am remembering properly. However, you can jumper it if you still need the cruise; it is just a redundant switch.:doh: For some reason, I was thinking of it as a residual pressure switch that would interrupt the cruise if you lost brake pressure. Sorry.
 

·
Registered
Joined
·
135 Posts
Discussion Starter #17
well i just went out and disconnected the switch on the MC and put in a jump;er wire and the cruise worked. i did take out the jumper and will go monday and get a new switch. next thing is the abs. LOL. thanks to all dave
 
1 - 19 of 19 Posts
Top