Bronco Forum - Full Size Ford Bronco Forum banner

1 - 12 of 12 Posts

·
~*~*~*~*~*~*~
Joined
·
10,123 Posts
Discussion Starter #1
Okay so when I turn on my defroster my engine will die (at idle). Seems to only happen when its raining or the humidity is up. Nice sunny, dry day it doesn't do it. If the heater is on vent or floor no issues. I'm thinking the cam might be causing this as a vacuum issue. I never had this issue until I did the rebuild. I installed a FMS E303 cam and it now has that nice loap from the cam. Anybody have this problem before? Ain't no big deal but if I come to a light and forget to turn the switch, I'll stall.:banghead And that sucks.
 

·
Registered
Joined
·
11,108 Posts
Is your truck a mass air, or SD truck?
 

·
~*~*~*~*~*~*~
Joined
·
10,123 Posts
Discussion Starter #3
truck is SD. But other than this issue it runs strong. I just dropped it off to get 3 inch exhaust done as I type. Was going to get duels but you guys and the exhaust guy talked me out of it. Should sound sweet. And who knows maybe since the truck will breathe better maybe I won't have this problem no more.
 

·
Registered
Joined
·
11,108 Posts
That's your problem, you've got vacuum issues. Should have done some research before you picked that cam.
 

·
~*~*~*~*~*~*~
Joined
·
10,123 Posts
Discussion Starter #5
What I don't understand is if it is a vacuum issue then why does it only do it when its moist outside. And the motor seems to run great other than this issue. Should I change it to mass air and how hard would that be? What benefits would I get from changing it over besides the stalling problem with the defroster. I will check all the vacuum lines when I get it back from the exhaust shop later today. I'm quite sure that they are all on.
 

·
Satyr of the Midwest
Joined
·
17,734 Posts
Loading an engine with an E303 cam at idle is just asking for Death. Hell, us Mustang guys have a helluva time just getting them to idle all by themselves, even on MAF-equipped 'stangs.

I don't think you need to convert to MA. You need to get that POS camshaft out of there.
 

·
~*~*~*~*~*~*~
Joined
·
10,123 Posts
Discussion Starter #7
Well the cam is going to stay in there because the truck has a whole LOT more power and if this is the only issue then I can live with it. Hell I have no problems with the idle, just on defrost. And to pull the cam back out...... too much time to do it as I'm working 6 days/10 hours.
 

·
crank trigger
Joined
·
8,150 Posts
yank the wire from your ac compressor. still have defrost that way.

also, SD can work with that cam if there is a tweec for it.
 

·
~*~*~*~*~*~*~
Joined
·
10,123 Posts
Discussion Starter #9
So, now its two years later and I have the solution for my problem. The past two years I've had my A/C compresser unpluged. Well, its been hot and I found out a few months after the last post that my compresser was seizing up because the belt would start smoling when the compresser kicked in. So I replaced the compresser a couple weeks ago. I now no longer have this issue. Thought maybe the E-cam was causing this issue but it actually was my compresser dying out. Now I once again can use my A/C and defroster, and not have this issue.
 

·
imdabes
Joined
·
937 Posts
So, now its two years later and I have the solution for my problem. The past two years I've had my A/C compresser unpluged. Well, its been hot and I found out a few months after the last post that my compresser was seizing up because the belt would start smoling when the compresser kicked in. So I replaced the compresser a couple weeks ago. I now no longer have this issue. Thought maybe the E-cam was causing this issue but it actually was my compresser dying out. Now I once again can use my A/C and defroster, and not have this issue.
You sir are my hero. My engine has been dying every time I turn AC on and idle. Engine wont even start with AC on, and it runs fine when I am driving, but first stop I make and go into idle it dies, or when I drop into neutral before a turn or something, etc.

Eh...where/how much did you get yours for?? I think I may unplug it first to see if it stops before replacing it, seems to be 250+ online.\

You may be able to help a guy over in the newb question section who has this same issue (probably)
 

·
~*~*~*~*~*~*~
Joined
·
10,123 Posts
Discussion Starter #11
You sir are my hero. My engine has been dying every time I turn AC on and idle. Engine wont even start with AC on, and it runs fine when I am driving, but first stop I make and go into idle it dies, or when I drop into neutral before a turn or something, etc.

Eh...where/how much did you get yours for?? I think I may unplug it first to see if it stops before replacing it, seems to be 250+ online.\

You may be able to help a guy over in the newb question section who has this same issue (probably)
I got my compresser for right near $250. from O'rielys. Then there oil and R134 to get also.
 

·
imdabes
Joined
·
937 Posts
I got my compresser for right near $250. from O'rielys. Then there oil and R134 to get also.
Ouch, well since I am not in the country, and it will be winter when I get back, and I am using fundage on cooler projects than fixing things, I will just wait and pull out the wire to see if that is actually the problem.
 
1 - 12 of 12 Posts
Top